]> git.pld-linux.org Git - packages/SPE.git/blob - SPE.spec
- BR: rpm-pythonprov
[packages/SPE.git] / SPE.spec
1 # TODO:
2 # - fix %%files (doc to %%doc, no .py, remove unused files)
3 %define _wx     2.6.1.0
4 #
5 Summary:        SPE - Stani's Python Editor
6 Summary(pl.UTF-8):      SPE - pythonowy edytor Staniego
7 Name:           SPE
8 Version:        0.8.2.a
9 Release:        5
10 License:        LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
11 Group:          Applications/Text
12 Source0:        http://download.berlios.de/python/%{name}-%{version}-wx%{_wx}.tar.gz
13 # Source0-md5:  d5d5a55414aa2410ac430f7e79b271e5
14 Source1:        %{name}.desktop
15 Source2:        %{name}.png
16 URL:            http://spe.pycs.net/
17 BuildRequires:  python
18 BuildRequires:  python-devel
19 BuildRequires:  python-modules
20 BuildRequires:  rpm-pythonprov
21 Requires:       pydoc
22 %pyrequires_eq  python-modules
23 Requires:       python-wxPython >= %{_wx}
24 # below is needed - SPE doesn't start without "hacked" release of wxPython (reporting version issue)
25 Requires:       python-wxPython >= 2.6.1.0-3
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Spe is a python IDE with auto-indentation, auto completion, call tips,
31 syntax coloring, syntax highlighting, class explorer, source index,
32 auto todo list, sticky notes, integrated pycrust shell, python file
33 browser, recent file browser, drag&drop, context help, ... Special is
34 its blender support with a blender 3d object browser and its ability
35 to run interactively inside blender. Spe is extensible with boa. 
36
37 %description -l pl.UTF-8
38 Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
39 wykonywaniem wcięć, automatycznym dopełnianiem, podpowiedziami
40 wywołań, kolorowaniem składni, podświetlaniem składni, eksploratorem
41 klas, indeksem źródeł, automatyczną listą TODO, przyklejanymi
42 notatkami, zintegrowaną powłoką pycrust, przeglądarką plików
43 pythonowych, przeglądarką ostatnio używanych plików, obsługą w stylu
44 przeciągnij-i-upuść, pomocą kontekstową... Specjalną rzeczą jest
45 wsparcie dla blendera z przeglądarką obiektów blendera 3D i
46 możliwością automatycznego uruchamiania z poziomu blendera. Spe jest
47 rozszerzalne przy pomocy boa.
48
49 %prep
50 %setup -q -n %{name}-%{version}-wx%{_wx}
51
52 %build
53 python setup.py build
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
58
59 python setup.py install \
60         --optimize=2 \
61         --root=$RPM_BUILD_ROOT
62
63 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
64 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
65
66 # SPE doesn't work without *.py files so don't remove them
67 #%%py_postclean
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.txt
75 %attr(755,root,root) %{_bindir}/*
76 %{py_sitescriptdir}/*
77 %{_desktopdir}/*.desktop
78 %{_pixmapsdir}/*
This page took 0.077312 seconds and 3 git commands to generate.