]> git.pld-linux.org Git - packages/SPE.git/blob - SPE.spec
5f8eee4dc6a3a17226f990b5987970925e8214f4
[packages/SPE.git] / SPE.spec
1 # TODO:
2 # - fix %%files (doc to %%doc, no .py, remove unused files)
3
4 %define _wx     2.5.4.1
5 %define _bl     2.35
6
7 Summary:        SPE - Stani's Python Editor
8 Summary(pl):    SPE - pythonowy edytor Staniego
9 Name:           SPE
10 Version:        0.7.3.a
11 Release:        0.1
12 License:        LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
13 Group:          Applications/Text
14 Source0:        http://projects.blender.org/frs/download.php/271/%{name}-%{version}-wx%{_wx}.-bl%{_bl}.zip
15 # Source0-md5:  52b1d02f179bab7a71b57f5698343230
16 URL:            http://spe.pycs.net/
17 BuildRequires:  python
18 BuildRequires:  python-devel
19 BuildRequires:  python-modules
20 BuildRequires:  unzip
21 %pyrequires_eq  python-modules
22 Requires:       python-wxPython >= %{_wx}
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Spe is a python IDE with auto-indentation, auto completion, call tips,
28 syntax coloring, syntax highlighting, class explorer, source index,
29 auto todo list, sticky notes, integrated pycrust shell, python file
30 browser, recent file browser, drag&drop, context help, ... Special is
31 its blender support with a blender 3d object browser and its ability
32 to run interactively inside blender. Spe is extensible with boa. 
33
34 %description -l pl
35 Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
36 wykonywaniem wciêæ, automatycznym dope³nianiem, podpowiedziami
37 wywo³añ, kolorowaniem sk³adni, pod¶wietlaniem sk³adni, eksploratorem
38 klas, indeksem ¼róde³, automatyczn± list± TODO, przyklejanymi
39 notatkami, zintegrowan± pow³ok± pycrust, przegl±dark± plików
40 pythonowych, przegl±dark± ostatnio u¿ywanych plików, obs³ug± w stylu
41 przeci±gnij-i-upu¶æ, pomoc± kontekstow±... Specjaln± rzecz± jest
42 wsparcie dla blendera z przegl±dark± obiektów blendera 3D i
43 mo¿liwo¶ci± automatycznego uruchamiania z poziomu blendera. Spe jest
44 rozszerzalne przy pomocy boa.
45
46 %prep
47 %setup -q -n %{name}-%{version}-wx%{_wx}.-bl%{_bl}
48
49 %build
50 python setup.py build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 python setup.py install \
56         --optimize=2 \
57         --root=$RPM_BUILD_ROOT
58
59 find $RPM_BUILD_ROOT -name '*.py' -exec rm "{}" ";"
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README.txt
67 %attr(755,root,root) %{_bindir}/*
68 %{py_sitescriptdir}/*
This page took 0.222367 seconds and 2 git commands to generate.