]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- added translations stolen from CNV.
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.2
20 Release:        4
21 License:        LGPL
22 Group:          X11/Libraries
23 Group(de):      X11/Libraries
24 Group(es):      X11/Bibliotecas
25 Group(fr):      X11/Librairies
26 Group(pl):      X11/Biblioteki
27 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
28 Patch0:         %{name}-byteorder.patch
29 Patch1:         %{name}-fixlibs.patch
30 URL:            http://www.libsdl.org/
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 %{!?_without_esound:BuildRequires:      esound-devel}
34 %{!?_without_arts:BuildRequires:        arts-devel}
35 BuildRequires:  gtk+-devel >= 1.2.1
36 BuildRequires:  XFree86-devel >= 4.0.2
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  perl-modules
39 %ifnarch sparc sparc64
40 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
41 %endif
42 %{?_with_svgalib:BuildRequires: svgalib-devel}
43 %{?_with_aalib:BuildRequires:   aalib-devel}
44 %{?_with_ggi:BuildRequires:     libggi-devel}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _prefix         /usr/X11R6
48 %define         _mandir         %{_prefix}/man
49
50 %description
51 SDL (Simple DirectMedia Layer) is a library that allows you portable,
52 low level access to a video framebuffer, audio output, mouse, and
53 keyboard. It can support both windowed and DGA modes of XFree86, and
54 it is designed to be portable - applications linked with SDL can also
55 be built on Win32 and BeOS.
56
57 %description -l pl
58 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
59 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
60 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
61 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
62 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
63
64 %description -l pt_BR
65 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de baixo
66 nível a áudio, teclado, mouse e vídeo em várias plataformas.
67
68 Essa biblioteca é usada por alguns jogos.
69
70 %package devel
71 Summary:        SDL - Header files
72 Summary(pl):    SDL - Pliki nag³ówkowe
73 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
74 Group:          X11/Libraries
75 Group(de):      X11/Libraries
76 Group(es):      X11/Bibliotecas
77 Group(fr):      X11/Librairies
78 Group(pl):      X11/Biblioteki
79 Requires:       %{name} = %{version}
80 %{!?_without_esound:Requires:   esound-devel}
81 %{!?_without_arts:Requires:     arts-devel}
82
83 %description devel
84 SDL - Header files.
85
86 %description -l pl devel
87 SDL - Pliki nag³ówkowe.
88
89 %description -l pt_BR devel
90 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros recursos para o
91 desenvolvimento de aplicativos com SDL.
92
93 %package static
94 Summary:        SDL - static libraries
95 Summary(pl):    SDL - biblioteki statyczne
96 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
97 Group:          X11/Libraries
98 Group(de):      X11/Libraries
99 Group(es):      X11/Bibliotecas
100 Group(fr):      X11/Librairies
101 Group(pl):      X11/Biblioteki
102 Requires:       %{name}-devel = %{version}
103
104 %description static
105 SDL - static libraries.
106
107 %description -l pl static
108 SDL - biblioteki statyczne.
109
110 %description -l pt_BR static
111 Biblioteca estática para desenvolvimento de aplicações com a SDL.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %patch1 -p1
117
118 %build
119 aclocal
120 autoconf
121 automake -a -c
122 %configure \
123 %ifnarch sparc sparc64
124         %{!?_without_alsa:--enable-alsa} \
125 %endif
126         --enable-nasm \
127         --enable-pthreads \
128         --enable-pthread-sem \
129         --with-x \
130         --enable-video-x11-vm \
131         --enable-video-x11-dga \
132         --enable-video-x11-mtrr \
133         --enable-video-x11-dgamouse \
134         --enable-video-opengl \
135         %{!?_without_esound:--enable-esd} \
136         %{!?_without_arts:--enable-arts} \
137         %{?_with_svga:--enable-video-svga} \
138         %{?_with_aalib:--enable-video-aalib} \
139         %{?_with_ggi:--enable-video-ggi}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         m4datadir=%{_aclocaldir}
147
148 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
149
150 gzip -9nf BUGS CREDITS README TODO WhatsNew
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
165 %attr(755,root,root) %{_bindir}/sdl-config
166 %attr(755,root,root) %{_libdir}/lib*.so
167 %attr(755,root,root) %{_libdir}/lib*.la
168 %{_libdir}/libSDLmain.a
169 %{_includedir}/SDL
170 %{_aclocaldir}/*
171 %{_mandir}/man3/*
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/lib*.a
This page took 0.054785 seconds and 3 git commands to generate.