]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- really copy user.js (not from one to itself)
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 # - kde4
3 # - gtk1 no longer updated. drop?
4 # - include /usr/share/themes/QtCurve/mozilla somewhere
5 # - unpackaged:
6 #
7 # Conditional build:
8 %bcond_with     gtk     # build GTK styles
9 %bcond_without  gtk2    # don't build GTK+2 styles
10 #
11 %define         kde_ver         0.55.1
12 %define         gtk2_ver        0.55.1
13 %define         gtk1_ver        0.42.2
14 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
15 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16 Name:           QtCurve
17 Version:        0.55.1
18 Release:        1
19 License:        GPL
20 Group:          Themes
21 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22 # Source0-md5:  1ba394626a40e8926966739500dbf87d
23 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24 # Source1-md5:  0d5eeb45990c3ecf060daa68a2ed2e6f
25 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
27 Patch0: %{name}-Gtk2-userjs.patch
28 URL:            http://www.kde-look.org/content/show.php?content=40492
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  cmake
32 %{?with_gtk:BuildRequires:      gtk+-devel}
33 %{?with_gtk2:BuildRequires:     gtk+2-devel}
34 BuildRequires:  kdelibs-devel >= 3.1
35 BuildRequires:  libtool
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.293
38 BuildRequires:  sed > 4.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A free and corrected port of Red Hat's GTK+/Qt theme.
43
44 %description -l pl.UTF-8
45 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
46
47 %package -n kde-style-QtCurve
48 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
49 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
50 Group:          Themes
51 Requires:       kdelibs >= 3.1
52
53 %description -n kde-style-QtCurve
54 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
55
56 %description -n kde-style-QtCurve -l pl.UTF-8
57 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
58 Wersja pod KDE.
59
60 %package -n gtk-theme-QtCurve
61 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
62 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
63 Group:          Themes
64 Requires:       theme-QtCurve-common = %{version}-%{release}
65
66 %description -n gtk-theme-QtCurve
67 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
68
69 %description -n gtk-theme-QtCurve -l pl.UTF-8
70 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
71 Wersja pod GTK+.
72
73 %package -n gtk2-theme-QtCurve
74 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
75 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
76 Group:          Themes
77 Requires:       theme-QtCurve-common = %{version}-%{release}
78
79 %description -n gtk2-theme-QtCurve
80 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
81
82 %description -n gtk2-theme-QtCurve -l pl.UTF-8
83 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
84 Wersja pod GTK+2.
85
86 %package -n theme-QtCurve-common
87 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
88 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
89 Group:          Themes
90 Obsoletes:      gtk-theme-bluecurve
91 Obsoletes:      gtk2-theme-bluecurve
92 Obsoletes:      kde-style-bluecurve
93 Obsoletes:      kde-theme-bluecurve
94 Obsoletes:      theme-bluecurve-common
95
96 %description -n theme-QtCurve-common
97 A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
98 and common files package.
99
100 %description -n theme-QtCurve-common -l pl.UTF-8
101 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
102 Pakiet z dokumentacja i plikami współdzielonymi.
103
104 %prep
105 %setup -q -c %{?with_gtk2:-a1} %{?with_gtk:-a2}
106 %if %{with gtk2}
107 cd %{name}-Gtk2-%{gtk2_ver}
108 %patch0 -p1
109 cd -
110 %endif
111
112 %build
113 cd %{name}-KDE3-%{kde_ver}
114 %cmake \
115         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
116         .
117 %{__make}
118 cd -
119
120 %if %{with gtk}
121 cd %{name}-Gtk1-%{gtk1_ver}
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure
128 %{__make}
129 cd -
130 %endif
131
132 %if %{with gtk2}
133 cd %{name}-Gtk2-%{gtk2_ver}
134 %cmake \
135         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
136         .
137 %{__make}
138 cd -
139 %endif
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} -C %{name}-KDE3-%{kde_ver} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %if %{with gtk}
148 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
149         DESTDIR=$RPM_BUILD_ROOT
150 %endif
151
152 %if %{with gtk2}
153 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
154         DESTDIR=$RPM_BUILD_ROOT
155 %endif
156
157 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %files -n kde-style-QtCurve
163 %defattr(644,root,root,755)
164 %{_libdir}/kde3/kstyle_qtcurve_config.la
165 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
166 #%{_libdir}/kde3/plugins/styles/*.la
167 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
168 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
169 %{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
170 %{_datadir}/apps/QtCurve
171
172 %if %{with gtk}
173 %files -n gtk-theme-QtCurve
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
176 %{_datadir}/themes/QtCurve/gtk
177 %endif
178
179 %if %{with gtk2}
180 %files -n gtk2-theme-QtCurve
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
183 %{_datadir}/themes/QtCurve/gtk-2.0
184 %{_datadir}/themes/QtCurve/mozilla
185 %endif
186
187 %files -n theme-QtCurve-common
188 %defattr(644,root,root,755)
189 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
190 %dir %{_datadir}/themes/QtCurve
This page took 0.043041 seconds and 3 git commands to generate.