]> git.pld-linux.org Git - packages/OpenCASCADE.git/blob - OpenCASCADE.spec
49e79aad56e5e5c45256d05100a22dddece6b833
[packages/OpenCASCADE.git] / OpenCASCADE.spec
1 #
2 # All modifications and additions to the file contributed by third parties
3 # remain the property of their copyright owners, unless otherwise agreed
4 # upon. The license for this file, and modifications and additions to the
5 # file, is the same license as for the pristine package itself (unless the
6 # license for the pristine package is not an Open Source License, in which
7 # case the license is the MIT License). An "Open Source License" is a
8 # license that conforms to the Open Source Definition (Version 1.9)
9 # published by the Open Source Initiative.
10
11 Summary:        OpenCASCADE CAE platform
12 Name:           OpenCASCADE
13 # The 6.3.1 is a maintenance release, only available for OCC customers
14 Version:        6.3.0
15 Release:         40.3
16 License:        LGPL-like, see http://www.opencascade.org/occ/license/
17 Group:          Applications/Engineering
18 Source0:        http://files.opencascade.com/OCC_6.3_release/%{name}_src.tgz
19 # Source0-md5:  52778127974cb3141c2827f9d40d1f11
20 Patch0:         %{name}6.3.0-obs-check.patch
21 Patch1:         %{name}6.3.0-strcmp.patch
22 Patch2:          OpenCASCADE6.3.0-occ6.3.0.patch
23 Patch3:         %{name}6.3.0-casroot.patch
24 Patch5:          OpenCASCADE6.3.0-tkernel-ld.patch
25 Patch6:          OpenCASCADE6.3.0-mft-disable-mmap.patch
26 Patch7:          OpenCASCADE6.3.0-no-bitmaps-icon.patch
27 Patch8:         %{name}6.3.0-DESTDIR.patch
28 Patch9:          OpenCASCADE6.3.0-maint-mode.patch
29 Patch10:         OpenCASCADE6.3.0-dep-libs.patch
30 Patch11:         OpenCASCADE6.3.0-move-vrml-vis.patch
31 Patch14:         OpenCASCADE6.3.0-wok-install.patch
32 Patch15:         OpenCASCADE6.3.0-udlist.patch
33 Patch16:         OpenCASCADE6.3.0-WOKUnix_FDescr.patch
34 URL:            http://www.opencascade.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  bison
38 BuildRequires:  flex
39 BuildRequires:  java-sun-jdk-base
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool
42 BuildRequires:  Mesa-libGLU-devel
43 BuildRequires:  tk-devel
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXmu-devel
46 BuildRequires:  xorg-proto-xproto-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 OpenCASCADE is a suite for 3D surface and solid modeling, visualization, data
51 exchange and rapid application development.  It is an excellent platform for
52 development of numerical simulation software including CAD/CAM/CAE, AEC and
53 GIS, as well as PDM applications.
54
55 %package libs
56 Summary:        OpenCASCADE shared libraries
57 Group:          Libraries
58
59 %description libs
60 OpenCASCADE shared libraries.
61
62 %package devel
63 Summary:        OpenCASCADE development files
64 Group:          Development/Libraries
65 Requires:       %{name}-libs = %{version}-%{release}
66
67 %description devel
68 OpenCASCADE development files.
69
70 %package doc
71 Summary:        OpenCASCADE documentation
72 Group:          Documentation
73
74 %description doc
75 OpenCASCADE help and html documentation.
76
77 %package samples
78 Summary:        OpenCASCADE samples
79 Group:          Documentation
80
81 %description samples
82 OpenCASCADE samples.
83
84 %prep
85 %setup -q -n %{name}%{version}
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch5 -p1
91 %patch6 -p1
92 %patch7 -p1
93 %patch8 -p1
94 %patch9 -p1
95 %patch10 -p1
96 %patch11 -p1
97 %patch14 -p1
98 %patch15 -p1
99 %patch16 -p1
100 cd ros/src/ExprIntrp
101 bison -d -p ExprIntrp -o ExprIntrp.tab.c ExprIntrp.yacc
102 flex -L -8 -Cf -Cr -P ExprIntrp -o lex.ExprIntrp.c ExprIntrp.lex
103 mv ExprIntrp.tab.h ../../inc/
104 cp ExprIntrp.tab.c lex.ExprIntrp.c ../../drv/ExprIntrp/
105
106 %build
107 cd ros
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113
114 %ifarch x86_64 ppc64
115 export CFLAGS="%{rpmcflags} -D_OCC64 -fno-strict-aliasing"
116 export CXXFLAGS="%{rpmcflags} -D_OCC64 -fno-strict-aliasing"
117 %else
118 export CFLAGS="%{rpmcflags} -fno-strict-aliasing"
119 export CXXFLAGS="%{rpmcflags} -fno-strict-aliasing"
120 %endif
121 LDFLAGS=-lpthread %configure \
122         %{?debug:--disable-production  --enable-debug} \
123         %{!?debug:--enable-production --disable-debug} \
124         --with-java-include="%{java_home}"/include
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_includedir}}
131
132 cd ros
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135 cd ..
136
137 cp -a data $RPM_BUILD_ROOT%{_datadir}/%{name}
138 mv $RPM_BUILD_ROOT{%{_prefix}/{src,wok,config.h,env_DRAW.sh},%{_datadir}/%{name}}
139 mv $RPM_BUILD_ROOT{%{_prefix}/inc,%{_includedir}/%{name}}
140 rm -r $RPM_BUILD_ROOT%{_prefix}/{Linux,lin}
141
142 mkdir -p $RPM_BUILD_ROOT/usr/src
143 for i in doc samples; do
144 mkdir -p $i-i
145 [ -d $i ] && mv $i $i-i/%{name}-%{version} || :
146 done
147 ln -s %{_builddir}/%{name}%{version}/doc-i   $RPM_BUILD_ROOT%{_defaultdocdir}
148 ln -s %{_builddir}/%{name}%{version}/samples-i $RPM_BUILD_ROOT%{_examplesdir}
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc ros/README.txt
159 %attr(755,root,root) %{_bindir}/DRAWEXE
160 %attr(755,root,root) %{_bindir}/wok*
161 %dir %{_datadir}/%{name}
162 %{_datadir}/%{name}/config.h
163 %{_datadir}/%{name}/data
164 %attr(755,root,root) %{_datadir}/%{name}/env_DRAW.sh
165 %dir %{_datadir}/%{name}/src
166 %dir %{_datadir}/%{name}/src/UnitsAPI
167 %{_datadir}/%{name}/src/UnitsAPI/*.dat
168 %{_datadir}/%{name}/wok
169
170 %files libs
171 %defattr(644,root,root,755)
172 %doc LICENSE
173 %attr(755,root,root) %{_libdir}/*.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/*.so.0
175
176 %files devel
177 %defattr(644,root,root,755)
178 %{_includedir}/%{name}
179 %{_libdir}/*.la
180 %attr(755,root,root) %{_libdir}/*.so
181 %{_datadir}/%{name}/src/*
182 %exclude %{_datadir}/%{name}/src/UnitsAPI/*.dat
183
184 %files doc
185 %defattr(644,root,root,755)
186 %{_docdir}/%{name}-%{version}
187
188 %files samples
189 %defattr(644,root,root,755)
190 %{_examplesdir}/%{name}-%{version}
This page took 0.128211 seconds and 2 git commands to generate.