]> git.pld-linux.org Git - packages/ORBit2.git/blob - ORBit2.spec
rebuild with separate debuginfo build-ids
[packages/ORBit2.git] / ORBit2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # gtk-doc based API documentation
4 %bcond_without  static_libs     # static libraries
5
6 Summary:        High-performance CORBA Object Request Broker
7 Summary(fr.UTF-8):      Requète d'Objects CORBA
8 Summary(pl.UTF-8):      Wysoko wydajny CORBA Object Request Broker
9 Name:           ORBit2
10 Version:        2.14.19
11 Release:        11
12 Epoch:          1
13 License:        GPL v2+/LGPL v2+
14 Group:          Libraries
15 Source0:        https://download.gnome.org/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
16 # Source0-md5:  7082d317a9573ab338302243082d10d1
17 Patch1:         %{name}-build-fix.patch
18 Patch2:         %{name}-idl-gtk-doc.patch
19 URL:            https://developer.gnome.org/ORBit2/
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  docbook-dtd412-xml
23 BuildRequires:  flex
24 BuildRequires:  glib2-devel >= 1:2.14.1
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
26 BuildRequires:  indent
27 BuildRequires:  libIDL-devel >= 0.8.10
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig >= 1:0.18
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  rpmbuild(macros) >= 1.197
32 Requires:       glib2 >= 1:2.14.1
33 Requires:       libIDL >= 0.8.10
34 Provides:       linc = 1.1.1
35 Obsoletes:      ORBit2-automake < 1:2.12.5
36 Obsoletes:      libORBit2_0
37 Obsoletes:      linc
38 Conflicts:      libbonobo < 2.3.2
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 ORBit is a high-performance CORBA (Common Object Request Broker
43 Architecture) ORB (object request broker). It allows programs to send
44 requests and receive replies from other programs, regardless of the
45 locations of the two programs. CORBA is an architecture that enables
46 communication between program objects, regardless of the programming
47 language they're written in or the operating system they run on.
48
49 %description -l fr.UTF-8
50 ORBit est un ORB CORBA avec support pour le language C. Il permet a
51 des programmes d'envoyer des requètes et recevoir de réponses d'autres
52 programmes, indépendement de l'endroit ou sont les deux programmes.
53
54 %description -l pl.UTF-8
55 ORBit to wysokiej wydajności CORBA (Common Object Request Broker
56 Architecture) ORB (object request broker). Pozwala na wysyłanie próśb
57 i otrzymywanie odpowiedzi od innych programów bez znajomości położenia
58 tych dwóch programów.
59
60 %package apidocs
61 Summary:        ORBit API documentation
62 Summary(pl.UTF-8):      Dokumentacja API ORBit
63 Group:          Documentation
64 Requires:       gtk-doc-common
65 BuildArch:      noarch
66
67 %description apidocs
68 ORBit API documentation.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API ORBit.
72
73 %package devel
74 Summary:        Header files, and utilities for ORBit
75 Summary(fr.UTF-8):      Librairies statiques et fichiers entête pour ORBit
76 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla ORBit
77 Group:          Development/Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79 Requires:       glib2-devel >= 1:2.14.1
80 Requires:       indent
81 Requires:       libIDL-devel >= 0.8.10
82 Provides:       linc-devel = 1.1.1
83 Obsoletes:      libORBit2_0-devel
84 Obsoletes:      linc-devel
85
86 %description devel
87 devel ORBit is a high-performance CORBA ORB with support for the C
88 language. It allows programs to send requests and receive replies from
89 other programs, regardless of the locations of the two programs.
90
91 This package includes the header files and utilities neecessary to
92 write programs that use CORBA technology.
93
94 %description devel -l fr.UTF-8
95 Librairies statiques et fichiers entête requis pour le development ou
96 la compilation de programmes utilisant ORBit.
97
98 %description devel -l pl.UTF-8
99 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
100 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
101 programów bez znajomości położenia tych dwóch programów.
102
103 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
104 programów używających technologi CORBA.
105
106 %package static
107 Summary:        Static libraries for ORBit
108 Summary(pl.UTF-8):      Biblioteki statyczne dla ORBit
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
111 Provides:       linc-static = 1.1.1
112 Obsoletes:      linc-static
113
114 %description static
115 ORBit is a high-performance CORBA ORB with support for the C language.
116 It allows programs to send requests and receive replies from other
117 programs, regardless of the locations of the two programs.
118
119 This package includes static libraries neecessary to write programs
120 statically linked that use CORBA technology.
121
122 %description static -l pl.UTF-8
123 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
124 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
125 programów bez znajomości położenia tych dwóch programów.
126
127 Ten pakiet zawiera biblioteki statyczne potrzebne do pisania programów
128 skonsolidowanych statycznie używających technologii CORBA.
129
130 %prep
131 %setup -q
132 %patch1 -p1
133 %patch2 -p1
134
135 %if %{without apidocs}
136 echo 'EXTRA_DIST=' > gtk-doc.make
137 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
138 %endif
139
140 %build
141 %{?with_apidocs:%{__gtkdocize}}
142 %{__libtoolize}
143 %{__aclocal}
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 %configure \
148         --with-html-dir=%{_gtkdocdir} \
149         %{!?with_static_libs:--disable-static} \
150         %{?with_apidocs:--enable-gtk-doc}
151 %{__make} -j1
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} -j1 install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 # obsoleted by pkg-config
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
161 # no static module - shut up check-files
162 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.la
163 %if %{with static_libs}
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.a
165 %endif
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc AUTHORS NEWS README
176 %attr(755,root,root) %{_bindir}/ior-decode-2
177 %attr(755,root,root) %{_bindir}/linc-cleanup-sockets
178 %attr(755,root,root) %{_bindir}/orbit-idl-2
179 %attr(755,root,root) %{_bindir}/typelib-dump
180 %attr(755,root,root) %{_libdir}/libORBit-2.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libORBit-2.so.0
182 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libORBit-imodule-2.so.0
184 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libORBitCosNaming-2.so.0
186 %dir %{_libdir}/orbit-2.0
187 %attr(755,root,root) %{_libdir}/orbit-2.0/Everything_module.so
188 %{_datadir}/idl/orbit-2.0
189
190 %if %{with apidocs}
191 %files apidocs
192 %defattr(644,root,root,755)
193 %{_gtkdocdir}/%{name}
194 %endif
195
196 %files devel
197 %defattr(644,root,root,755)
198 %doc ChangeLog
199 %attr(755,root,root) %{_bindir}/orbit2-config
200 %attr(755,root,root) %{_libdir}/libORBit-2.so
201 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
202 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
203 # static-only library
204 %{_libdir}/libname-server-2.a
205 %{_includedir}/orbit-2.0
206 %{_pkgconfigdir}/ORBit-2.0.pc
207 %{_pkgconfigdir}/ORBit-CosNaming-2.0.pc
208 %{_pkgconfigdir}/ORBit-idl-2.0.pc
209 %{_pkgconfigdir}/ORBit-imodule-2.0.pc
210 %{_aclocaldir}/ORBit2.m4
211
212 %if %{with static_libs}
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libORBit-2.a
216 %{_libdir}/libORBit-imodule-2.a
217 %{_libdir}/libORBitCosNaming-2.a
218 %endif
This page took 0.118721 seconds and 3 git commands to generate.