]> git.pld-linux.org Git - packages/MHonArc.git/commitdiff
- updated to 2.6.19 (security fix from 2014) master auto/th/MHonArc-2.6.19-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 20 Apr 2024 05:40:37 +0000 (07:40 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 20 Apr 2024 05:40:37 +0000 (07:40 +0200)
MHonArc-FHS2.patch
MHonArc.spec

index bf58a62e27f5a1306ee9a44cd0cc2c48a5e77ffb..16f55d00a52e6b78b0cef7f1f9458d8023a8794f 100644 (file)
@@ -10,30 +10,28 @@ diff -urN MHonArc2.4.2.orig/mha-dbedit MHonArc2.4.2/mha-dbedit
  
      ## Initialize MHonArc
      require 'mhamain.pl' || die qq/ERROR: Unable to require "mhamain.pl"\n/;
-diff -urN MHonArc2.4.2.orig/mha-dbrecover MHonArc2.4.2/mha-dbrecover
---- MHonArc2.4.2.orig/mha-dbrecover    Thu Aug 12 17:37:46 1999
-+++ MHonArc2.4.2/mha-dbrecover Thu Aug 12 17:38:35 1999
-@@ -33,7 +33,7 @@
+--- MHonArc-2.6.19/mha-dbrecover.orig  2024-04-20 07:24:49.052203467 +0200
++++ MHonArc-2.6.19/mha-dbrecover       2024-04-20 07:28:10.667777889 +0200
+@@ -35,7 +35,7 @@ use Getopt::Long;
  ##---------------------------------------------------------------------------##
  
  MAIN: {
 -    unshift(@INC, 'lib');     # Should I leave this line in?
 +    unshift(@INC, '/usr/share/MHonArc');      # Should I leave this line in?
  
-     ## Initialize MHonArc
-     require 'mhamain.pl' || die qq/ERROR: Unable to require "mhamain.pl"\n/;
-diff -urN MHonArc2.4.2.orig/mha-decode MHonArc2.4.2/mha-decode
---- MHonArc2.4.2.orig/mha-decode       Thu Aug 12 17:37:46 1999
-+++ MHonArc2.4.2/mha-decode    Thu Aug 12 17:38:45 1999
-@@ -33,7 +33,7 @@
+     ## Grab options from @ARGV unique to this program
+     my %opts = ( );
+--- MHonArc-2.6.19/mha-decode.orig     2024-04-20 07:24:49.052203467 +0200
++++ MHonArc-2.6.19/mha-decode  2024-04-20 07:28:37.270967100 +0200
+@@ -35,7 +35,7 @@ use Getopt::Long;
  ##---------------------------------------------------------------------------##
  
  MAIN: {
 -    unshift(@INC, 'lib');     # Should I leave this line in?
 +    unshift(@INC, '/usr/share/MHonArc');      # Should I leave this line in?
  
-     ## Initialize MHonArc
-     require 'mhamain.pl' || die qq/ERROR: Unable to require "mhamain.pl"\n/;
+     ## Grab options from @ARGV unique to this program
+     my %opts = ( );
 diff -urN MHonArc2.4.2.orig/mhonarc MHonArc2.4.2/mhonarc
 --- MHonArc2.4.2.orig/mhonarc  Thu Aug 12 17:37:46 1999
 +++ MHonArc2.4.2/mhonarc       Thu Aug 12 17:39:20 1999
index 9de1a899a7f7af55901262480891e0ca85a43705..60e1710620eb2261605dde865248d0a9151e113d 100644 (file)
@@ -1,15 +1,16 @@
 Summary:       An Email-to-HTML converter
 Summary(pl.UTF-8):     Konwerter Poczta->HTML
 Name:          MHonArc
-Version:       2.6.18
+Version:       2.6.19
 Release:       1
-License:       GPL
+License:       GPL v2+
 Group:         Applications/Mail
-Source0:       http://www.mhonarc.org/release/MHonArc/tar/%{name}-%{version}.tar.bz2
-# Source0-md5: c3eaec31467b3cc5bae751fb68080742
+Source0:       https://www.mhonarc.org/release/MHonArc/tar/%{name}-%{version}.tar.bz2
+# Source0-md5: 6e74712a6da370c8c63b5bde7573f48f
 Patch0:                %{name}-FHS2.patch
-URL:           http://www.mhonarc.org/
+URL:           https://www.mhonarc.org/
 BuildRequires: rpm-perlprov
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRequires: sed >= 4.0
 Requires:      perl-Unicode-MapUTF8
 Requires:      perl-Unicode-String
@@ -26,20 +27,24 @@ customization features.
 %description -l pl.UTF-8
 MHonArc to konwerter poczta->HTML napisany w Perlu. MHonArc pozwala na
 archiwizowanie poczty w postaci stron HTML z indeksowaniem według
-wątku. MHonArc wspiera MIME oraz łatwo przystosowuje się do wymagań
+wątku. MHonArc obsługuje MIME oraz łatwo przystosowuje się do wymagań
 użytkownika.
 
 %prep
 %setup -q
-%{__sed} -i -e 's,^#!.*bin/perl5\?,#!%{__perl},' $(grep -rl '^#!.*/bin/perl' .)
 %patch0 -p1
 
+# some files have /usr/local/bin/perl or /net/nf/bin/perl
+%{__sed} -i -e '1s,^#!.*bin/perl5\?,#!%{__perl},' $(grep -rl '^#!.*/bin/perl' .)
+
 %build
 %{__perl} Makefile.PL
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__perl} install.me \
        -batch \
        -nodoc \
@@ -53,7 +58,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc doc examples extras logo admin ACKNOWLG BUGS CHANGES RELNOTES
-%attr(755,root,root) %{_bindir}/*
+%doc ACKNOWLG BUGS CHANGES README.txt RELNOTES TODO admin doc examples extras logo
+%attr(755,root,root) %{_bindir}/mha-dbedit
+%attr(755,root,root) %{_bindir}/mha-dbrecover
+%attr(755,root,root) %{_bindir}/mha-decode
+%attr(755,root,root) %{_bindir}/mhonarc
 %{_datadir}/%{name}
-%{_mandir}/man?/*
+%{_mandir}/man1/mha-dbedit.1*
+%{_mandir}/man1/mha-dbrecover.1*
+%{_mandir}/man1/mha-decode.1*
+%{_mandir}/man1/mhonarc.1*
This page took 0.207455 seconds and 4 git commands to generate.