]> git.pld-linux.org Git - packages/KoboDeluxe.git/commitdiff
- added gcc44.patch and nostd_pipe2.patch
authorSzymon Siwek <sls@pld-linux.org>
Mon, 24 May 2010 17:44:32 +0000 (17:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    KoboDeluxe.spec -> 1.14
    gcc44.patch -> 1.1
    nostd_pipe2.patch -> 1.1

KoboDeluxe.spec
gcc44.patch [new file with mode: 0644]
nostd_pipe2.patch [new file with mode: 0644]

index 7519de9c95835b96612f322d51853f9bc012ef5c..b6a3323bda7ead4bbe877cd0bdcf52030d7b22a5 100644 (file)
@@ -1,4 +1,4 @@
-# $Revision: 1.13 $, $Dat: 2003/08/04 19:06:42 $
+# $Revision: 1.14 $, $Dat: 2003/08/04 19:06:42 $
 Summary:       A third person scrolling 2D shooter
 Summary(pl.UTF-8):     Prosta strzelanka 2D
 Name:          KoboDeluxe
@@ -11,6 +11,8 @@ Group:                X11/Applications/Games
 Source0:       http://olofson.net/kobodl/download/%{name}-%{version}.tar.bz2
 # Source0-md5: cb5dcdaf07ccad18a921058138dedc4a
 Patch0:                kobousr2var.patch
+Patch1:                gcc44.patch
+Patch2:                nostd_pipe2.patch
 URL:           http://olofson.net/kobodl/
 BuildRequires: SDL-devel >= 1.2
 BuildRequires: SDL_image-devel >= 1.2
@@ -42,6 +44,8 @@ potrzebujesz różnych taktyk.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
diff --git a/gcc44.patch b/gcc44.patch
new file mode 100644 (file)
index 0000000..34129e6
--- /dev/null
@@ -0,0 +1,11 @@
+--- KoboDeluxe-0.5.1/graphics/window.cpp.orig  2010-05-24 18:48:48.024498000 +0200
++++ KoboDeluxe-0.5.1/graphics/window.cpp       2010-05-24 18:48:58.684496628 +0200
+@@ -398,7 +398,7 @@ void window_t::center_token_fxp(int _x, 
+                */
+               if(token)
+               {
+-                      char *tok = strchr(txt, token);
++                      const char *tok = strchr(txt, token);
+                       if(tok)
+                               tokpos = tok-txt;
+                       else
diff --git a/nostd_pipe2.patch b/nostd_pipe2.patch
new file mode 100644 (file)
index 0000000..ca9f5a4
--- /dev/null
@@ -0,0 +1,62 @@
+--- KoboDeluxe-0.5.1/enemies.h.orig    2010-05-24 18:53:21.647803692 +0200
++++ KoboDeluxe-0.5.1/enemies.h 2010-05-24 18:54:37.847056344 +0200
+@@ -72,7 +72,7 @@ extern const enemy_kind bombdeto;
+ extern const enemy_kind cannon;
+ extern const enemy_kind pipe1;
+ extern const enemy_kind core;
+-extern const enemy_kind pipe2;
++extern const enemy_kind kobo_pipe2;
+ extern const enemy_kind rock;
+ extern const enemy_kind ring;
+ extern const enemy_kind enemy_m1;
+@@ -430,7 +430,7 @@ inline int _enemy::realize()
+ inline int _enemy::is_pipe()
+ {
+-      return ((_state != notuse) && ((ek == &pipe1) || (ek == &pipe2)));
++      return ((_state != notuse) && ((ek == &pipe1) || (ek == &kobo_pipe2)));
+ }
+--- KoboDeluxe-0.5.1/enemy.cpp.orig    2010-05-24 19:04:08.577739047 +0200
++++ KoboDeluxe-0.5.1/enemy.cpp 2010-05-24 19:04:48.070235366 +0200
+@@ -755,10 +755,10 @@ void _enemy::move_core()
+ void _enemy::kill_core()
+ {
+-      enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
+-      enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
+-      enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
+-      enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
++      enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
++      enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
++      enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
++      enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
+       enemies.make(&explosion4, CS2PIXEL(x), CS2PIXEL(y));
+       sound.g_base_core_explo(x, y);
+       release();
+@@ -978,19 +978,19 @@ void _enemy::move_pipe2()
+       }
+       p ^= a;
+       if(p & U_MASK)
+-              enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
++              enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
+       if(p & R_MASK)
+-              enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
++              enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
+       if(p & D_MASK)
+-              enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
++              enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
+       if(p & L_MASK)
+-              enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
++              enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
+       manage.add_score(10);
+       release();
+ }
+-const enemy_kind pipe2 = {
++const enemy_kind kobo_pipe2 = {
+       0,
+       &_enemy::make_pipe2,
+       &_enemy::move_pipe2,
This page took 0.064391 seconds and 4 git commands to generate.