]> git.pld-linux.org Git - packages/FreeImage.git/commitdiff
- added libwebp-cpp patch (fix preprocessor tokens in internal libwebp); release 2 auto/th/FreeImage-3.17.0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 23 May 2016 18:38:22 +0000 (20:38 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 23 May 2016 18:38:22 +0000 (20:38 +0200)
FreeImage-libwebp-cpp.patch [new file with mode: 0644]
FreeImage.spec

diff --git a/FreeImage-libwebp-cpp.patch b/FreeImage-libwebp-cpp.patch
new file mode 100644 (file)
index 0000000..1c17869
--- /dev/null
@@ -0,0 +1,42 @@
+--- FreeImage/Source/LibWebP/src/dsp/dsp.upsampling_mips_dsp_r2.c.orig 2015-02-20 03:34:36.000000000 +0100
++++ FreeImage/Source/LibWebP/src/dsp/dsp.upsampling_mips_dsp_r2.c      2016-05-23 15:13:46.386879788 +0200
+@@ -34,15 +34,15 @@
+     G = G - t2 + kGCst;                                                        \\r
+     B = B + kBCst;                                                             \\r
+     __asm__ volatile (                                                         \\r
+-      "shll_s.w         %["#R"],      %["#R"],        9              \n\t"     \\r
+-      "shll_s.w         %["#G"],      %["#G"],        9              \n\t"     \\r
+-      "shll_s.w         %["#B"],      %["#B"],        9              \n\t"     \\r
+-      "precrqu_s.qb.ph  %["#R"],      %["#R"],        $zero          \n\t"     \\r
+-      "precrqu_s.qb.ph  %["#G"],      %["#G"],        $zero          \n\t"     \\r
+-      "precrqu_s.qb.ph  %["#B"],      %["#B"],        $zero          \n\t"     \\r
+-      "srl              %["#R"],      %["#R"],        24             \n\t"     \\r
+-      "srl              %["#G"],      %["#G"],        24             \n\t"     \\r
+-      "srl              %["#B"],      %["#B"],        24             \n\t"     \\r
++      "shll_s.w         %[" #R "],      %[" #R "],        9              \n\t"     \\r
++      "shll_s.w         %[" #G "],      %[" #G "],        9              \n\t"     \\r
++      "shll_s.w         %[" #B "],      %[" #B "],        9              \n\t"     \\r
++      "precrqu_s.qb.ph  %[" #R "],      %[" #R "],        $zero          \n\t"     \\r
++      "precrqu_s.qb.ph  %[" #G "],      %[" #G "],        $zero          \n\t"     \\r
++      "precrqu_s.qb.ph  %[" #B "],      %[" #B "],        $zero          \n\t"     \\r
++      "srl              %[" #R "],      %[" #R "],        24             \n\t"     \\r
++      "srl              %[" #G "],      %[" #G "],        24             \n\t"     \\r
++      "srl              %[" #B "],      %[" #B "],        24             \n\t"     \\r
+       : [R]"+r"(R), [G]"+r"(G), [B]"+r"(B)                                     \\r
+       :                                                                        \\r
+     );                                                                         \\r
+--- FreeImage/Source/LibWebP/src/dsp/dsp.yuv_mips_dsp_r2.c.orig        2015-02-20 03:34:38.000000000 +0100
++++ FreeImage/Source/LibWebP/src/dsp/dsp.yuv_mips_dsp_r2.c     2016-05-23 15:15:34.452490572 +0200
+@@ -54,9 +54,9 @@
+   "srl              %[temp5],   %[temp5],       24              \n\t"          \\r
+   "srl              %[temp6],   %[temp6],       24              \n\t"          \\r
+   "srl              %[temp7],   %[temp7],       24              \n\t"          \\r
+-  "sb               %[temp5],   "#R"(%[dst])                    \n\t"          \\r
+-  "sb               %[temp6],   "#G"(%[dst])                    \n\t"          \\r
+-  "sb               %[temp7],   "#B"(%[dst])                    \n\t"          \\r
++  "sb               %[temp5],   " #R "(%[dst])                    \n\t"          \\r
++  "sb               %[temp6],   " #G "(%[dst])                    \n\t"          \\r
++  "sb               %[temp7],   " #B "(%[dst])                    \n\t"          \\r
\r
+ #define ASM_CLOBBER_LIST()                                                     \\r
+   : [temp0]"=&r"(temp0), [temp1]"=&r"(temp1), [temp2]"=&r"(temp2),             \\r
index ee3f5a0417640ed2b7f227ceb7ff3fe86c75ef16..0e4acd9008969659f6d0ff70ab90d9fdcaa52d8b 100644 (file)
@@ -13,13 +13,14 @@ Summary:    Library for handling different graphics files formats
 Summary(pl.UTF-8):     Biblioteka do manipulacji różnymi formatami plików graficznych
 Name:          FreeImage
 Version:       3.17.0
-Release:       1
+Release:       2
 License:       GPL and FIPL v1.0 (see the license-fi.txt)
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/freeimage/%{name}%{fver}.zip
 # Source0-md5: 459e15f0ec75d6efa3c7bd63277ead86
 Source1:       http://downloads.sourceforge.net/freeimage/%{name}%{fver}.pdf
 # Source1-md5: 9d7e12d5062b51082407a6d69aa7d020
+Patch0:                %{name}-libwebp-cpp.patch
 URL:           http://freeimage.sourceforge.net/index.html
 BuildRequires: libstdc++-devel
 BuildRequires: unzip
@@ -63,6 +64,7 @@ Statyczna biblioteka FreeImage.
 
 %prep
 %setup -q -n %{name}
+%patch0 -p1
 
 %build
 CFLAGS="%{rpmcflags} -fPIC -fvisibility=hidden" \
This page took 0.059356 seconds and 4 git commands to generate.