]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
- fix building with ffmpeg 4.0 auto/th/DirectFB-1.7.7-4
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 28 Apr 2018 23:49:33 +0000 (01:49 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 28 Apr 2018 23:49:33 +0000 (01:49 +0200)
- rel 4

DirectFB.spec
ffmpeg4.patch [new file with mode: 0644]

index aad4c823027f24ae75d5131dda3304dfc318adb0..d8e2a22d4c4fdc999b6737aabf89cabe8066caa9 100644 (file)
@@ -25,7 +25,7 @@ Summary:      DirectFB - Hardware graphics acceleration
 Summary(pl.UTF-8):     DirectFB - Wspomaganie grafiki
 Name:          DirectFB
 Version:       1.7.7
-Release:       3
+Release:       4
 Epoch:         1
 License:       LGPL v2+
 Group:         Libraries
@@ -52,6 +52,7 @@ Patch12:      x32-asm.patch
 Patch13:       ffmpeg3.patch
 Patch14:       %{name}-tslib.patch
 Patch15:       %{name}-libtimidity.patch
+Patch16:       ffmpeg4.patch
 URL:           http://www.directfb.net/
 BuildRequires: Mesa-libEGL-devel
 BuildRequires: Mesa-libGLES-devel
@@ -949,6 +950,7 @@ Statyczna biblioteka sawman.
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
 
 # video drivers
 %{__sed} -i -e 's/checkfor_\(cle266\|cyber5k\|radeon\|savage\|unichrome\|vmware\)=no/checkfor_\1=yes/' configure.in
diff --git a/ffmpeg4.patch b/ffmpeg4.patch
new file mode 100644 (file)
index 0000000..386b430
--- /dev/null
@@ -0,0 +1,22 @@
+--- DirectFB-1.7.7/interfaces/IDirectFBImageProvider/idirectfbimageprovider_ffmpeg.c~
++++ DirectFB-1.7.7/interfaces/IDirectFBImageProvider/idirectfbimageprovider_ffmpeg.c
+@@ -300,7 +300,7 @@ IDirectFBImageProvider_FFMPEG_RenderTo( IDirectFBImageProvider *thiz,
+      av_pkt.data = comp_data_buffer;
+      /*We don't pass complete frames*/
+-     av_codec_ctx->flags |= CODEC_FLAG_TRUNCATED;
++     av_codec_ctx->flags |= AV_CODEC_FLAG_TRUNCATED;
+      do
+      {
+--- DirectFB-1.7.7/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_ffmpeg.c~  2018-04-29 01:34:51.000000000 +0200
++++ DirectFB-1.7.7/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_ffmpeg.c   2018-04-29 01:44:29.654235050 +0200
+@@ -549,7 +549,7 @@
+           }
+           
+           if (av_read_frame( data->context, &packet ) < 0) {
+-               if (url_feof( data->context->pb )) {
++               if (avio_feof( data->context->pb )) {
+                     if (data->input.buffering) {
+                          pthread_mutex_unlock( &data->audio.queue.lock ); 
+                          pthread_mutex_unlock( &data->video.queue.lock );
This page took 0.053871 seconds and 4 git commands to generate.