]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
rediff patches
authorJan Palus <atler@pld-linux.org>
Tue, 7 Jun 2022 10:35:02 +0000 (12:35 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 7 Jun 2022 10:35:02 +0000 (12:35 +0200)
DirectFB-fix.patch
DirectFB-pmake.patch
DirectFB-zlib.patch

index 5bf271e79f7351d666f3f801bfd030b45879e6d4..6ad4719d43806ca0082e1548641c1eaba57ea051 100644 (file)
@@ -2,24 +2,24 @@
 +++ DirectFB-0.9.21/gfxdrivers/cle266/Makefile.am      2005-01-15 15:07:27.813759856 +0100
 @@ -32,7 +32,7 @@
  libdirectfb_cle266_la_LDFLAGS = \
-       -export-dynamic         \
+       -module                 \
        -avoid-version          \
 -      $(DFB_LDFLAGS)
 +      $(DFB_LDFLAGS) -lm
  
- include $(top_srcdir)/rules/libobject.make
+ libdirectfb_cle266_la_LIBADD = \
+       -lm \
 --- DirectFB-0.9.21/gfxdrivers/unichrome/Makefile.am.orig      2004-10-09 01:48:19.000000000 +0200
 +++ DirectFB-0.9.21/gfxdrivers/unichrome/Makefile.am   2005-01-15 15:07:38.104195472 +0100
 @@ -34,7 +34,7 @@
  libdirectfb_unichrome_la_LDFLAGS = \
-       -export-dynamic            \
+       -module                    \
        -avoid-version             \
 -      $(DFB_LDFLAGS)
 +      $(DFB_LDFLAGS) -lm
  
- include $(top_srcdir)/rules/libobject.make
+ libdirectfb_unichrome_la_LIBADD = \
+       $(top_builddir)/lib/direct/libdirect.la \
 --- DirectFB-1.0.0.orig/include/dfb_types.h    2007-03-03 21:36:07.000000000 +0100
 +++ DirectFB-1.0.0/include/dfb_types.h 2007-03-09 12:20:59.000000000 +0100
 @@ -29,6 +29,7 @@
@@ -27,9 +27,9 @@
  #define __DFB_TYPES_H__
  
 +#include <asm/types.h>
+ #include <direct/types.h>
  
- #ifdef USE_KOS
+ #ifdef WIN32
 --- DirectFB-1.6.0/interfaces/IDirectFBImageProvider/Makefile.am.orig  2012-06-14 18:00:08.000000000 +0200
 +++ DirectFB-1.6.0/interfaces/IDirectFBImageProvider/Makefile.am       2012-06-17 19:13:20.781373488 +0200
 @@ -115,6 +115,7 @@
index a0b8d7cc648ab4cd230b32be1410ef8c49c3d34a..b46d58907685db550c9ff5a356e21469f1b92bb5 100644 (file)
@@ -2,7 +2,7 @@ diff -aurN DirectFB-0.9.19.orig/src/Makefile.am DirectFB-0.9.19/src/Makefile.am
 --- DirectFB-0.9.19.orig/src/Makefile.am       2003-07-02 04:22:25.000000000 +0200
 +++ DirectFB-0.9.19/src/Makefile.am    2003-07-21 21:31:00.000000000 +0200
 @@ -59,7 +59,8 @@
-       cp -af libdirectfb_fixed.a .libs/libdirectfb.a
+       cp -pf libdirectfb_fixed.a .libs/libdirectfb.a
  
  .libs/libdirectfb.a: libdirectfb.la
 -
index e0cafc22272bae255b3712fb507ee4f7bf504228..3dc74e99ce0fe5065d2f1069404867955f9c6481 100644 (file)
@@ -8,5 +8,5 @@
 +#include <zlib.h>
 +#endif
  
- D_DEBUG_DOMAIN( Core_Surface, "Core/Surface", "DirectFB Core Surface" );
+ D_DEBUG_DOMAIN( Core_Surface,         "Core/Surface",         "DirectFB Core Surface" );
+ D_DEBUG_DOMAIN( Core_Surface_Updates, "Core/Surface/Updates", "DirectFB Core Surface Updates" );
This page took 0.074923 seconds and 4 git commands to generate.