]> git.pld-linux.org Git - packages/DiVine.git/commitdiff
- updated to 1.6.3 auto/th/DiVine-1.6.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Jan 2013 18:18:34 +0000 (19:18 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Jan 2013 18:18:34 +0000 (19:18 +0100)
- added missing patch (missing file from git)

DiVine-missing.patch [new file with mode: 0644]
DiVine.spec

diff --git a/DiVine-missing.patch b/DiVine-missing.patch
new file mode 100644 (file)
index 0000000..f88d114
--- /dev/null
@@ -0,0 +1,53 @@
+--- DiVine-1.6.3/lib/idivine.h.orig    1970-01-01 01:00:00.000000000 +0100
++++ DiVine-1.6.3/lib/idivine.h 2013-01-19 19:14:42.934224700 +0100
+@@ -0,0 +1,50 @@
++/*
++   (c) Copyright 2001-2009  The world wide DirectFB Open Source Community (directfb.org)
++   (c) Copyright 2000-2004  Convergence (integrated media) GmbH
++
++   All rights reserved.
++
++   Written by Denis Oliver Kropp <dok@directfb.org>,
++              Andreas Hundt <andi@fischlustig.de>,
++              Sven Neumann <neo@directfb.org>,
++              Ville Syrjälä <syrjala@sci.fi> and
++              Claudio Ciccani <klan@users.sf.net>.
++
++   This library is free software; you can redistribute it and/or
++   modify it under the terms of the GNU Lesser General Public
++   License as published by the Free Software Foundation; either
++   version 2 of the License, or (at your option) any later version.
++
++   This library is distributed in the hope that it will be useful,
++   but WITHOUT ANY WARRANTY; without even the implied warranty of
++   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
++   Lesser General Public License for more details.
++
++   You should have received a copy of the GNU Lesser General Public
++   License along with this library; if not, write to the
++   Free Software Foundation, Inc., 59 Temple Place - Suite 330,
++   Boston, MA 02111-1307, USA.
++*/
++
++#ifndef __IDIVINE_H__
++#define __IDIVINE_H__
++
++#include <divine.h>
++
++/*
++ * private data struct of IDiVine
++ */
++typedef struct {
++     int                         ref;      /* reference counter */
++
++     DiVine                     *divine;
++} IDiVine_data;
++
++/*
++ * IDiVine constructor/destructor
++ */
++DFBResult IDiVine_Construct( IDiVine *thiz );
++
++void      IDiVine_Destruct ( IDiVine *thiz );
++
++#endif
index f0bc116afdd7fd8c2874d7350dc87d5b0706d5a1..4a8304a5dfffa991e0506de6f3567c508bd7cddf 100644 (file)
@@ -1,16 +1,17 @@
 Summary:       DirectFB Virtual Input extension
 Summary(pl.UTF-8):     Rozszerzenie DirectFB o wirtualne wejście
 Name:          DiVine
-Version:       0.4.0
+Version:       1.6.3
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://www.directfb.org/downloads/Extras/%{name}-%{version}.tar.gz
-# Source0-md5: 6c1147d186e421f707afd48403749364
+# Source0-md5: a5a08ef9197bf32c8bc6b030f96f2103
+Patch0:                %{name}-missing.patch
 URL:           http://www.directfb.org/
-BuildRequires: DirectFB-devel >= 1:1.2.0
+BuildRequires: DirectFB-devel >= 1:1.6.0
 BuildRequires: pkgconfig >= 1:0.9
-%requires_eq   DirectFB
+Requires:      DirectFB >= 1:1.6.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -23,7 +24,6 @@ DiVine consists of:
   script featuring button or motion events, linear or circular
   automated motion and delays.
 
-
 %description -l pl.UTF-8
 DiVine składa się z:
 - sterownika wejścia czytającego surowe zdarzenia wejściowe z potoku
@@ -39,7 +39,7 @@ Summary:      Header files for divine library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki divine
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      DirectFB-devel >= 1:1.0.0
+Requires:      DirectFB-devel >= 1:1.6.0
 
 %description devel
 Header files for divine library.
@@ -61,6 +61,7 @@ Statyczna biblioteka divine.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure \
@@ -83,9 +84,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
 %attr(755,root,root) %{_bindir}/spooky
-%attr(755,root,root) %{_libdir}/libdivine-0.4.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libdivine-0.4.so.0
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/inputdrivers/libdirectfb_divine.so
+%attr(755,root,root) %{_libdir}/libdivine-1.6.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdivine-1.6.so.0
+%attr(755,root,root) %{_libdir}/directfb-1.6-0/inputdrivers/libdirectfb_divine.so
+%dir %{_libdir}/directfb-1.6-0/interfaces/IDiVine
+%attr(755,root,root) %{_libdir}/directfb-1.6-0/interfaces/IDiVine/libidivine_dispatcher.so
+%attr(755,root,root) %{_libdir}/directfb-1.6-0/interfaces/IDiVine/libidivine_requestor.so
 
 %files devel
 %defattr(644,root,root,755)
@@ -98,4 +102,6 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libdivine.a
-%{_libdir}/directfb-1.2-0/inputdrivers/libdirectfb_divine.[aol]*
+%{_libdir}/directfb-1.6-0/inputdrivers/libdirectfb_divine.[aol]*
+%{_libdir}/directfb-1.6-0/interfaces/IDiVine/libidivine_dispatcher.[aol]*
+%{_libdir}/directfb-1.6-0/interfaces/IDiVine/libidivine_requestor.[aol]*
This page took 0.103229 seconds and 4 git commands to generate.