]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- initial release
[packages/Atlas-C++.git] / Atlas-C++.spec
1 Summary:        C++ reference implementation of the Atlas protocol
2 Summary(pl):    Implementacja protoko³u Atlas
3 Name:           Atlas-C++
4 Version:        0.4.4
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Group(de):      Libraries
9 Group(es):      Bibliotecas
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Group(pt_BR):   Bibliotecas
13 Group(ru):      âÉÂÌÉÏÔÅËÉ
14 Group(uk):      â¦Â̦ÏÔÅËÉ
15 Source0:        ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/%{name}-%{version}.tar.gz
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  libstdc++-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
24 communications layer designed to be used in the WorldForge MMORPG
25 gaming system. This library is suitable for linking to either clients
26 or servers.
27
28 %description -l pl
29 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
30 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
31 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
32
33 %package devel
34 Summary:        Header files and libraries for Atlas-C++ development
35 Group:          Development/Libraries
36 Group(de):      Entwicklung/Libraries
37 Group(es):      Desarrollo/Bibliotecas
38 Group(fr):      Development/Librairies
39 Group(pl):      Programowanie/Biblioteki
40 Group(pt_BR):   Desenvolvimento/Bibliotecas
41 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
42 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
43 Requires:       %{name} = %{version}
44 Requires:       libstdc++-devel
45
46 %description devel
47 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
48 communications layer designed to be used in the WorldForge MMORPG
49 gaming system. This library is suitable for linking to either clients
50 or servers.
51
52 This package contains the header files needed to develop programs that
53 use these Atlas-C++
54
55 %description devel -l pl
56 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
57 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
58 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
59
60 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
61 u¿ywaj±cych bibliotek Atlas-C++.
62
63 %package static
64 Summary:        Static libraries for Atlas-C++ development
65 Group:          Development/Libraries
66 Group(de):      Entwicklung/Libraries
67 Group(es):      Desarrollo/Bibliotecas
68 Group(fr):      Development/Librairies
69 Group(pl):      Programowanie/Biblioteki
70 Group(pt_BR):   Desenvolvimento/Bibliotecas
71 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
72 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
77 communications layer designed to be used in the WorldForge MMORPG
78 gaming system. This library is suitable for linking to either clients
79 or servers.
80
81 This package contains the static Atlas-C++ libraries.
82
83 %description static -l pl
84 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
85 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
86 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
87
88 Pakiet zawiera statyczne biblioteki Atlas-C++.
89
90 %prep
91 %setup -q
92
93 %build
94 aclocal
95 autoheader
96 libtoolize --automake --copy --force
97 automake --add-missing --copy --gnu --force
98 autoconf
99 %configure
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install DESTDIR=$RPM_BUILD_ROOT
106
107 gzip -9nf AUTHORS ChangeLog NEWS README
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc *.gz
115 %{_libdir}/lib*.so.1
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/atlas-config
121 %{_includedir}/Atlas
122 %attr(755,root,root) %{_libdir}/lib*.la
123 %{_libdir}/lib*.so
124 %{_aclocaldir}/atlas.m4
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/lib*.a
This page took 0.134535 seconds and 4 git commands to generate.