]> git.pld-linux.org Git - packages/strigi.git/blame - strigi.spec
- added gccversion, includes patches (allow build with gcc up to 12); release 15
[packages/strigi.git] / strigi.spec
CommitLineData
1253c3bb 1#
6a7d7a23
ER
2# Conditional build:
3%bcond_without dbus # dbus support
4#
64e6c73a 5%define qtver 4.6.3
9897709b 6
493bcf16 7Summary: Strigi desktop search
abba28fc 8Summary(pl.UTF-8): System wyszukiwania Strigi
1253c3bb 9Name: strigi
cfce5085 10Version: 0.7.8
b4637576 11Release: 15
4a9fce3d 12License: LGPL v2+
1253c3bb 13Group: X11/Applications
cfce5085
AM
14Source0: http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
15# Source0-md5: d69443234f4286d71997db9de543331a
845404c3
JR
16Patch0: %{name}-as-needed.patch
17Patch1: ffmpeg3.patch
c732e135 18Patch2: gcc7.patch
3a3e482a 19Patch3: ffmpeg4.patch
da2080a9 20Patch4: gcc8.patch
6a993bac 21Patch5: exiv2.patch
b4637576
JB
22Patch6: %{name}-gccversion.patch
23Patch7: %{name}-includes.patch
1becfb15 24URL: http://strigi.sourceforge.net/
9897709b 25BuildRequires: QtDBus-devel >= %{qtver}
26BuildRequires: QtGui-devel >= %{qtver}
4a9fce3d 27BuildRequires: attr-devel
6a7d7a23 28BuildRequires: bzip2-devel
4a9fce3d
JB
29BuildRequires: clucene-core-devel >= 0.9.21
30BuildRequires: cmake >= 2.8.9
f331c639 31BuildRequires: cppunit-devel
6a7d7a23 32%{?with_dbus:BuildRequires: dbus-devel >= 1.0}
c732e135 33%{?with_dbus:BuildRequires: dbus-x11 >= 1.0}
2027d9a2 34BuildRequires: exiv2-devel >= 0.21
6a7d7a23 35BuildRequires: expat-devel
9b415f88 36BuildRequires: fam-devel
44a8c079 37BuildRequires: ffmpeg-devel
e7233fa1 38BuildRequires: libstdc++-devel
4a9fce3d 39BuildRequires: libxml2-devel >= 2
b7b1af67 40BuildRequires: log4cxx-devel
9b415f88 41%{?with_dbus:BuildRequires: pkgconfig}
9897709b 42BuildRequires: qt4-build >= %{qtver}
43BuildRequires: qt4-qmake >= %{qtver}
4a9fce3d 44BuildRequires: rpmbuild(macros) >= 1.605
6a7d7a23 45BuildRequires: zlib-devel
e7233fa1
JB
46Requires: QtDBus >= %{qtver}
47Requires: QtGui >= %{qtver}
48Requires: clucene-core >= 0.9.21
49%{?with_dbus:Requires: dbus-libs >= 1.0}
50Requires: exiv2-libs >= 0.21
1253c3bb 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
abba28fc
JB
54Here are the main features of Strigi Desktop Search: very fast
55crawling, very small memory footprint, no hammering of the system,
56pluggable backend (currently clucene and hyperestraier, sqlite3 and
57xapian are in the works), communication between daemon and search
58program over an abstract interface with two implementations: DBus and
b25c5eb4 59a simple Unix socket. Especially the DBus interface makes it very easy
abba28fc
JB
60to write client applications. There are a few sample scripts in the
61code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
62any GNOME or KDE app could implement this. Additionally, there is a
63simple interface for implementing plugins for extracting information.
64We'll try to reuse the kat plugins, although native plugins will have
65a large speed advantage. Strigi also has calculation of sha1 for every
66file crawled which allows for fast finding of duplicate files.
493bcf16 67
abba28fc
JB
68%description -l pl.UTF-8
69Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
70przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
71backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
72i xapian w trakcie rozwoju), komunikacja między demonem a programem
73wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
74DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
75ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
76skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
77klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
78zaimplementować. Ponadto istnieje prosty interfejs do implementowania
79wtyczek do wydobywania informacji. Autorzy będą próbowali
80wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
81szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
82pliku, co pozwala na szybkie znajdowanie duplikatów.
1253c3bb 83
84%package devel
493bcf16 85Summary: Header files for strigi
86Summary(pl.UTF-8): Pliki nagłówkowe dla strigi
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
e7233fa1 89Requires: libstdc++-devel
1253c3bb 90
91%description devel
92Header files for strigi.
93
94%description devel -l pl.UTF-8
95Pliki nagłówkowe dla strigi.
96
97%prep
98%setup -q
845404c3 99%patch0 -p1
acbb9c35 100%patch1 -p1
c732e135 101%patch2 -p1
3a3e482a 102%patch3 -p1
da2080a9 103%patch4 -p1
6a993bac 104%patch5 -p1
b4637576
JB
105%patch6 -p1
106%patch7 -p1
1253c3bb 107
108%build
109install -d build
110cd build
4a9fce3d
JB
111# note: package expects relative CMAKE_INSTALL_LIBDIR
112%cmake .. \
cfce5085 113 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
130bea1a 114 -DFORCE_DEPS=1 \
b7b1af67 115 -DENABLE_FAM=1 \
4a9fce3d
JB
116 -DENABLE_INOTIFY=1 \
117 -DENABLE_LOG4CXX=1
1253c3bb 118
119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
abba28fc
JB
123
124%{__make} -C build install \
1253c3bb 125 DESTDIR=$RPM_BUILD_ROOT
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(644,root,root,755)
4a9fce3d
JB
135%doc AUTHORS ChangeLog
136%attr(755,root,root) %{_bindir}/deepfind
137%attr(755,root,root) %{_bindir}/deepgrep
138%attr(755,root,root) %{_bindir}/lucene2indexer
139%attr(755,root,root) %{_bindir}/rdfindexer
140%attr(755,root,root) %{_bindir}/strigiclient
141%attr(755,root,root) %{_bindir}/strigicmd
142%attr(755,root,root) %{_bindir}/strigidaemon
143%attr(755,root,root) %{_bindir}/xmlindexer
3b877464 144%attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
f29c8e58 145%attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
4a9fce3d 146%attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
a52c8172 147%attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
4a9fce3d 148%attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
a52c8172 149%attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
4a9fce3d 150%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
f29c8e58 151%attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
4a9fce3d 152%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
f29c8e58
JB
153%attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
154%dir %{_libdir}/strigi
155%attr(755,root,root) %{_libdir}/strigi/*.so
4a9fce3d
JB
156%{?with_dbus:%{_datadir}/dbus-1/services/org.freedesktop.xesam.searcher.service}
157%{?with_dbus:%{_datadir}/dbus-1/services/vandenoever.strigi.service}
a52c8172
JB
158%dir %{_datadir}/strigi
159%{_datadir}/strigi/fieldproperties
1253c3bb 160
161%files devel
162%defattr(644,root,root,755)
3b877464 163%attr(755,root,root) %{_libdir}/libsearchclient.so
a52c8172
JB
164%attr(755,root,root) %{_libdir}/libstreamanalyzer.so
165%attr(755,root,root) %{_libdir}/libstreams.so
3b877464
RT
166%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
167%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
31d6d646 168%dir %{_libdir}/cmake/Strigi
cfce5085
AM
169%{_libdir}/cmake/Strigi/*.cmake
170%dir %{_libdir}/cmake/LibSearchClient
171%{_libdir}/cmake/LibSearchClient/LibSearchClientConfig.cmake
172%dir %{_libdir}/cmake/LibStreamAnalyzer
173%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
174%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
175%dir %{_libdir}/cmake/LibStreams
176%{_libdir}/cmake/LibStreams/LibStreamsConfig.cmake
177%{_libdir}/cmake/LibStreams/LibStreamsConfigVersion.cmake
178%{_libdir}/cmake/LibStreams/LibStreamsTargets-pld.cmake
179%{_libdir}/cmake/LibStreams/LibStreamsTargets.cmake
1253c3bb 180%dir %{_includedir}/strigi
181%{_includedir}/strigi/*.h
3b877464 182%{_includedir}/strigi/qtdbus
a52c8172
JB
183%{_pkgconfigdir}/libstreamanalyzer.pc
184%{_pkgconfigdir}/libstreams.pc
This page took 0.290381 seconds and 4 git commands to generate.