]> git.pld-linux.org Git - packages/strigi.git/blame - strigi.spec
- rebuild with exiv2 0.26
[packages/strigi.git] / strigi.spec
CommitLineData
1253c3bb 1#
6a7d7a23
ER
2# Conditional build:
3%bcond_without dbus # dbus support
4#
64e6c73a 5%define qtver 4.6.3
9897709b 6
493bcf16 7Summary: Strigi desktop search
abba28fc 8Summary(pl.UTF-8): System wyszukiwania Strigi
1253c3bb 9Name: strigi
cfce5085 10Version: 0.7.8
8e55e367 11Release: 9
4a9fce3d 12License: LGPL v2+
1253c3bb 13Group: X11/Applications
cfce5085
AM
14Source0: http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
15# Source0-md5: d69443234f4286d71997db9de543331a
845404c3
JR
16Patch0: %{name}-as-needed.patch
17Patch1: ffmpeg3.patch
1becfb15 18URL: http://strigi.sourceforge.net/
9897709b 19BuildRequires: QtDBus-devel >= %{qtver}
20BuildRequires: QtGui-devel >= %{qtver}
4a9fce3d 21BuildRequires: attr-devel
6a7d7a23 22BuildRequires: bzip2-devel
4a9fce3d
JB
23BuildRequires: clucene-core-devel >= 0.9.21
24BuildRequires: cmake >= 2.8.9
f331c639 25BuildRequires: cppunit-devel
6a7d7a23 26%{?with_dbus:BuildRequires: dbus-devel >= 1.0}
2027d9a2 27BuildRequires: exiv2-devel >= 0.21
6a7d7a23 28BuildRequires: expat-devel
9b415f88 29BuildRequires: fam-devel
44a8c079 30BuildRequires: ffmpeg-devel
e7233fa1 31BuildRequires: libstdc++-devel
4a9fce3d 32BuildRequires: libxml2-devel >= 2
b7b1af67 33BuildRequires: log4cxx-devel
9b415f88 34%{?with_dbus:BuildRequires: pkgconfig}
9897709b 35BuildRequires: qt4-build >= %{qtver}
36BuildRequires: qt4-qmake >= %{qtver}
4a9fce3d 37BuildRequires: rpmbuild(macros) >= 1.605
6a7d7a23 38BuildRequires: zlib-devel
e7233fa1
JB
39Requires: QtDBus >= %{qtver}
40Requires: QtGui >= %{qtver}
41Requires: clucene-core >= 0.9.21
42%{?with_dbus:Requires: dbus-libs >= 1.0}
43Requires: exiv2-libs >= 0.21
1253c3bb 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
abba28fc
JB
47Here are the main features of Strigi Desktop Search: very fast
48crawling, very small memory footprint, no hammering of the system,
49pluggable backend (currently clucene and hyperestraier, sqlite3 and
50xapian are in the works), communication between daemon and search
51program over an abstract interface with two implementations: DBus and
b25c5eb4 52a simple Unix socket. Especially the DBus interface makes it very easy
abba28fc
JB
53to write client applications. There are a few sample scripts in the
54code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
55any GNOME or KDE app could implement this. Additionally, there is a
56simple interface for implementing plugins for extracting information.
57We'll try to reuse the kat plugins, although native plugins will have
58a large speed advantage. Strigi also has calculation of sha1 for every
59file crawled which allows for fast finding of duplicate files.
493bcf16 60
abba28fc
JB
61%description -l pl.UTF-8
62Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
63przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
64backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
65i xapian w trakcie rozwoju), komunikacja między demonem a programem
66wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
67DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
68ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
69skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
70klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
71zaimplementować. Ponadto istnieje prosty interfejs do implementowania
72wtyczek do wydobywania informacji. Autorzy będą próbowali
73wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
74szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
75pliku, co pozwala na szybkie znajdowanie duplikatów.
1253c3bb 76
77%package devel
493bcf16 78Summary: Header files for strigi
79Summary(pl.UTF-8): Pliki nagłówkowe dla strigi
80Group: Development/Libraries
81Requires: %{name} = %{version}-%{release}
e7233fa1 82Requires: libstdc++-devel
1253c3bb 83
84%description devel
85Header files for strigi.
86
87%description devel -l pl.UTF-8
88Pliki nagłówkowe dla strigi.
89
90%prep
91%setup -q
845404c3 92%patch0 -p1
acbb9c35 93%patch1 -p1
1253c3bb 94
95%build
96install -d build
97cd build
4a9fce3d
JB
98# note: package expects relative CMAKE_INSTALL_LIBDIR
99%cmake .. \
cfce5085 100 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
130bea1a 101 -DFORCE_DEPS=1 \
b7b1af67 102 -DENABLE_FAM=1 \
4a9fce3d
JB
103 -DENABLE_INOTIFY=1 \
104 -DENABLE_LOG4CXX=1
1253c3bb 105
106%{__make}
107
108%install
109rm -rf $RPM_BUILD_ROOT
abba28fc
JB
110
111%{__make} -C build install \
1253c3bb 112 DESTDIR=$RPM_BUILD_ROOT
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119
120%files
121%defattr(644,root,root,755)
4a9fce3d
JB
122%doc AUTHORS ChangeLog
123%attr(755,root,root) %{_bindir}/deepfind
124%attr(755,root,root) %{_bindir}/deepgrep
125%attr(755,root,root) %{_bindir}/lucene2indexer
126%attr(755,root,root) %{_bindir}/rdfindexer
127%attr(755,root,root) %{_bindir}/strigiclient
128%attr(755,root,root) %{_bindir}/strigicmd
129%attr(755,root,root) %{_bindir}/strigidaemon
130%attr(755,root,root) %{_bindir}/xmlindexer
3b877464 131%attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
f29c8e58 132%attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
4a9fce3d 133%attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
a52c8172 134%attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
4a9fce3d 135%attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
a52c8172 136%attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
4a9fce3d 137%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
f29c8e58 138%attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
4a9fce3d 139%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
f29c8e58
JB
140%attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
141%dir %{_libdir}/strigi
142%attr(755,root,root) %{_libdir}/strigi/*.so
4a9fce3d
JB
143%{?with_dbus:%{_datadir}/dbus-1/services/org.freedesktop.xesam.searcher.service}
144%{?with_dbus:%{_datadir}/dbus-1/services/vandenoever.strigi.service}
a52c8172
JB
145%dir %{_datadir}/strigi
146%{_datadir}/strigi/fieldproperties
1253c3bb 147
148%files devel
149%defattr(644,root,root,755)
3b877464 150%attr(755,root,root) %{_libdir}/libsearchclient.so
a52c8172
JB
151%attr(755,root,root) %{_libdir}/libstreamanalyzer.so
152%attr(755,root,root) %{_libdir}/libstreams.so
3b877464
RT
153%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
154%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
31d6d646 155%dir %{_libdir}/cmake/Strigi
cfce5085
AM
156%{_libdir}/cmake/Strigi/*.cmake
157%dir %{_libdir}/cmake/LibSearchClient
158%{_libdir}/cmake/LibSearchClient/LibSearchClientConfig.cmake
159%dir %{_libdir}/cmake/LibStreamAnalyzer
160%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
161%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
162%dir %{_libdir}/cmake/LibStreams
163%{_libdir}/cmake/LibStreams/LibStreamsConfig.cmake
164%{_libdir}/cmake/LibStreams/LibStreamsConfigVersion.cmake
165%{_libdir}/cmake/LibStreams/LibStreamsTargets-pld.cmake
166%{_libdir}/cmake/LibStreams/LibStreamsTargets.cmake
1253c3bb 167%dir %{_includedir}/strigi
168%{_includedir}/strigi/*.h
3b877464 169%{_includedir}/strigi/qtdbus
a52c8172
JB
170%{_pkgconfigdir}/libstreamanalyzer.pc
171%{_pkgconfigdir}/libstreams.pc
This page took 0.08893 seconds and 4 git commands to generate.