]> git.pld-linux.org Git - packages/strigi.git/blame - strigi.spec
- fix building with ffmpeg 4.0
[packages/strigi.git] / strigi.spec
CommitLineData
1253c3bb 1#
6a7d7a23
ER
2# Conditional build:
3%bcond_without dbus # dbus support
4#
64e6c73a 5%define qtver 4.6.3
9897709b 6
493bcf16 7Summary: Strigi desktop search
abba28fc 8Summary(pl.UTF-8): System wyszukiwania Strigi
1253c3bb 9Name: strigi
cfce5085 10Version: 0.7.8
3a3e482a 11Release: 11
4a9fce3d 12License: LGPL v2+
1253c3bb 13Group: X11/Applications
cfce5085
AM
14Source0: http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
15# Source0-md5: d69443234f4286d71997db9de543331a
845404c3
JR
16Patch0: %{name}-as-needed.patch
17Patch1: ffmpeg3.patch
c732e135 18Patch2: gcc7.patch
3a3e482a 19Patch3: ffmpeg4.patch
1becfb15 20URL: http://strigi.sourceforge.net/
9897709b 21BuildRequires: QtDBus-devel >= %{qtver}
22BuildRequires: QtGui-devel >= %{qtver}
4a9fce3d 23BuildRequires: attr-devel
6a7d7a23 24BuildRequires: bzip2-devel
4a9fce3d
JB
25BuildRequires: clucene-core-devel >= 0.9.21
26BuildRequires: cmake >= 2.8.9
f331c639 27BuildRequires: cppunit-devel
6a7d7a23 28%{?with_dbus:BuildRequires: dbus-devel >= 1.0}
c732e135 29%{?with_dbus:BuildRequires: dbus-x11 >= 1.0}
2027d9a2 30BuildRequires: exiv2-devel >= 0.21
6a7d7a23 31BuildRequires: expat-devel
9b415f88 32BuildRequires: fam-devel
44a8c079 33BuildRequires: ffmpeg-devel
e7233fa1 34BuildRequires: libstdc++-devel
4a9fce3d 35BuildRequires: libxml2-devel >= 2
b7b1af67 36BuildRequires: log4cxx-devel
9b415f88 37%{?with_dbus:BuildRequires: pkgconfig}
9897709b 38BuildRequires: qt4-build >= %{qtver}
39BuildRequires: qt4-qmake >= %{qtver}
4a9fce3d 40BuildRequires: rpmbuild(macros) >= 1.605
6a7d7a23 41BuildRequires: zlib-devel
e7233fa1
JB
42Requires: QtDBus >= %{qtver}
43Requires: QtGui >= %{qtver}
44Requires: clucene-core >= 0.9.21
45%{?with_dbus:Requires: dbus-libs >= 1.0}
46Requires: exiv2-libs >= 0.21
1253c3bb 47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
abba28fc
JB
50Here are the main features of Strigi Desktop Search: very fast
51crawling, very small memory footprint, no hammering of the system,
52pluggable backend (currently clucene and hyperestraier, sqlite3 and
53xapian are in the works), communication between daemon and search
54program over an abstract interface with two implementations: DBus and
b25c5eb4 55a simple Unix socket. Especially the DBus interface makes it very easy
abba28fc
JB
56to write client applications. There are a few sample scripts in the
57code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
58any GNOME or KDE app could implement this. Additionally, there is a
59simple interface for implementing plugins for extracting information.
60We'll try to reuse the kat plugins, although native plugins will have
61a large speed advantage. Strigi also has calculation of sha1 for every
62file crawled which allows for fast finding of duplicate files.
493bcf16 63
abba28fc
JB
64%description -l pl.UTF-8
65Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
66przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
67backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
68i xapian w trakcie rozwoju), komunikacja między demonem a programem
69wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
70DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
71ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
72skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
73klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
74zaimplementować. Ponadto istnieje prosty interfejs do implementowania
75wtyczek do wydobywania informacji. Autorzy będą próbowali
76wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
77szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
78pliku, co pozwala na szybkie znajdowanie duplikatów.
1253c3bb 79
80%package devel
493bcf16 81Summary: Header files for strigi
82Summary(pl.UTF-8): Pliki nagłówkowe dla strigi
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
e7233fa1 85Requires: libstdc++-devel
1253c3bb 86
87%description devel
88Header files for strigi.
89
90%description devel -l pl.UTF-8
91Pliki nagłówkowe dla strigi.
92
93%prep
94%setup -q
845404c3 95%patch0 -p1
acbb9c35 96%patch1 -p1
c732e135 97%patch2 -p1
3a3e482a 98%patch3 -p1
1253c3bb 99
100%build
101install -d build
102cd build
4a9fce3d
JB
103# note: package expects relative CMAKE_INSTALL_LIBDIR
104%cmake .. \
cfce5085 105 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
130bea1a 106 -DFORCE_DEPS=1 \
b7b1af67 107 -DENABLE_FAM=1 \
4a9fce3d
JB
108 -DENABLE_INOTIFY=1 \
109 -DENABLE_LOG4CXX=1
1253c3bb 110
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
abba28fc
JB
115
116%{__make} -C build install \
1253c3bb 117 DESTDIR=$RPM_BUILD_ROOT
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(644,root,root,755)
4a9fce3d
JB
127%doc AUTHORS ChangeLog
128%attr(755,root,root) %{_bindir}/deepfind
129%attr(755,root,root) %{_bindir}/deepgrep
130%attr(755,root,root) %{_bindir}/lucene2indexer
131%attr(755,root,root) %{_bindir}/rdfindexer
132%attr(755,root,root) %{_bindir}/strigiclient
133%attr(755,root,root) %{_bindir}/strigicmd
134%attr(755,root,root) %{_bindir}/strigidaemon
135%attr(755,root,root) %{_bindir}/xmlindexer
3b877464 136%attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
f29c8e58 137%attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
4a9fce3d 138%attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
a52c8172 139%attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
4a9fce3d 140%attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
a52c8172 141%attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
4a9fce3d 142%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
f29c8e58 143%attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
4a9fce3d 144%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
f29c8e58
JB
145%attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
146%dir %{_libdir}/strigi
147%attr(755,root,root) %{_libdir}/strigi/*.so
4a9fce3d
JB
148%{?with_dbus:%{_datadir}/dbus-1/services/org.freedesktop.xesam.searcher.service}
149%{?with_dbus:%{_datadir}/dbus-1/services/vandenoever.strigi.service}
a52c8172
JB
150%dir %{_datadir}/strigi
151%{_datadir}/strigi/fieldproperties
1253c3bb 152
153%files devel
154%defattr(644,root,root,755)
3b877464 155%attr(755,root,root) %{_libdir}/libsearchclient.so
a52c8172
JB
156%attr(755,root,root) %{_libdir}/libstreamanalyzer.so
157%attr(755,root,root) %{_libdir}/libstreams.so
3b877464
RT
158%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
159%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
31d6d646 160%dir %{_libdir}/cmake/Strigi
cfce5085
AM
161%{_libdir}/cmake/Strigi/*.cmake
162%dir %{_libdir}/cmake/LibSearchClient
163%{_libdir}/cmake/LibSearchClient/LibSearchClientConfig.cmake
164%dir %{_libdir}/cmake/LibStreamAnalyzer
165%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
166%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
167%dir %{_libdir}/cmake/LibStreams
168%{_libdir}/cmake/LibStreams/LibStreamsConfig.cmake
169%{_libdir}/cmake/LibStreams/LibStreamsConfigVersion.cmake
170%{_libdir}/cmake/LibStreams/LibStreamsTargets-pld.cmake
171%{_libdir}/cmake/LibStreams/LibStreamsTargets.cmake
1253c3bb 172%dir %{_includedir}/strigi
173%{_includedir}/strigi/*.h
3b877464 174%{_includedir}/strigi/qtdbus
a52c8172
JB
175%{_pkgconfigdir}/libstreamanalyzer.pc
176%{_pkgconfigdir}/libstreams.pc
This page took 0.118382 seconds and 4 git commands to generate.