]> git.pld-linux.org Git - packages/strigi.git/blame - strigi.spec
Release 14 (by relup.sh)
[packages/strigi.git] / strigi.spec
CommitLineData
1253c3bb 1#
6a7d7a23
ER
2# Conditional build:
3%bcond_without dbus # dbus support
4#
64e6c73a 5%define qtver 4.6.3
9897709b 6
493bcf16 7Summary: Strigi desktop search
abba28fc 8Summary(pl.UTF-8): System wyszukiwania Strigi
1253c3bb 9Name: strigi
cfce5085 10Version: 0.7.8
00a0041b 11Release: 14
4a9fce3d 12License: LGPL v2+
1253c3bb 13Group: X11/Applications
cfce5085
AM
14Source0: http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
15# Source0-md5: d69443234f4286d71997db9de543331a
845404c3
JR
16Patch0: %{name}-as-needed.patch
17Patch1: ffmpeg3.patch
c732e135 18Patch2: gcc7.patch
3a3e482a 19Patch3: ffmpeg4.patch
da2080a9 20Patch4: gcc8.patch
6a993bac 21Patch5: exiv2.patch
1becfb15 22URL: http://strigi.sourceforge.net/
9897709b 23BuildRequires: QtDBus-devel >= %{qtver}
24BuildRequires: QtGui-devel >= %{qtver}
4a9fce3d 25BuildRequires: attr-devel
6a7d7a23 26BuildRequires: bzip2-devel
4a9fce3d
JB
27BuildRequires: clucene-core-devel >= 0.9.21
28BuildRequires: cmake >= 2.8.9
f331c639 29BuildRequires: cppunit-devel
6a7d7a23 30%{?with_dbus:BuildRequires: dbus-devel >= 1.0}
c732e135 31%{?with_dbus:BuildRequires: dbus-x11 >= 1.0}
2027d9a2 32BuildRequires: exiv2-devel >= 0.21
6a7d7a23 33BuildRequires: expat-devel
9b415f88 34BuildRequires: fam-devel
44a8c079 35BuildRequires: ffmpeg-devel
e7233fa1 36BuildRequires: libstdc++-devel
4a9fce3d 37BuildRequires: libxml2-devel >= 2
b7b1af67 38BuildRequires: log4cxx-devel
9b415f88 39%{?with_dbus:BuildRequires: pkgconfig}
9897709b 40BuildRequires: qt4-build >= %{qtver}
41BuildRequires: qt4-qmake >= %{qtver}
4a9fce3d 42BuildRequires: rpmbuild(macros) >= 1.605
6a7d7a23 43BuildRequires: zlib-devel
e7233fa1
JB
44Requires: QtDBus >= %{qtver}
45Requires: QtGui >= %{qtver}
46Requires: clucene-core >= 0.9.21
47%{?with_dbus:Requires: dbus-libs >= 1.0}
48Requires: exiv2-libs >= 0.21
1253c3bb 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
abba28fc
JB
52Here are the main features of Strigi Desktop Search: very fast
53crawling, very small memory footprint, no hammering of the system,
54pluggable backend (currently clucene and hyperestraier, sqlite3 and
55xapian are in the works), communication between daemon and search
56program over an abstract interface with two implementations: DBus and
b25c5eb4 57a simple Unix socket. Especially the DBus interface makes it very easy
abba28fc
JB
58to write client applications. There are a few sample scripts in the
59code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
60any GNOME or KDE app could implement this. Additionally, there is a
61simple interface for implementing plugins for extracting information.
62We'll try to reuse the kat plugins, although native plugins will have
63a large speed advantage. Strigi also has calculation of sha1 for every
64file crawled which allows for fast finding of duplicate files.
493bcf16 65
abba28fc
JB
66%description -l pl.UTF-8
67Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
68przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
69backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
70i xapian w trakcie rozwoju), komunikacja między demonem a programem
71wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
72DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
73ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
74skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
75klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
76zaimplementować. Ponadto istnieje prosty interfejs do implementowania
77wtyczek do wydobywania informacji. Autorzy będą próbowali
78wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
79szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
80pliku, co pozwala na szybkie znajdowanie duplikatów.
1253c3bb 81
82%package devel
493bcf16 83Summary: Header files for strigi
84Summary(pl.UTF-8): Pliki nagłówkowe dla strigi
85Group: Development/Libraries
86Requires: %{name} = %{version}-%{release}
e7233fa1 87Requires: libstdc++-devel
1253c3bb 88
89%description devel
90Header files for strigi.
91
92%description devel -l pl.UTF-8
93Pliki nagłówkowe dla strigi.
94
95%prep
96%setup -q
845404c3 97%patch0 -p1
acbb9c35 98%patch1 -p1
c732e135 99%patch2 -p1
3a3e482a 100%patch3 -p1
da2080a9 101%patch4 -p1
6a993bac 102%patch5 -p1
1253c3bb 103
104%build
105install -d build
106cd build
4a9fce3d
JB
107# note: package expects relative CMAKE_INSTALL_LIBDIR
108%cmake .. \
cfce5085 109 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
130bea1a 110 -DFORCE_DEPS=1 \
b7b1af67 111 -DENABLE_FAM=1 \
4a9fce3d
JB
112 -DENABLE_INOTIFY=1 \
113 -DENABLE_LOG4CXX=1
1253c3bb 114
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
abba28fc
JB
119
120%{__make} -C build install \
1253c3bb 121 DESTDIR=$RPM_BUILD_ROOT
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post -p /sbin/ldconfig
127%postun -p /sbin/ldconfig
128
129%files
130%defattr(644,root,root,755)
4a9fce3d
JB
131%doc AUTHORS ChangeLog
132%attr(755,root,root) %{_bindir}/deepfind
133%attr(755,root,root) %{_bindir}/deepgrep
134%attr(755,root,root) %{_bindir}/lucene2indexer
135%attr(755,root,root) %{_bindir}/rdfindexer
136%attr(755,root,root) %{_bindir}/strigiclient
137%attr(755,root,root) %{_bindir}/strigicmd
138%attr(755,root,root) %{_bindir}/strigidaemon
139%attr(755,root,root) %{_bindir}/xmlindexer
3b877464 140%attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
f29c8e58 141%attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
4a9fce3d 142%attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
a52c8172 143%attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
4a9fce3d 144%attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
a52c8172 145%attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
4a9fce3d 146%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
f29c8e58 147%attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
4a9fce3d 148%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
f29c8e58
JB
149%attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
150%dir %{_libdir}/strigi
151%attr(755,root,root) %{_libdir}/strigi/*.so
4a9fce3d
JB
152%{?with_dbus:%{_datadir}/dbus-1/services/org.freedesktop.xesam.searcher.service}
153%{?with_dbus:%{_datadir}/dbus-1/services/vandenoever.strigi.service}
a52c8172
JB
154%dir %{_datadir}/strigi
155%{_datadir}/strigi/fieldproperties
1253c3bb 156
157%files devel
158%defattr(644,root,root,755)
3b877464 159%attr(755,root,root) %{_libdir}/libsearchclient.so
a52c8172
JB
160%attr(755,root,root) %{_libdir}/libstreamanalyzer.so
161%attr(755,root,root) %{_libdir}/libstreams.so
3b877464
RT
162%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
163%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
31d6d646 164%dir %{_libdir}/cmake/Strigi
cfce5085
AM
165%{_libdir}/cmake/Strigi/*.cmake
166%dir %{_libdir}/cmake/LibSearchClient
167%{_libdir}/cmake/LibSearchClient/LibSearchClientConfig.cmake
168%dir %{_libdir}/cmake/LibStreamAnalyzer
169%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
170%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
171%dir %{_libdir}/cmake/LibStreams
172%{_libdir}/cmake/LibStreams/LibStreamsConfig.cmake
173%{_libdir}/cmake/LibStreams/LibStreamsConfigVersion.cmake
174%{_libdir}/cmake/LibStreams/LibStreamsTargets-pld.cmake
175%{_libdir}/cmake/LibStreams/LibStreamsTargets.cmake
1253c3bb 176%dir %{_includedir}/strigi
177%{_includedir}/strigi/*.h
3b877464 178%{_includedir}/strigi/qtdbus
a52c8172
JB
179%{_pkgconfigdir}/libstreamanalyzer.pc
180%{_pkgconfigdir}/libstreams.pc
This page took 0.184693 seconds and 4 git commands to generate.