]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
extra requires on features not required due strict dependencies
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
17b8c9f1 4#
5# Conditional build:
d12e8042 6%bcond_with tests # run tests
dd55e3fd 7%bcond_without tcl # Tcl extension
d12e8042
JB
8%bcond_without doc # disable documentation building
9%bcond_without unlock_notify # disable unlock notify API
60f66380 10%bcond_without load_extension # enable load extension API
5df4522e 11
f1015391
JR
12%ifarch alpha sparc %{x8664}
13%undefine with_tests
14%endif
15
16# disabling tcl currently breaks making test target,
17# some hack in Makefile needs to be done
5df4522e 18%if %{without tcl}
f1015391
JR
19%undefine with_tests
20%endif
21
7e2f6050 22#define version_num %(echo %{version} | awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
625d6d92 23%define version_num 3071602
65cfa56f 24%define _ulibdir /usr/lib
539069d8 25%define tclver 8.5
f1015391 26
17b8c9f1 27Summary: SQLite library
e882a99f 28Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 29Name: sqlite3
625d6d92 30Version: 3.7.16.2
a20aff57 31Release: 1
dd55e3fd 32License: Public Domain
17b8c9f1 33Group: Libraries
65cfa56f 34# Source0Download: http://www.sqlite.org/download.html
e4bb9672 35Source0: http://www.sqlite.org/2013/sqlite-src-%{version_num}.zip
625d6d92 36# Source0-md5: 0d821779acdb56eee1fd71343b41a1cc
a3d8a32d 37Patch0: %{name}-sign-function.patch
65cfa56f 38URL: http://www.sqlite.org/
d70f95dc 39%{?with_load_extension:Provides: %{name}(load_extension)}
40%{?with_unlock_notify:Provides: %{name}(unlock_notify)}
dd55e3fd 41BuildRequires: autoconf >= 2.50
17b8c9f1 42BuildRequires: automake
43BuildRequires: libtool
44BuildRequires: readline-devel
6ca4ac16 45%{?with_load_extension:BuildRequires: sed >= 4.0}
0e44e992 46BuildRequires: tcl
1a6aae8d 47%{?with_tcl:BuildRequires: tcl-devel}
086e11d9 48BuildRequires: unzip
17b8c9f1 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52SQLite is a C library that implements an SQL database engine. A large
53subset of SQL92 is supported. A complete database is stored in a
54single disk file. The API is designed for convenience and ease of use.
55Applications that link against SQLite can enjoy the power and
56flexiblity of an SQL database without the administrative hassles of
57supporting a separate database server. Because it omits the
58client-server interaction overhead and writes directly to disk, SQLite
59is also faster than the big database servers for most operations. In
60addition to the C library, the SQLite distribution includes a
61command-line tool for interacting with SQLite databases and SQLite
62bindings for Tcl/Tk.
63
b7c0e1f2
JR
64%description -l pl.UTF-8
65SQLite jest biblioteką języka C, która implementuje silnik baz danych
66SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
67przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
68bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
69danych bez konieczności utrzymywania osobnego serwera baz danych.
70Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
71bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
72bazodanowych przy większości operacji na bazie danych. Dodatkowo
73oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 74bazami danych.
75
76%package devel
77Summary: Header files for SQLite development
e882a99f 78Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
d70f95dc 81%if %{with unlock_notify}
d70f95dc 82Provides: %{name}-devel(unlock_notify)
83%endif
84%if %{with load_extension}
d70f95dc 85Provides: %{name}-devel(load_extension)
86%endif
17b8c9f1 87
88%description devel
89SQLite is a C library that implements an SQL database engine. A large
90subset of SQL92 is supported. A complete database is stored in a
91single disk file. The API is designed for convenience and ease of use.
92Applications that link against SQLite can enjoy the power and
93flexiblity of an SQL database without the administrative hassles of
94supporting a separate database server. Because it omits the
95client-server interaction overhead and writes directly to disk, SQLite
96is also faster than the big database servers for most operations. In
97addition to the C library, the SQLite distribution includes a
98command-line tool for interacting with SQLite databases and SQLite
99bindings for Tcl/Tk.
100
101This package contains the header files needed to develop programs that
102use these SQLite.
103
b7c0e1f2
JR
104%description devel -l pl.UTF-8
105SQLite jest biblioteką języka C, która implementuje silnik baz danych
106SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
107przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
108bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
109danych bez konieczności utrzymywania osobnego serwera baz danych.
110Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
111bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
112bazodanowych przy większości operacji na bazie danych. Dodatkowo
113oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 114bazami danych.
115
b7c0e1f2
JR
116Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
117używających biblioteki SQLite.
17b8c9f1 118
119%package static
120Summary: Static libraries for SQLite development
e882a99f 121Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 122Group: Development/Libraries
123Requires: %{name}-devel = %{version}-%{release}
d70f95dc 124%if %{with unclock_notify}
d70f95dc 125Provides: %{name}-static(unlock_notify)
126%endif
127%if %{with load_extension}
d70f95dc 128Provides: %{name}-static(load_extension)
129%endif
17b8c9f1 130
131%description static
132SQLite is a C library that implements an SQL database engine. A large
133subset of SQL92 is supported. A complete database is stored in a
134single disk file. The API is designed for convenience and ease of use.
135Applications that link against SQLite can enjoy the power and
136flexiblity of an SQL database without the administrative hassles of
137supporting a separate database server. Because it omits the
138client-server interaction overhead and writes directly to disk, SQLite
139is also faster than the big database servers for most operations. In
140addition to the C library, the SQLite distribution includes a
141command-line tool for interacting with SQLite databases and SQLite
142bindings for Tcl/Tk.
143
144This package contains the static SQLite libraries.
145
b7c0e1f2
JR
146%description static -l pl.UTF-8
147SQLite jest biblioteką języka C, która implementuje silnik baz danych
148SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
149przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
150bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
151danych bez konieczności utrzymywania osobnego serwera baz danych.
152Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
153bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
154bazodanowych przy większości operacji na bazie danych. Dodatkowo
155oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 156bazami danych.
157
158Pakiet zawiera statyczne biblioteki SQLite.
159
c743401f 160%package -n tcl-%{name}
8e66772b 161Summary: sqlite3 tcl extension
e882a99f 162Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 163Group: Development/Languages/Tcl
c743401f
AM
164
165%description -n tcl-%{name}
166sqlite3 tcl extension.
167
b7c0e1f2 168%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
169Rozszerzenie sqlite3 dla Tcl.
170
17b8c9f1 171%prep
c883dce2 172%setup -q -n sqlite-src-%{version_num}
30682d5a 173%patch0 -p1
1cd2f537 174
faed6cf7
ER
175%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
176
17b8c9f1 177%build
178%{__libtoolize}
179cp -f /usr/share/automake/config.sub .
180%{__aclocal}
181%{__autoconf}
6ca4ac16 182CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}"
f1015391 183export CFLAGS
6ca4ac16 184%if %{with load_extension}
185LIBS=-ldl
186export LIBS
187%endif
87af9815
MB
188%if %{with tcl}
189export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
190%endif
17b8c9f1 191%configure \
1a6aae8d 192 %{?with_tcl:--with-tcl=%{_ulibdir}} \
193 %{!?with_tcl:--disable-tcl} \
60f66380 194 %{__enable_disable load_extension load-extension} \
17b8c9f1 195 --enable-threadsafe
60f66380 196
5df4522e 197%{__make}
1a6aae8d 198
e16bc4b1 199%if %{with doc}
17b8c9f1 200%{__make} doc
1a6aae8d 201%endif
17b8c9f1 202
3e5df83c 203%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 204
205%install
206rm -rf $RPM_BUILD_ROOT
1c91d9d5 207install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
17b8c9f1 208
209%{__make} install \
dd55e3fd 210 DESTDIR=$RPM_BUILD_ROOT
ec30f86a 211
1c91d9d5 212mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
dd55e3fd 213%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
1c91d9d5
JR
214ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
215 $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
216
5df4522e 217cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 218
219%clean
220rm -rf $RPM_BUILD_ROOT
221
222%post -p /sbin/ldconfig
223%postun -p /sbin/ldconfig
224
225%files
226%defattr(644,root,root,755)
227%doc README
228%attr(755,root,root) %{_bindir}/sqlite3
1c91d9d5
JR
229%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
230%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
c743401f 231%{_mandir}/man1/sqlite3.1*
17b8c9f1 232
233%files devel
234%defattr(644,root,root,755)
7e92c022
JB
235%attr(755,root,root) %{_libdir}/libsqlite3.so
236%{_libdir}/libsqlite3.la
17b8c9f1 237%{_includedir}/sqlite3.h
ef88c71c 238%{_includedir}/sqlite3ext.h
7e92c022 239%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 240
241%files static
242%defattr(644,root,root,755)
7e92c022 243%{_libdir}/libsqlite3.a
c743401f 244
1a6aae8d 245%if %{with tcl}
c743401f
AM
246%files -n tcl-%{name}
247%defattr(644,root,root,755)
80deaf18 248%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
249%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
250%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 251%endif
This page took 0.070378 seconds and 4 git commands to generate.