]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- updated to 3.6.22
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
8ef92c1a 4# - enable --enable-load-extension?
17b8c9f1 5#
6# Conditional build:
f1015391 7%bcond_with tests # run tests
158e8e57 8%bcond_with tcl # enable tcl extension
f1015391 9%bcond_without doc # disable documentation building
5df4522e 10
f1015391
JR
11%ifarch alpha sparc %{x8664}
12%undefine with_tests
13%endif
14
15# disabling tcl currently breaks making test target,
16# some hack in Makefile needs to be done
5df4522e 17%if %{without tcl}
f1015391
JR
18%undefine with_tests
19%endif
20
65cfa56f 21%define _ulibdir /usr/lib
539069d8 22%define tclver 8.5
f1015391 23
17b8c9f1 24Summary: SQLite library
e882a99f 25Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 26Name: sqlite3
000fb3e1 27Version: 3.6.22
3b4ef700 28Release: 1
17b8c9f1 29License: LGPL
30Group: Libraries
65cfa56f
ER
31# Source0Download: http://www.sqlite.org/download.html
32Source0: http://www.sqlite.org/sqlite-%{version}.tar.gz
000fb3e1 33# Source0-md5: a17bd53f1fde11f84adf79c6a1510ce5
a3d8a32d 34Patch0: %{name}-sign-function.patch
65cfa56f 35URL: http://www.sqlite.org/
17b8c9f1 36BuildRequires: autoconf
37BuildRequires: automake
38BuildRequires: libtool
39BuildRequires: readline-devel
0e44e992 40BuildRequires: tcl
1a6aae8d 41%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45SQLite is a C library that implements an SQL database engine. A large
46subset of SQL92 is supported. A complete database is stored in a
47single disk file. The API is designed for convenience and ease of use.
48Applications that link against SQLite can enjoy the power and
49flexiblity of an SQL database without the administrative hassles of
50supporting a separate database server. Because it omits the
51client-server interaction overhead and writes directly to disk, SQLite
52is also faster than the big database servers for most operations. In
53addition to the C library, the SQLite distribution includes a
54command-line tool for interacting with SQLite databases and SQLite
55bindings for Tcl/Tk.
56
b7c0e1f2
JR
57%description -l pl.UTF-8
58SQLite jest biblioteką języka C, która implementuje silnik baz danych
59SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
60przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
61bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
62danych bez konieczności utrzymywania osobnego serwera baz danych.
63Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
64bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
65bazodanowych przy większości operacji na bazie danych. Dodatkowo
66oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 67bazami danych.
68
69%package devel
70Summary: Header files for SQLite development
e882a99f 71Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 72Group: Development/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description devel
76SQLite is a C library that implements an SQL database engine. A large
77subset of SQL92 is supported. A complete database is stored in a
78single disk file. The API is designed for convenience and ease of use.
79Applications that link against SQLite can enjoy the power and
80flexiblity of an SQL database without the administrative hassles of
81supporting a separate database server. Because it omits the
82client-server interaction overhead and writes directly to disk, SQLite
83is also faster than the big database servers for most operations. In
84addition to the C library, the SQLite distribution includes a
85command-line tool for interacting with SQLite databases and SQLite
86bindings for Tcl/Tk.
87
88This package contains the header files needed to develop programs that
89use these SQLite.
90
b7c0e1f2
JR
91%description devel -l pl.UTF-8
92SQLite jest biblioteką języka C, która implementuje silnik baz danych
93SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
94przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
95bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
96danych bez konieczności utrzymywania osobnego serwera baz danych.
97Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
98bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
99bazodanowych przy większości operacji na bazie danych. Dodatkowo
100oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 101bazami danych.
102
b7c0e1f2
JR
103Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
104używających biblioteki SQLite.
17b8c9f1 105
106%package static
107Summary: Static libraries for SQLite development
e882a99f 108Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 109Group: Development/Libraries
110Requires: %{name}-devel = %{version}-%{release}
111
112%description static
113SQLite is a C library that implements an SQL database engine. A large
114subset of SQL92 is supported. A complete database is stored in a
115single disk file. The API is designed for convenience and ease of use.
116Applications that link against SQLite can enjoy the power and
117flexiblity of an SQL database without the administrative hassles of
118supporting a separate database server. Because it omits the
119client-server interaction overhead and writes directly to disk, SQLite
120is also faster than the big database servers for most operations. In
121addition to the C library, the SQLite distribution includes a
122command-line tool for interacting with SQLite databases and SQLite
123bindings for Tcl/Tk.
124
125This package contains the static SQLite libraries.
126
b7c0e1f2
JR
127%description static -l pl.UTF-8
128SQLite jest biblioteką języka C, która implementuje silnik baz danych
129SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
130przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
131bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
132danych bez konieczności utrzymywania osobnego serwera baz danych.
133Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
134bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
135bazodanowych przy większości operacji na bazie danych. Dodatkowo
136oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 137bazami danych.
138
139Pakiet zawiera statyczne biblioteki SQLite.
140
c743401f 141%package -n tcl-%{name}
8e66772b 142Summary: sqlite3 tcl extension
e882a99f 143Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 144Group: Development/Languages/Tcl
c743401f
AM
145
146%description -n tcl-%{name}
147sqlite3 tcl extension.
148
b7c0e1f2 149%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
150Rozszerzenie sqlite3 dla Tcl.
151
17b8c9f1 152%prep
c743401f 153%setup -q -n sqlite-%{version}
30682d5a 154%patch0 -p1
1cd2f537 155
faed6cf7
ER
156%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
157
17b8c9f1 158%build
159%{__libtoolize}
160cp -f /usr/share/automake/config.sub .
161%{__aclocal}
162%{__autoconf}
c7a7c162 163CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1"
f1015391 164export CFLAGS
17b8c9f1 165%configure \
1a6aae8d 166 %{?with_tcl:--with-tcl=%{_ulibdir}} \
167 %{!?with_tcl:--disable-tcl} \
17b8c9f1 168 --enable-threadsafe
5df4522e 169%{__make}
1a6aae8d 170
e16bc4b1 171%if %{with doc}
17b8c9f1 172%{__make} doc
1a6aae8d 173%endif
17b8c9f1 174
3e5df83c 175%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 176
177%install
178rm -rf $RPM_BUILD_ROOT
179install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
180
181%{__make} install \
80deaf18
JR
182 DESTDIR=$RPM_BUILD_ROOT \
183 TCLLIBDIR=%{_libdir}/tcl%{tclver}
17b8c9f1 184
22de4c1c 185%if %{with tcl}
7e92c022 186sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
22de4c1c 187%endif
ec30f86a 188
5df4522e 189cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post -p /sbin/ldconfig
195%postun -p /sbin/ldconfig
196
197%files
198%defattr(644,root,root,755)
199%doc README
200%attr(755,root,root) %{_bindir}/sqlite3
7e92c022
JB
201%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
202%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
c743401f 203%{_mandir}/man1/sqlite3.1*
17b8c9f1 204
205%files devel
206%defattr(644,root,root,755)
7e92c022
JB
207%attr(755,root,root) %{_libdir}/libsqlite3.so
208%{_libdir}/libsqlite3.la
17b8c9f1 209%{_includedir}/sqlite3.h
ef88c71c 210%{_includedir}/sqlite3ext.h
7e92c022 211%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 212
213%files static
214%defattr(644,root,root,755)
7e92c022 215%{_libdir}/libsqlite3.a
c743401f 216
1a6aae8d 217%if %{with tcl}
c743401f
AM
218%files -n tcl-%{name}
219%defattr(644,root,root,755)
80deaf18 220%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
221%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
222%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 223%endif
This page took 0.149687 seconds and 4 git commands to generate.