]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- cleaned up install and files
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
4
5# The channel can be stable, beta, or nightly
6%define channel stable
7
8#
9# Conditional build:
10%bcond_with bootstrap
11%bcond_without tests # build without tests
12
13%if "%{channel}" == "stable"
d6d4cb2b 14%define rustc_package rustc-%{version}-src
e361528e 15%else
d6d4cb2b 16%define rustc_package rustc-%{channel}-src
e361528e
ER
17%endif
18
19# To bootstrap from scratch, set the channel and date from src/stage0.txt
20# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
21# or nightly wants some beta-YYYY-MM-DD
d6d4cb2b
JR
22%define bootstrap_rust 1.17.0
23%global bootstrap_cargo 0.18.0
24%define bootstrap_date 2017-04-27
25%define bootstrap_base https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}
e361528e
ER
26
27Summary: The Rust Programming Language
28Name: rust
d6d4cb2b 29Version: 1.18.0
e361528e 30Release: 0.1
d1b96fd8 31# Licenses: (rust itself) and (bundled libraries)
e361528e 32License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
e361528e 33Group: Development/Languages
d6d4cb2b
JR
34Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
35# Source0-md5: c37c0cd9d500f6a9d1f2f44401351f88
e361528e 36Source1: %{bootstrap_base}-x86_64-unknown-linux-gnu.tar.gz
d6d4cb2b 37# Source1-md5: 98e8f479515969123b4c203191104a54
e361528e 38Source2: %{bootstrap_base}-i686-unknown-linux-gnu.tar.gz
d6d4cb2b 39# Source2-md5: 2d5de850c32aa8d40c8c21abacf749f8
e361528e
ER
40URL: https://www.rust-lang.org/
41BuildRequires: cmake
42BuildRequires: curl
43BuildRequires: gcc
44BuildRequires: libstdc++-devel
d1b96fd8 45BuildRequires: libstdc++-devel
e361528e 46BuildRequires: llvm-devel
d1b96fd8 47BuildRequires: ncurses-devel
e361528e
ER
48BuildRequires: python
49BuildRequires: zlib-devel
50%if %{without bootstrap}
51BuildRequires: %{name} < %{version}-%{release}
d6d4cb2b 52BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 53BuildRequires: cargo >= %{bootstrap_cargo}
e361528e
ER
54%endif
55# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
56BuildRequires: procps
e361528e
ER
57# The C compiler is needed at runtime just for linking. Someday rustc might
58# invoke the linker directly, and then we'll only need binutils.
59# https://github.com/rust-lang/rust/issues/11937
60Requires: gcc
61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62# Only x86_64 and i686 are Tier 1 platforms at this time.
63# https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
64ExclusiveArch: %{x8664} %{ix86} %{arm}
65
66%define rust_triple %{_target_cpu}-unknown-linux-gnu
67
68%if %{without bootstrap}
69%define local_rust_root %{_prefix}
70%else
d6d4cb2b
JR
71%define bootstrap_root rust-%{bootstrap_rust}-%{rust_triple}
72%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
73%endif
74
75# ALL Rust libraries are private, because they don't keep an ABI.
76%global _privatelibs lib.*-[[:xdigit:]]{8}[.]so.*
77%global __provides_exclude ^(%{_privatelibs})$
78%global __requires_exclude ^(%{_privatelibs})$
79
80%description
81Rust is a systems programming language that runs blazingly fast,
82prevents segfaults, and guarantees thread safety.
83
84This package includes the Rust compiler, standard library, and
85documentation generator.
86
d1b96fd8
JR
87%package debugger-common
88Summary: Common debugger pretty printers for Rust
89Group: Development/Debuggers
90BuildArch: noarch
91
92%description debugger-common
93This package includes the common functionality for %{name}-gdb and
94%{name}-lldb.
95
e361528e
ER
96%package gdb
97Summary: GDB pretty printers for Rust
d1b96fd8
JR
98Group: Development/Debuggers
99Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 100Requires: gdb
e361528e 101BuildArch: noarch
e361528e
ER
102
103%description gdb
104This package includes the rust-gdb script, which allows easier
105debugging of Rust programs.
106
d1b96fd8
JR
107%package lldb
108Summary: LLDB pretty printers for Rust
109Group: Development/Debuggers
110Requires: %{name}-debugger-common = %{version}-%{release}
111Requires: lldb
112Requires: python-lldb
113BuildArch: noarch
114
115%description lldb
116This package includes the rust-lldb script, which allows easier
117debugging of Rust programs.
118
e361528e
ER
119%package doc
120Summary: Documentation for Rust
d1b96fd8
JR
121Group: Documentation
122BuildArch: noarch
e361528e
ER
123
124%description doc
125This package includes HTML documentation for the Rust programming
126language and its standard library.
127
128%prep
129%setup -q -n %{rustc_package}
130%if %{with bootstrap}
131%ifarch %{x8664}
132tar xf %{SOURCE1}
133%endif
134%ifarch %{ix86}
135tar xf %{SOURCE2}
136%endif
d6d4cb2b
JR
137%{__mv} %{bootstrap_root} %{bootstrap_root}-root
138%{bootstrap_root}-root/install.sh \
139 --components=cargo,rustc,rust-std-%{rust_triple} \
140 --prefix=%{local_rust_root} \
141 --disable-ldconfig
142test -f %{local_rust_root}/bin/cargo
e361528e
ER
143test -f %{local_rust_root}/bin/rustc
144%endif
145
146# unbundle
147rm -r src/jemalloc/
148rm -r src/llvm/
149
150# extract bundled licenses for packaging
151cp -p src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
152sed -e '/*\//q' src/libbacktrace/backtrace.h \
153 >src/libbacktrace/LICENSE-libbacktrace
154
155# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
156sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
157 src/etc/rust-gdb
158
159# These tests assume that alloc_jemalloc is present
160sed -i -e '1i // ignore-test jemalloc is disabled' \
161 src/test/compile-fail/allocator-dylib-is-system.rs \
162 src/test/compile-fail/allocator-rust-dylib-is-jemalloc.rs \
163 src/test/run-pass/allocator-default.rs
164
165# Fedora's LLVM doesn't support any mips targets -- see "llc -version".
166# Fixed properly by Rust PR36344, which should be released in 1.13.
167sed -i -e '/target=mips/,+1s/^/# unsupported /' \
168 src/test/run-make/atomic-lock-free/Makefile
169
170%if %{without bootstrap}
171# The hardcoded stage0 "lib" is inappropriate when using Fedora's own rustc
172sed -i -e '/^HLIB_RELATIVE/s/lib$/$$(CFG_LIBDIR_RELATIVE)/' mk/main.mk
173%endif
174
175%build
176%configure \
177 --disable-option-checking \
178 --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
179 --enable-local-rust --local-rust-root=%{local_rust_root} \
180 --llvm-root=%{_prefix} --disable-codegen-tests \
181 --disable-jemalloc \
182 --disable-rpath \
183 --enable-debuginfo \
d6d4cb2b 184 --enable-vendor \
e361528e
ER
185 --release-channel=%{channel}
186
d6d4cb2b 187./x.py dist
e361528e
ER
188
189%install
190rm -rf $RPM_BUILD_ROOT
e361528e 191
d1b96fd8 192DESTDIR=$RPM_BUILD_ROOT ./x.py dist --install
e361528e 193
d1b96fd8 194# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
195find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
196
d1b96fd8
JR
197# The libdir libraries are identical to those under rustlib/. It's easier on
198# library loading if we keep them in libdir, but we do need them in rustlib/
199# to support dynamic linking for compiler plugins, so we'll symlink.
200(cd "$RPM_BUILD_ROOT%{_libdir}/rustlib/%{rust_triple}/lib" &&
201 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
202 -exec ln -v -f -s -t . '{}' '+')
203
204# Remove installer artifacts (manifests, uninstall scripts, etc.)
205find $RPM_BUILD_ROOT%{_libdir}/rustlib/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
206
207# FIXME: __os_install_post will strip the rlibs
208# -- should we find a way to preserve debuginfo?
209
210# Remove unwanted documentation files (we already package them)
211rm $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
212rm $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
213rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
214rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
215
216# Sanitize the HTML documentation
217find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
218find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
219
220# Move rust-gdb's python scripts so they're noarch
221install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
222mv -v $RPM_BUILD_ROOT%{_libdir}/rustlib%{_sysconfdir} $RPM_BUILD_ROOT%{_datadir}/%{name}/
223
224%clean
225rm -rf $RPM_BUILD_ROOT
226
227%post -p /sbin/ldconfig
228%postun -p /sbin/ldconfig
229
230%files
231%defattr(644,root,root,755)
232%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT
233%doc src/libbacktrace/LICENSE-libbacktrace
234%doc src/rt/hoedown/LICENSE-hoedown
235%doc README.md
236%attr(755,root,root) %{_bindir}/rustc
237%attr(755,root,root) %{_bindir}/rustdoc
238%{_mandir}/man1/rustc.1*
239%{_mandir}/man1/rustdoc.1*
240%{_libdir}/lib*
241%dir %{_libdir}/rustlib
242%{_libdir}/rustlib/%{rust_triple}
243
d1b96fd8
JR
244%files debugger-common
245%defattr(644,root,root,755)
246%dir %{_datadir}/%{name}
247%dir %{_datadir}/%{name}/etc
248%{_datadir}/%{name}/etc/debugger_*.py*
249
250%files lldb
251%defattr(644,root,root,755)
252%attr(755,root,root) %{_bindir}/rust-lldb
253%{_datadir}/%{name}/etc/lldb_*.py*
254
e361528e
ER
255%files gdb
256%defattr(644,root,root,755)
257%attr(755,root,root) %{_bindir}/rust-gdb
d1b96fd8 258%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
259
260%files doc
261%defattr(644,root,root,755)
262%dir %{_docdir}/%{name}
d1b96fd8 263%doc %{_docdir}/%{name}/html
This page took 0.074121 seconds and 4 git commands to generate.