]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- release 56 (rebuild against 2.6.16.56-1)
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 8%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29 10# Note that gcc4 build is very problematic and not supported by qemu team
80e91c68 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
b337f190 13%bcond_without kernel # build kqemu KERNEL MODULES
3a6eaa3b 14%bcond_without up # don't build up module
8bb1261c
KK
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
55023879 17%bcond_with grsec_kernel # build for kernel-grsecurity
0287446d 18
b0b2a1d9 19# no kernel kqemu module for ppc
20%ifarch ppc
21%undefine with_kqemu
22%undefine with_kernel
23%endif
0287446d 24
ae00823b
ER
25%if %{without kernel}
26%undefine with_dist_kernel
27%endif
ae00823b
ER
28%if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
29%define alt_kernel grsecurity
30%endif
0287446d
ER
31%if "%{_alt_kernel}" != "%{nil}"
32%undefine with_userspace
33%endif
ae00823b 34
b337f190 35%define _kqemu_version 1.3.0pre11
5aeef342 36%define _rel 56
cd19124e 37Summary: QEMU CPU Emulator
4d74b97c 38Summary(pl): QEMU - emulator procesora
cd19124e 39Name: qemu
b337f190 40Version: 0.9.0
8bb1261c 41Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
42License: GPL
43Group: Applications/Emulators
867764ba 44#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 45Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b337f190 46# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
c33439fc 47Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
b337f190 48# Source1-md5: 970521874ef8b1ba4598925ace5936c3
8bd2aee2 49Patch0: %{name}-nostatic.patch
c33439fc 50Patch1: %{name}-cc.patch
d8d8cede 51Patch3: %{name}-dot.patch
8d073aaa
ER
52Patch4: %{name}-gcc4_x86.patch
53Patch5: %{name}-gcc4_ppc.patch
54Patch6: %{name}-nosdlgui.patch
55Patch7: %{name}-ifup.patch
81a493f2
MM
56# Proof of concept, for reference, do not remove
57Patch8: %{name}-kde_virtual_workspaces_hack.patch
e05988b9
AM
58# http://gwenole.beauchesne.info/en/projects/qemu
59Patch9: %{name}-0.8.0-gcc4-hacks.patch
e05988b9 60Patch11: %{name}-0.7.2-gcc4-opts.patch
b337f190 61#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
b4d7fbfb 62Patch13: %{name}-dosguest.patch
5b888e18 63# Fix crash when using qemu instances with NICs connected via socket
64# This patch will be obsolete in versions after 0.9.0
65Patch14: %{name}-0.9.0-remove-iohandlers.patch
cd19124e 66URL: http://fabrice.bellard.free.fr/qemu/
ae00823b
ER
67%if %{with kernel}
68%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
9ea49998 69BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 70%endif
71%if %{with userspace}
867764ba 72BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 73BuildRequires: alsa-lib-devel
21c5c008 74%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 75BuildRequires: perl-tools-pod
2fb8ea02 76BuildRequires: tetex
8bb1261c 77BuildRequires: sed >= 4.0
d1ae30a6 78%endif
8bb1261c 79Requires: SDL >= 1.2.1
2ef13cb9 80# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 81ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 82BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
867764ba 84# some SPARC boot image in ELF format
ca55b10f 85%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 86
cd19124e 87%description
88QEMU is a FAST! processor emulator. By using dynamic translation it
89achieves a reasonnable speed while being easy to port on new host
90CPUs. QEMU has two operating modes:
91
92- User mode emulation. In this mode, QEMU can launch Linux processes
93 compiled for one CPU on another CPU. Linux system calls are converted
94 because of endianness and 32/64 bit mismatches. Wine (Windows
95 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
96
97- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
98 including a processor and various peripherials. It can also be used to
99 provide virtual hosting of several virtual PC on a single server.
cd19124e 100
4d74b97c 101%description -l pl
102