]> git.pld-linux.org Git - packages/bigloo.git/blob - bigloo.spec
f3f8036fff06ace5711f26fbc8a00d4e15a08394
[packages/bigloo.git] / bigloo.spec
1 Summary:        Bigloo is compiler for the Scheme programming language
2 Summary(pl.UTF-8):   Bigloo - kompilator języka programowania Scheme
3 Name:           bigloo
4 Version:        2.6b
5 Release:        2
6 License:        see README file
7 Group:          Development/Languages
8 Source0:        ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/%{name}%{version}.tar.gz
9 # Source0-md5:  bbb788e70fafe2191f1da87c6fdb3f01
10 Patch0:         %{name}-install.patch
11 Patch1:         %{name}-gcc4.patch
12 URL:            http://www-sop.inria.fr/mimosa/fp/Bigloo/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Bigloo is a compiler and interpreter for an extended version of the
17 Scheme programming language. Bigloo allows a full connection between
18 Scheme and C programs. It delivers fast and small executables.
19
20 %description -l pl.UTF-8
21 Bigloo jest kompilatorem i interpreterem rozszerzonej wersji języka
22 programowania Scheme. Bigloo pozwala na pełne łączenie programów w
23 Scheme i w C. Daje szybkie i małe binarki.
24
25 %prep
26 %setup -q -n %{name}%{version}
27 %patch0 -p1
28 %patch1 -p1
29
30 %build
31 ./configure \
32         --prefix=%{_prefix} \
33         --bindir=%{_bindir} \
34         --libdir=%{_libdir} \
35         --mandir=%{_mandir}/man1 \
36         --infodir=%{_infodir} \
37         --emacs=/bin/true \
38         --jvm=no \
39         --cflags="%{rpmcflags}" \
40         --coflags="%{rpmcflags}"
41
42 %{__make} boot
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 BIGLOOLIB=$RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}
48 export BIGLOOLIB
49 %{__make} install compile-bee \
50         DESTDIR=$RPM_BUILD_ROOT
51 %{__make} install-bee \
52         DESTDIR=$RPM_BUILD_ROOT
53 #%{__make} -C fthread install \
54 #       DESTDIR=$RPM_BUILD_ROOT
55
56 install manuals/bigloo.man $RPM_BUILD_ROOT%{_mandir}/man1/bigloo.1
57 install manuals/afile.man $RPM_BUILD_ROOT%{_mandir}/man1/afile.1
58 install manuals/jfile.man $RPM_BUILD_ROOT%{_mandir}/man1/jfile.1
59 install manuals/bdepend.man $RPM_BUILD_ROOT%{_mandir}/man1/bdepend.1
60 install manuals/bmake.man $RPM_BUILD_ROOT%{_mandir}/man1/bmake.1
61 install manuals/mco.man $RPM_BUILD_ROOT%{_mandir}/man1/mco.1
62 install manuals/bpp.man $RPM_BUILD_ROOT%{_mandir}/man1/bpp.1
63 install manuals/bprof.man $RPM_BUILD_ROOT%{_mandir}/man1/bprof.1
64 install manuals/btags.man $RPM_BUILD_ROOT%{_mandir}/man1/btags.1
65
66 ln -sf %{_libdir}/bigloo/%{version}/libbigloo_s-%{version}.so           $RPM_BUILD_ROOT%{_libdir}/libbigloo_s-%{version}.so
67 ln -sf %{_libdir}/bigloo/%{version}/libbigloo_u-%{version}.so           $RPM_BUILD_ROOT%{_libdir}/libbigloo_u-%{version}.so
68 ln -sf %{_libdir}/bigloo/%{version}/libbigloobdl_s-%{version}.so        $RPM_BUILD_ROOT%{_libdir}/libbigloobdl_s-%{version}.so
69 ln -sf %{_libdir}/bigloo/%{version}/libbigloobdl_u-%{version}.so        $RPM_BUILD_ROOT%{_libdir}/libbigloobdl_u-%{version}.so
70 ln -sf %{_libdir}/bigloo/%{version}/libbigloofth_s-%{version}.so        $RPM_BUILD_ROOT%{_libdir}/libbigloofth_s-%{version}.so
71 ln -sf %{_libdir}/bigloo/%{version}/libbigloofth_u-%{version}.so        $RPM_BUILD_ROOT%{_libdir}/libbigloofth_u-%{version}.so
72 ln -sf %{_libdir}/bigloo/%{version}/libbigloogc-%{version}.so           $RPM_BUILD_ROOT%{_libdir}/libbigloogc-%{version}.so
73 ln -sf %{_libdir}/bigloo/%{version}/libbigloogc_fth-%{version}.so       $RPM_BUILD_ROOT%{_libdir}/libbigloogc_fth-%{version}.so
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README ChangeLog manuals/*.html
84 %dir %{_libdir}/bigloo
85 %dir %{_libdir}/bigloo/%{version}
86 %attr(755,root,root) %{_bindir}/*
87 %{_libdir}/bigloo/%{version}/Makefile.config
88 %{_libdir}/bigloo/%{version}/bigloo.h
89 %{_libdir}/bigloo/%{version}/bigloo_config.h
90 %{_libdir}/bigloo/%{version}/*.init
91 #%{_libdir}/bigloo/%{version}/*.zip
92 %{_libdir}/bigloo/%{version}/*.*heap
93 %{_libdir}/bigloo/%{version}/lib*.a
94 %{_libdir}/bigloo/%{version}/bmem
95 %attr(755,root,root) %{_libdir}/bigloo/%{version}/lib*.so
96 %attr(755,root,root) %{_libdir}/lib*.so
97 %{_mandir}/man1/*
98 %{_datadir}/info/bigloo.info*
99 #%%{_datadir}/xemacs/site-lisp/bigloo/*.el*
This page took 0.045999 seconds and 2 git commands to generate.