]> git.pld-linux.org Git - packages/bfilter.git/blob - bfilter.spec
- rm VERSION & INSTAL from %doc
[packages/bfilter.git] / bfilter.spec
1
2 %bcond_with gui         # Enable GTK+ UI (doesn't build)
3
4 Summary:        A filtering Web proxy
5 Summary(pl):    Filtruj±ce proxy WWW
6 Name:           bfilter
7 Version:        0.9.4
8 Release:        1
9 License:        GPL v2+
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12 # Source0-md5:  72ca85565bd4c556b06e3a264c0c24f1
13 Source1:        %{name}.init
14 URL:            http://bfilter.sf.net
15 BuildRequires:  zlib-devel
16 BuildRequires:  popt-devel
17 BuildRequires:  libsigc++12-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  libstdc++-devel
20 Requires(post): /usr/sbin/groupadd
21 Requires(post): /usr/sbin/useradd
22 Requires(post,preun):   /sbin/chkconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description 
26 BFilter is a filtering web proxy. It was originally intended for
27 removing banner ads only, but at some point it has been extended to
28 remove popups and webbugs.  Its main advantage over the similar tools
29 is its heuristic ad detection algorithm. 
30
31 %description -l pl
32 BFilter jest filtruj±cym proxy WWW.  Pierwotnie mia³ on filtrowaæ
33 tylko bannery, jednak rozszerzono go o usuwanie popupów i innych
34 reklam.  G³ówn± jego przewag± nad innymi tego rodzaju narzêdziami jest
35 heurystyczny algorytm rozpoznawania reklam.
36
37 %prep
38 %setup -q
39
40 %build
41 %configure \
42         --with%{!?with_gui:out}-gui
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT/etc/init.d
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{__install} %{SOURCE1} $RPM_BUILD_ROOT/etc/init.d/%{name}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %pre
58 groupadd -r -f %{name}
59 useradd -r -s /bin/false -d / -M -g %{name} -c 'BFilter filtering proxy' %{name} || :
60
61 %post
62 chkconfig --add %{name}
63 if [ -f /var/lock/subsys/%{name} ]; then
64         /etc/rc.d/init.d/%{name} restart 1>&2
65 else
66         echo "Type \"/etc/rc.d/init.d/%{name} start\" to start %{name}." 1>&2
67 fi
68
69 %preun
70 if [ "$1" = "0" ]; then
71         if [ -f /var/lock/subsys/%{name} ]; then
72                 /etc/rc.d/init.d/%{name} stop 1>&2
73         fi
74         /sbin/chkconfig --del %{name}
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog NEWS README doc/*.html doc/*.png
80 %attr(755,root,root) %{_bindir}/%{name}
81 %attr(755,root,root) /etc/init.d/%{name}
82 %dir %{_sysconfdir}/%{name}
83 %config %{_sysconfdir}/%{name}/config
84 %config %{_sysconfdir}/%{name}/rules.local
85 %{_sysconfdir}/%{name}/config.default
86 %{_sysconfdir}/%{name}/rules
This page took 0.095563 seconds and 3 git commands to generate.