]> git.pld-linux.org Git - packages/bfilter.git/blob - bfilter.spec
03e56160972a60602ee058dc2071597198e0089d
[packages/bfilter.git] / bfilter.spec
1 %bcond_with gui         # Enable GTK+ UI (doesn't build)
2
3 Summary:        A filtering Web proxy
4 Summary(pl):    Filtruj±ce proxy WWW
5 Name:           bfilter
6 Version:        0.9.4
7 Release:        1
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
11 # Source0-md5:  72ca85565bd4c556b06e3a264c0c24f1
12 Source1:        %{name}.init
13 URL:            http://bfilter.sf.net
14 BuildRequires:  zlib-devel
15 BuildRequires:  popt-devel
16 BuildRequires:  libsigc++12-devel
17 BuildRequires:  pkgconfig
18 BuildRequires:  libstdc++-devel
19 Requires(post): /usr/sbin/groupadd
20 Requires(post): /usr/sbin/useradd
21 Requires(post,preun):   /sbin/chkconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description 
25 BFilter is a filtering web proxy. It was originally intended for
26 removing banner ads only, but at some point it has been extended to
27 remove popups and webbugs.  Its main advantage over the similar tools
28 is its heuristic ad detection algorithm. 
29
30 %description -l pl
31 BFilter jest filtruj±cym proxy WWW.  Pierwotnie mia³ on filtrowaæ
32 tylko bannery, jednak rozszerzono go o usuwanie popupów i innych
33 reklam.  G³ówn± jego przewag± nad innymi tego rodzaju narzêdziami jest
34 heurystyczny algorytm rozpoznawania reklam.
35
36 %prep
37 %setup -q
38
39 %build
40 %configure \
41         --with%{!?with_gui:out}-gui
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 # create directories if necessary
47 #install -d $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51 %{__install} -d $RPM_BUILD_ROOT/etc/init.d
52 %{__install} -m 0755 %{SOURCE1} $RPM_BUILD_ROOT/etc/init.d/%{name}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %pre
58 groupadd -r -f %{name}
59 useradd -r -s /bin/false -d / -M -g %{name} -c 'BFilter filtering proxy' %{name} || :
60
61 %post
62 chkconfig --add %{name}
63 if [ -f /var/lock/subsys/%{name} ]; then
64         /etc/rc.d/init.d/%{name} restart 1>&2
65 else
66         echo "Type \"/etc/rc.d/init.d/%{name} start\" to start %{name}." 1>&2
67 fi
68
69 %preun
70 if [ "$1" = "0" ]; then
71         if [ -f /var/lock/subsys/%{name} ]; then
72                 /etc/rc.d/init.d/%{name} stop 1>&2
73         fi
74         /sbin/chkconfig --del %{name}
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog INSTALL NEWS README VERSION doc/*.html doc/*.png
80 %attr(755,root,root) %{_bindir}/%{name}
81 %attr(755,root,root) /etc/init.d/%{name}
82 %dir %{_sysconfdir}/%{name}
83 %config %{_sysconfdir}/%{name}/config
84 %config %{_sysconfdir}/%{name}/rules.local
85 %{_sysconfdir}/%{name}/config.default
86 %{_sysconfdir}/%{name}/rules
This page took 0.053171 seconds and 2 git commands to generate.