]> git.pld-linux.org Git - packages/bbclone.git/commitdiff
- files for bbclone.spec
authormatipl <matipl@pld-linux.org>
Thu, 17 Mar 2005 19:24:01 +0000 (19:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bbclone-security.patch -> 1.1
    bbclone.conf -> 1.1
    bbclone.txt -> 1.1

bbclone-security.patch [new file with mode: 0644]
bbclone.conf [new file with mode: 0644]
bbclone.txt [new file with mode: 0644]

diff --git a/bbclone-security.patch b/bbclone-security.patch
new file mode 100644 (file)
index 0000000..089a75c
--- /dev/null
@@ -0,0 +1,11 @@
+--- bbclone/conf/config.php    2005-03-13 18:33:01.000000000 +0100
++++ bbclone/conf/config.new    2005-03-17 19:36:29.761977136 +0100
+@@ -37,7 +37,7 @@
+ // Syntax:
+ // $BBC_SHOW_CONFIG = 1;      => Display show_config.php (default)
+ // $BBC_SHOW_CONFIG = "";     => Don't display show_config.php
+-$BBC_SHOW_CONFIG = 1;
++$BBC_SHOW_CONFIG = "";
+ // The title being displayed in the navigation bar of all bbclone pages.
+ // The following macros are recognised:
diff --git a/bbclone.conf b/bbclone.conf
new file mode 100644 (file)
index 0000000..076d6d6
--- /dev/null
@@ -0,0 +1,31 @@
+#
+#  File: bbclone.conf
+#
+#  This is the BBClone configuration file; it is included from
+#  the Apache httpd.conf file.
+#
+
+<IfModule mod_alias.c>
+    Alias /bbclone /usr/share/bbclone
+</IfModule>
+
+<IfModule mod_access.c>
+<Directory "/usr/share/bbclone/conf">
+    order deny,allow
+    deny from all
+</Directory>
+<Directory "/usr/share/bbclone/lib">
+    order deny,allow
+    deny from all
+</Directory>
+<Directory "/usr/share/bbclone/language">
+    order deny,allow
+    deny from all
+</Directory>
+<Directory "/usr/share/bbclone/var">
+    order deny,allow
+    deny from all
+</Directory>
+</IfModule>
+
+# vim: filetype=apache ts=4 sw=4 et
diff --git a/bbclone.txt b/bbclone.txt
new file mode 100644 (file)
index 0000000..54f6367
--- /dev/null
@@ -0,0 +1,29 @@
+Simple example
+----------------
+
+You must add to top of your files:
+
+<?php
+ define("_BBC_PAGE_NAME", $title);                                                                             
+ define("_BBCLONE_DIR", "/usr/share/bbclone/");                                                                
+ define("COUNTER", _BBCLONE_DIR."mark_page.php");                                                              
+ if (is_readable(COUNTER)) include_once(COUNTER);
+?>
+where $title is uniqued name for pages
+
+We can use "access.php" as regular inclusion for other documents as well,
+if we specify the path to it. The following example demostrates,
+how we could display the total amount of visits:
+
+<?php                                                                                                          
+//------ Display Total Unique ----------------------                                                           
+require("/usr/share/bbclone/var/access.php");                                                                  
+$totalvisits   = $access["stat"]["totalvisits"];                                                               
+$totalcount    = $access["stat"]["totalcount"];                                                                
+$visitorsmonth = $access["time"]["month"][date("n")-1];                                                        
+$visitorstoday = $access["time"]["wday"][date("w")];
+$wday          = $access["time"]["wday"];
+
+echo "Total Visits&nbsp;&nbsp;".$totalcount."<br />";
+echo "Visitors Today&nbsp;&nbsp;".$visitorstoday."<br />";
+?>
This page took 0.081141 seconds and 4 git commands to generate.