]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
- update gtkhtml-devel BR
[packages/balsa.git] / balsa.spec
1 # TODO:
2 #       - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
3 #       - problems with id locale
4 #
5 # Conditional build:
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_with     gpgme           # build with GPG support (experimental)
8 %bcond_without  esmtp           # build without ESMTP support
9 %bcond_without  gtkhtml         # build without HTML support
10 %bcond_with     gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-3)
11 %bcond_with     compface        # build with Compface
12 %bcond_with     gtksourceview   # build with GtkSourceView
13 %bcond_without  gtkspell        # build without GtkSpell
14 %bcond_with     sqlite          # build with SQLite for GPE address books
15 #
16 Summary:        Balsa Mail Client
17 Summary(es.UTF-8):      Balsa es un lector de e-mail
18 Summary(pl.UTF-8):      Balsa - klient poczty
19 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
20 Name:           balsa
21 Version:        2.4.9
22 Release:        1
23 License:        GPL v3+
24 Group:          X11/Applications
25 Source0:        http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
26 # Source0-md5:  bd7ac44f0cf3117a5fdb46d17dac2b51
27 Patch0:         %{name}-desktop.patch
28 URL:            http://balsa.gnome.org/
29 BuildRequires:  ORBit2-devel >= 1:2.12.4
30 BuildRequires:  aspell-devel >= 2:0.50
31 BuildRequires:  autoconf >= 2.52
32 BuildRequires:  automake
33 %{?with_compface:BuildRequires: compface-devel}
34 BuildRequires:  docbook-dtd412-xml
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib2-devel >= 2.6.4-1
37 BuildRequires:  gmime-devel >= 2.4.0
38 BuildRequires:  gnome-doc-utils
39 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
40 BuildRequires:  gtk+2-devel >= 2:2.10.0
41 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
42 %{?with_gtkspell:BuildRequires: gtkspell-devel}
43 BuildRequires:  heimdal-devel
44 BuildRequires:  intltool
45 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
46 %if %{with gtkhtml}
47 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 3.14}
48 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
49 %endif
50 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
51 BuildRequires:  libltdl-devel
52 BuildRequires:  libnotify-devel
53 BuildRequires:  libtool
54 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
55 BuildRequires:  openssl-devel >= 0.9.7d
56 BuildRequires:  pcre-devel >= 3.0
57 BuildRequires:  pkgconfig
58 BuildRequires:  rpmbuild(macros) >= 1.197
59 BuildRequires:  scrollkeeper >= 0.1.4
60 # actually, it requires sqlite >= 2.8
61 %{?with_sqlite:BuildRequires:   sqlite3-devel}
62 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
63 Requires(post,postun):  scrollkeeper
64 # sr@Latn vs. sr@latin
65 Conflicts:      glibc-misc < 6:2.7
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Balsa is an e-mail reader.  This client is part of the GNOME
70 desktop environment.  It supports local mailboxes, POP3 and
71 IMAP.
72
73 %description -l es.UTF-8
74 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
75 cajas de correo electrónico locales, POP3 y IMAP.
76
77 %description -l pl.UTF-8
78 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
79 IMAP oraz lokalne skrzynki pocztowe.
80
81 %description -l pt_BR.UTF-8
82 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
83 Suporta caixas de correio locais, POP3 a IMAP.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__autoconf}
95 %configure \
96         --with-gss \
97         --with-ssl \
98         %{!?with_esmtp:--without-esmtp} \
99         %{!?with_gtkhtml:--disable-gtkhtml}\
100         %{?with_gtkhtml2:--with-gtkhtml=2}\
101         %{?with_gpgme:--with-gpgme} \
102         %{?with_compface:--with-compface} \
103         %{?with_gtksourceview:--with-gtksourceview} \
104         %{?with_gtkspell:--with-gtkspell} \
105         %{?with_sqlite:--with-sqlite} \
106         %{?with_ldap:--with-ldap}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
116         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
117 %find_lang %{name} --with-gnome --all-name
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 %scrollkeeper_update_post
124
125 %postun
126 %scrollkeeper_update_postun
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README TODO
131 %attr(755,root,root) %{_bindir}/*
132 %{_sysconfdir}/sound/events/*
133 %{_datadir}/%{name}
134 %{_datadir}/sounds/%{name}
135 %{_libdir}/bonobo/servers/*.server
136 %{_datadir}/idl/*.idl
137 %{_mandir}/man1/*
138 %{_omf_dest_dir}/%{name}
139 %{_desktopdir}/*.desktop
140 %{_pixmapsdir}/*
141 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.251123 seconds and 3 git commands to generate.