]> git.pld-linux.org Git - packages/autossh.git/blob - autossh.spec
No empty pidfile/config.
[packages/autossh.git] / autossh.spec
1 Summary:        Automatically restart SSH sessions and tunnels
2 Summary(pl.UTF-8):      Automatyczny restart sesji i tuneli SSH
3 Name:           autossh
4 Version:        1.4b
5 Release:        4
6 License:        GPL
7 Group:          Applications/Networking
8 Source0:        http://www.harding.motd.ca/autossh/%{name}-%{version}.tgz
9 Source1:        %{name}.init
10 Source2:        %{name}.tab
11 Source3:        %{name}.tmpfiles
12 # Source0-md5:  8f9aa006f6f69e912d3c2f504622d6f7
13 URL:            http://www.harding.motd.ca/autossh/
14 Requires:       openssh-clients
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Autossh is a program to start a copy of ssh and monitor it, restarting
19 it as necessary should it die or stop passing traffic. The idea and
20 the mechanism are from rstunnel (Reliable SSH Tunnel), but implemented
21 in C. The author's view is that it is not as fiddly as rstunnel to get
22 to work. Connection monitoring using a loop of port forwardings. Backs
23 off on rate of connection attempts when experiencing rapid failures
24 such as connection refused. Compiled and tested on OpenBSD, Linux, and
25 Solaris; should work fine on other BSDs (except Mac OS 10).
26
27 %description -l pl.UTF-8
28 autossh jest programem uruchamiającym kopię ssh i monitorującym ją,
29 restartując w miarę potrzeby, jeśli umrze lub przestanie przekazywać
30 ruch. Idea i mechanizm pochodzą z rstunnela (Reliable SSH Tunnel), ale
31 zaimplementowano je w C. Według autora nie trzeba się tak patyczkować,
32 jak z rstunnelem, aby go uruchomić. Monitorowanie połączenia używa
33 pętli przekazywania portów. Częstotliwość prób połączeń jest
34 zmniejszana w przypadku napotkania nagłych awarii, takich jak
35 odrzucenie połączenia. Program skompilowano i sprawdzono na OpenBSD,
36 Linuksie i Solarisie; powinien działać także na innych BSD (oprócz
37 MacOS 10).
38
39 %package init
40 Summary:        autossh configuration as system service
41 Summary(pl.UTF-8):      konfiguracja autossh jako usługi systemowej
42 Group:          Networking/Daemons
43 Requires(post,preun):   /sbin/chkconfig
44 Requires:       autossh = %{epoch}:%{version}-%{release}
45 Requires:       awk
46 Requires:       rc-scripts >= 0.4.0.20
47
48 %description init
49 this package contains init script and example configuration file, that
50 allows to run autossh as Unix system service.
51
52 %description init -l pl.UTF-8
53 Ten pakiet zawiera skrypt startowy oraz przykładowy plik
54 konfiguracyjny, które pozwalają uruchamić autossh jako uniksową usługę
55 systemową.
56
57 %prep
58 %setup -q
59
60 %build
61 %configure
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/run/%{name},%{_bindir},%{_mandir}/man1} \
67         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
68
69 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
70 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/autossh.tab
71 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
72
73 install autossh $RPM_BUILD_ROOT%{_bindir}
74 install autossh.1 $RPM_BUILD_ROOT%{_mandir}/man1
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post init
80 /sbin/chkconfig --add autossh
81 %service autossh restart "autossh"
82
83 %preun init
84 if [ "$1" = "0" ]; then
85         %service autossh stop
86         /sbin/chkconfig --del autossh
87 fi
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README CHANGES autossh.host rscreen
92 %attr(755,root,root) %{_bindir}/autossh
93 %{_mandir}/man1/autossh.1*
94
95 %files init
96 %defattr(644,root,root,755)
97 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.tab
98 %attr(754,root,root) /etc/rc.d/init.d/%{name}
99 /usr/lib/tmpfiles.d/%{name}.conf
100 %dir /var/run/autossh
This page took 0.098623 seconds and 3 git commands to generate.