]> git.pld-linux.org Git - packages/autossh.git/blob - autossh.spec
- add systemd tmpfiles config
[packages/autossh.git] / autossh.spec
1 Summary:        Automatically restart SSH sessions and tunnels
2 Summary(pl.UTF-8):      Automatyczny restart sesji i tuneli SSH
3 Name:           autossh
4 Version:        1.4b
5 Release:        2
6 License:        GPL
7 Group:          Applications/Networking
8 Source0:        http://www.harding.motd.ca/autossh/%{name}-%{version}.tgz
9 Source1:        %{name}.init
10 Source2:        %{name}.tab
11 # Source0-md5:  8f9aa006f6f69e912d3c2f504622d6f7
12 URL:            http://www.harding.motd.ca/autossh/
13 Requires:       openssh-clients
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Autossh is a program to start a copy of ssh and monitor it, restarting
18 it as necessary should it die or stop passing traffic. The idea and
19 the mechanism are from rstunnel (Reliable SSH Tunnel), but implemented
20 in C. The author's view is that it is not as fiddly as rstunnel to get
21 to work. Connection monitoring using a loop of port forwardings. Backs
22 off on rate of connection attempts when experiencing rapid failures
23 such as connection refused. Compiled and tested on OpenBSD, Linux, and
24 Solaris; should work fine on other BSDs (except Mac OS 10).
25
26 %description -l pl.UTF-8
27 autossh jest programem uruchamiającym kopię ssh i monitorującym ją,
28 restartując w miarę potrzeby, jeśli umrze lub przestanie przekazywać
29 ruch. Idea i mechanizm pochodzą z rstunnela (Reliable SSH Tunnel), ale
30 zaimplementowano je w C. Według autora nie trzeba się tak patyczkować,
31 jak z rstunnelem, aby go uruchomić. Monitorowanie połączenia używa
32 pętli przekazywania portów. Częstotliwość prób połączeń jest
33 zmniejszana w przypadku napotkania nagłych awarii, takich jak
34 odrzucenie połączenia. Program skompilowano i sprawdzono na OpenBSD,
35 Linuksie i Solarisie; powinien działać także na innych BSD (oprócz
36 MacOS 10).
37
38 %package init
39 Summary:        autossh configuration as system service
40 Summary(pl.UTF-8):      konfiguracja autossh jako usługi systemowej
41 Group:          Networking/Daemons
42 Requires(post,preun):   /sbin/chkconfig
43 Requires:       autossh = %{epoch}:%{version}-%{release}
44 Requires:       awk
45 Requires:       rc-scripts >= 0.4.0.20
46
47 %description init
48 this package contains init script and example configuration file, that
49 allows to run autossh as Unix system service.
50
51 %description init -l pl.UTF-8
52 Ten pakiet zawiera skrypt startowy oraz przykładowy plik
53 konfiguracyjny, które pozwalają uruchamić autossh jako uniksową usługę
54 systemową.
55
56 %prep
57 %setup -q
58
59 %build
60 %configure
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/run/%{name},%{_bindir},%{_mandir}/man1}
66
67 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
68 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/autossh.tab
69
70 install autossh $RPM_BUILD_ROOT%{_bindir}
71 install autossh.1 $RPM_BUILD_ROOT%{_mandir}/man1
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post init
77 /sbin/chkconfig --add autossh
78 %service autossh restart "autossh"
79
80 %preun init
81 if [ "$1" = "0" ]; then
82         %service autossh stop
83         /sbin/chkconfig --del autossh
84 fi
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README CHANGES autossh.host rscreen
89 %attr(755,root,root) %{_bindir}/autossh
90 %{_mandir}/man1/autossh.1*
91
92 %files init
93 %defattr(644,root,root,755)
94 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.tab
95 %attr(754,root,root) /etc/rc.d/init.d/%{name}
96 %dir /var/run/autossh
This page took 0.09694 seconds and 3 git commands to generate.