]> git.pld-linux.org Git - packages/arpack.git/blob - arpack.spec
- etime_ is not exposed in libgfortran-4.2.0
[packages/arpack.git] / arpack.spec
1 #
2 # Conditional build:
3 %bcond_with     acml    # With ACML version of BLAS instead of NETLIB implementation
4 #
5 Summary:        Subroutines for solving large scale eigenvalue problems
6 Summary(pl.UTF-8):      Rozwiązywanie zagadnienia własnego dla dużych macierzy
7 Name:           arpack
8 Version:        2.1
9 Release:        3%{?with_acml:ACML}
10 License:        Freely distributable
11 Group:          Libraries
12 Source0:        http://www.caam.rice.edu/software/ARPACK/SRC/%{name}96.tar.gz
13 # Source0-md5:  fffaa970198b285676f4156cebc8626e
14 Source1:        http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
15 # Source1-md5:  14830d758f195f272b8594a493501fa2
16 Source2:        http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
17 # Source2-md5:  79cc51e4812c75873adafcad2185842e
18 Source3:        http://www.caam.rice.edu/software/ARPACK/SRC/P57_58.ps.gz
19 # Source3-md5:  b86d77199f989fc438acaf7ac0433e76
20 Source4:        http://www.caam.rice.edu/software/ARPACK/SRC/P61_62.ps.gz
21 # Source4-md5:  d116887acb3d61fecf645c2d37d4d517
22 Patch0:         %{name}-automake_support.patch
23 URL:            http://www.caam.rice.edu/software/ARPACK/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gcc-g77
27 BuildRequires:  libtool >= 2:1.5
28 %{!?with_acml:BuildRequires:    blas-devel}
29 %{?with_acml:ExclusiveArch:     %{x8664}}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 ARPACK software is capable of solving large scale symmetric,
34 nonsymmetric, and generalized eigenproblems from significant
35 application areas. The software is designed to compute a few (k)
36 eigenvalues with user specified features such as those of largest real
37 part or largest magnitude. Storage requirements are on the order of
38 n*k locations. No auxiliary storage is required. A set of Schur basis
39 vectors for the desired k-dimensional eigen-space is computed which is
40 numerically orthogonal to working precision. Numerically accurate
41 eigenvectors are available on request.
42
43 %description -l pl.UTF-8
44 Rozwiązywanie zagadnienia własnego (symetrycznego, niesymetrycznego,
45 ogólnego) dla dużych macierzy. Macierz może być dowolna, przy czym
46 procedury działają szczególnie dobrze w przypadku dużych macierzy
47 rzadkich bądź macierzy ze znaną strukturą. Biblioteka służy do
48 obliczenia kilku (k) wartości własnych o zadanych z góry własnościach,
49 takich jak największa (najmniejsza) część rzeczywista albo największy
50 (najmniejszy) moduł. Wymagania pamięciowe są rzędu n*k, żadna
51 dodatkowa pamięć (np. dyskowa) nie jest wymagana.
52
53 %package devel
54 Summary:        ARPACK development files
55 Summary(pl.UTF-8):      Pliki programistyczne ARPACK
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 %{!?with_acml:Requires: blas-devel}
59
60 %description devel
61 ARPACK development files.
62
63 %description devel -l pl.UTF-8
64 Pliki programistyczne ARPACK.
65
66 %package static
67 Summary:        Static ARPACK library
68 Summary(pl.UTF-8):      Statyczna biblioteka ARPACK
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static ARPACK library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka ARPACK.
77
78 %prep
79 %setup -q -n ARPACK -b1
80 %patch0 -p1
81 cp %{SOURCE2} .
82 cp %{SOURCE3} .
83 cp %{SOURCE4} .
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoheader}
89 %{__autoconf}
90 %{__automake}
91 %configure \
92         LDFLAGS=%{?with_acml:-lacml}%{!?with_acml:-lblas}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -fr $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README
111 %attr(755,root,root) %{_libdir}/libarpack.so.*.*.*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc DOCUMENTS/*.doc *.ps.gz
116 %attr(755,root,root) %{_libdir}/libarpack.so
117 %{_libdir}/libarpack.la
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libarpack.a
This page took 0.060242 seconds and 3 git commands to generate.