]> git.pld-linux.org Git - packages/ardour.git/blob - ardour.spec
- added system-libs patch, regenerate ac/am (for system libsigc++1 and gtkmm1)
[packages/ardour.git] / ardour.spec
1 # TODO:
2 # - use external libraries if possible (sigc++1 and gtkmm1)
3 # - .desktop
4 # - check BR (ladspa - is it really needed at compile time?)
5 # - optflags (in gtk_ardour, libs/{ardour,gtkmmext,midi++,pbd,soundtouch}
6 #
7 %define         _beta beta2
8 Summary:        Multitrack hard disk recorder
9 Summary(pl):    Wieloscie¿kowy magnetofon nagrywaj±cy na twardym dysku
10 Name:           ardour
11 Version:        0.9
12 Release:        0.%{_beta}.1
13 License:        GPL
14 Group:          X11/Applications/Sound
15 Source0:        http://dl.sourceforge.net/ardour/%{name}-%{version}%{_beta}.tar.bz2
16 # Source0-md5:  91db0b724e5183e7c92408a986aa17ea
17 Patch0:         %{name}-system-libs.patch
18 URL:            http://ardour.sourceforge.net/
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  alsa-lib-devel >= 0.9.0
23 BuildRequires:  gtk+-devel >= 1.0.0
24 BuildRequires:  gtkmm1-devel >= 1.2.6
25 BuildRequires:  jack-audio-connection-kit-devel >= 0.66.0
26 BuildRequires:  ladspa-devel
27 BuildRequires:  libart_lgpl >= 2.3
28 BuildRequires:  liblrdf-devel >= 0.3.0
29 BuildRequires:  libsamplerate-devel >= 0.0.13
30 BuildRequires:  libsigc++1-devel >= 0.8.8
31 BuildRequires:  libsndfile-devel >= 1.0.0
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  libxml2-devel >= 2.5.0
35 BuildRequires:  pkgconfig
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A "professional" multitrack, multichannel audio recorder and DAW for
40 Linux, using ALSA-supported audio interfaces. Supports up to 32 bit
41 samples, 24+ channels at up to 96kHz, full MMC control,
42 non-destructive, non-linear editor, LADSPA plugins.
43
44 %description -l pl
45 "Profesjonalny" wielo¶cie¿kowy, wielokana³owy magnetofon oraz DAW dla
46 Linuksa, wykorzystuj±cy interfejsu d¼wiêkowe obs³ugiwane przez ALSA.
47 Obs³uguje próbki do 32 bitów, 24+ kana³ów do 96kHz, pe³n± kontrolê
48 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
49
50 %prep
51 %setup -q -n %{name}-%{version}%{_beta}
52 %patch -p1
53
54 install -d m4
55 # extract AM_BUILD_ENVIRONMENT (patched!)
56 tail +787 aclocal.m4 > m4/buildenv.m4
57 # AC_UNIQUIFY_{LAST,FIRST}
58 tail +6685 libs/ardour/aclocal.m4 >> m4/buildenv.m4
59 # AC_POSIX_RTSCHED
60 tail +870 libs/pbd/aclocal.m4 | head -118 >> m4/buildenv.m4
61
62 %build
63 %{__aclocal} -I m4
64 %{__autoconf}
65 %{__automake}
66 cd gtk_ardour
67 %{__aclocal} -I ../m4
68 %{__autoconf}
69 %{__automake}
70 cd ../libs
71 %{__libtoolize}
72 %{__aclocal} -I ../m4
73 %{__autoconf}
74 %{__automake}
75 cd ardour
76 %{__libtoolize}
77 %{__aclocal} -I ../../m4
78 %{__autoconf}
79 %{__automake}
80 cd ../gtk-canvas
81 %{__aclocal} -I ../../m4
82 %{__autoconf}
83 %{__automake}
84 cd ../gtkmmext
85 %{__aclocal} -I ../../m4
86 %{__autoconf}
87 %{__automake}
88 cd ../midi++
89 %{__aclocal} -I ../../m4
90 %{__autoconf}
91 %{__automake}
92 cd ../pbd
93 %{__aclocal} -I ../../m4
94 %{__autoconf}
95 %{__automake}
96 cd ../soundtouch
97 %{__aclocal} -I ../../m4
98 %{__autoconf}
99 %{__automake}
100 cd ../..
101 # ksi doesn't build for a moment
102 %configure \
103         --disable-ksi
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %find_lang %{name} --all-name
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc ChangeLog README ReleaseNotes* TODO
121 %attr(755,root,root) %{_bindir}/*
122 %dir %{_datadir}/%{name}
123 %{_datadir}/%{name}/pixmaps
124 %{_datadir}/%{name}/splash.ppm
125 %{_mandir}/man1/*
126 %dir %{_sysconfdir}/ardour
127 %{_sysconfdir}/ardour/*.rc
This page took 0.058309 seconds and 3 git commands to generate.