]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blob - apache1-mod_throttle.spec
- tabs in preamble
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
1 %bcond_without  ipv6            # disable IPv6 support
2
3 %define         mod_name        throttle
4 %define         apxs            /usr/sbin/apxs1
5 Summary:        Bandwidth & Request Throttling for Apache
6 Summary(cs.UTF-8):      Omezení síťového provozu pro Apache
7 Summary(de.UTF-8):      Ein Modul, das die Bandbreiten- und Anforderungseinschränkung für Apache implementiert
8 Summary(es.UTF-8):      Módulo que implementa la gestión de ancho de banda y peticiones para Apache
9 Summary(fr.UTF-8):      Module qui met en oeuvre la bande passante et l'étranglement requis pour Apache
10 Summary(it.UTF-8):      Modulo che implementa la larghezza di banda e la richiesta di throttling per Apache
11 Summary(ja.UTF-8):      Apache 用帯域幅および要求スロットルを実装するモジュール
12 Summary(pl.UTF-8):      Tłumienie przepustowości i zapytań dla Apache'a
13 Summary(pt_BR.UTF-8):   Descompressão "On-the-fly" de arquivos HTML para o Apache
14 Summary(sv.UTF-8):      En modul som implementerar bandvidd- och begäranbegränsningar i Apache
15 Name:           apache1-mod_%{mod_name}
16 Version:        3.1.2
17 Release:        4
18 License:        BSD-like
19 Group:          Networking/Daemons
20 Source0:        http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
21 # Source0-md5:  6edc45c3ea8a0855d4b0b14cf0f76404
22 Patch0:         apache1-mod_throttle-PLD-v6stuff.patch
23 URL:            http://www.snert.com/Software/mod_throttle/
24 BuildRequires:  %{apxs}
25 #{?with_ipv6:BuildRequires:     apache1(ipv6)-devel}
26 BuildRequires:  apache1-devel >= 1.3.33-2
27 BuildRequires:  rpmbuild(macros) >= 1.268
28 Requires(triggerpostun):        %{apxs}
29 Requires:       apache1(EAPI)
30 Obsoletes:      apache-mod_throttle <= 3.1.2
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
34 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
35 %define         _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
36
37 %description
38 This Apache module is intended to reduce the load on your server &
39 bandwidth generated by popular virtual hosts, directories, locations,
40 or users according to supported polices (see below) that decide when
41 to delay or refuse requests. Also mod_throttle can track and throttle
42 incoming connections by IP address or by authenticated remote user.
43
44 %description -l cs.UTF-8
45 Balíček mod_throttle obsahuje modul, který umožňuje omezit průtok dat,
46 která odcházejí z WWW serveru Apache. Limity mohou být nastaveny pro
47 jednotlivé virtuální weby, adresáře, umístění nebo autentizované
48 uživatele.
49
50 %description -l de.UTF-8
51 Mod_throttle kann verwendet werden, um die Datenmenge zu beschränken,
52 die Ihr Web-Server behandelt. Diese Einschränkungen können für
53 einzelne virtuelle Rechner, Verzeichnisse, Speicherstellen oder
54 authentifizierte Benutzer eingestellt werden.
55
56 %description -l es.UTF-8
57 Mod_throttle puede usarse para limitar la cantidad de datos que su
58 servidor web va a servir. Estos límites se pueden configurar para
59 hosts virtuales individuales, directorios, lugares o usuarios
60 autenticados.
61
62 %description -l fr.UTF-8
63 Mod_throttle peut être utilisé pour limiter la quantité de données
64 servies par votre serveur Web. Ces limites peuvent être définies pour
65 des hôtes virtuels individuels, répertoires, emplacements ou
66 utilisateurs authentifiés.
67
68 %description -l it.UTF-8
69 Mod_throttle può essere usato per limitare la quantità di dati che il
70 server Web dovrà servire. Queste limitazioni possono essere
71 configurate per singoli host virtuali, directory, indirizzi o utenti
72 autenticati.
73
74 %description -l ja.UTF-8
75 Mod_throttle によって Web サーバーが処理するデータ量を制限できます
76 これらの制限は、個々の仮想ホスト、ディレクトリ、場所、または
77 認証ユーザー用について設定できます。
78
79 %description -l pl.UTF-8
80 Ten moduł Apache ma służyć do zmniejszania obciążenia serwera i ruchu
81 generowanego przez popularne hosty wirtualne, katalogi, pliki lub
82 użytkowników zgodnie z obsługiwanymi polisami, które decydują kiedy
83 opóźnić lub odrzucić zapytanie. mod_throttle może także śledzić i
84 tłumić połączenia przychodzące z danego adresu IP lub danego,
85 autentykującego się, użytkownika.
86
87 %description -l pt_BR.UTF-8
88 Descompressão "On-the-fly" de arquivos HTML para o Apache.
89
90 %description -l sv.UTF-8
91 Mod_throttle kan användas för att begränsa mängden data som din
92 webbserver skickar. Dessa gränser kan sättas för enskilda virtuella
93 värdar, kataloger, platser eller autenticerade användare.
94
95 %prep
96 %setup -q -n mod_%{mod_name}-%{version}
97 %{?with_ipv6:%patch0 -p1}
98
99 %build
100 %{apxs} -o mod_%{mod_name}.so -c mod_%{mod_name}.c
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_pkglogdir}}
105
106 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
107
108 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
109         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
110
111 sed -e 's/<!--#/<!--/g' index.shtml > mod_%{mod_name}.html
112
113 > $RPM_BUILD_ROOT%{_pkglogdir}/mod_throttle.runtime
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 %service -q apache restart
120
121 %postun
122 if [ "$1" = "0" ]; then
123         %service -q apache restart
124 fi
125
126 %triggerpostun -- apache1-mod_%{mod_name} < 3.1.2-1.1
127 # check that they're not using old apache.conf
128 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
129         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
130 fi
131
132 %files
133 %defattr(644,root,root,755)
134 %doc *.txt *.html
135 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
136 %attr(755,root,root) %{_pkglibdir}/*
137 %attr(660,root,http) %ghost %{_pkglogdir}/*
This page took 0.042428 seconds and 3 git commands to generate.