]> git.pld-linux.org Git - packages/apache1-mod_pointer.git/blob - apache1-mod_pointer.spec
b613d7ea793c1ec6d2bfeca4662b8430f8039077
[packages/apache1-mod_pointer.git] / apache1-mod_pointer.spec
1 # TODO
2 # - apache config
3 # - package split by backend
4 %define         mod_name        pointer
5 %define         apxs            %{_sbindir}/apxs1
6 Summary:        Apache module for making domain redirects
7 Summary(pl):    Modu³ Apache'a do tworzenia przekierowañ domen
8 Name:           apache1-mod_%{mod_name}
9 Version:        0.8
10 Release:        0.6
11 License:        Apache
12 Group:          Networking/Daemons
13 Source0:        http://stderr.net/mod_pointer/dist/mod_pointer-%{version}.tar.gz
14 # Source0-md5:  2f6529c49f1d10ecd06d3f6bc8503a5f
15 Patch0:         apache1-mod_pointer-mysql.patch
16 URL:            http://stderr.net/mod_pointer/
17 BuildRequires:  apache1-devel >= 1.3.34-8.5
18 BuildRequires:  gdbm-devel
19 BuildRequires:  mysql-devel
20 BuildRequires:  postgresql-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache1 >= 1.3.33-2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 mod_pointer is an Apache module for making domain redirects easy - the
30 known service of many hosting providers that lets a domain point to
31 your webpage on another server.
32
33 The configuration part of the mappings are handled in either a MySQL
34 or PostgreSQL database or a NDBM or SDBM db file, so it's easy to
35 build a webbased interface for letting users change it on their own.
36
37 %description -l pl
38 mod_pointer to modu³ Apache'a do ³atwego tworzenia przekierowañ domen
39 - znanej us³ugi wielu providerów pozwalaj±cej domenie wskazywaæ na
40 stronê na innym serwerze.
41
42 Czê¶æ konfiguracyjna odwzorowañ jest obs³ugiwana poprzez bazê danych
43 MySQL lub PostgreSQL albo plik bazy danych NDBM lub SDBM, wiêc ³atwo
44 stworzyæ oparty na WWW interfejs umo¿liwiaj±cy u¿ytkownikom
45 samodzieln± zmianê przekierowañ.
46
47 %prep
48 %setup -q -n mod_%{mod_name}-%{version}
49 %patch0 -p1
50
51 %build
52 %{__make} all \
53         WITH_APXS=%{apxs}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
58
59 %{__make} install \
60         APXS="%{apxs} -S DESTDIR=$RPM_BUILD_ROOT"
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %service -q apache restart
67
68 %postun
69 if [ "$1" = "0" ]; then
70         %service -q apache restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README CHANGES SUPPORT TODO frameset.html *.sql *.readme pointer.conf
76 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
77 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.02594 seconds and 2 git commands to generate.