]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blob - apache1-mod_mp3.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
1 # TODO
2 #  - with mysql and pgsql?
3 %define         mod_name        mp3
4 %define         apxs            /usr/sbin/apxs1
5 Summary:        MP3 Apache module
6 Summary(pl.UTF-8):      Moduł MP3 do Apache
7 Name:           apache1-mod_%{mod_name}
8 Version:        0.40
9 Release:        4
10 License:        BSD
11 Group:          Networking/Daemons
12 Source0:        http://www.tangent.org/download/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  a36b25ee4db268df45a03231993e718d
14 Source1:        %{name}.conf
15 URL:            http://media.tangent.org/
16 BuildRequires:  apache1-devel >= 1.3.39
17 BuildRequires:  libghttp-devel
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(triggerpostun):        %{apxs}
20 Requires(triggerpostun):        grep
21 Requires(triggerpostun):        sed >= 4.0
22 Requires:       apache1(EAPI)
23 Obsoletes:      apache-mod_mp3 <= 0.40
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
28
29 %description
30 This turns apache into your basic RIAA hating, but every college
31 student loving MP3 streaming server. It can play from a list of files,
32 either straight through or randomly. It can also be used to cache
33 MP3's into memory and have the server operate entirely from memory.
34 Enjoy, groove, MP3s not included.
35
36 %description -l pl.UTF-8
37 Ten pakiet zamienia Twojego Apache w znienawidzony przez RIAA, ale
38 uwielbiany przez studentów serwer strumieni MP3. Może odtwarzać listę
39 plików, w kolejności lub losowo. Może być także użyty do buforowania
40 plików MP3 w pamięci, pozwalając serwerowi operować wyłącznie na
41 pamięci. Baw się dobrze; pliki MP3 nie są załączone.
42
43 %prep
44 %setup -q -n mod_%{mod_name}-%{version}
45
46 %build
47 ./configure \
48         --with-apxs=%{apxs} \
49         %{?debug:--with-debug}
50
51 %{__make} \
52         APXS=%{apxs} \
53         AINCLUDEDIR="-I$(%{apxs} -q INCLUDEDIR) $(%{apxs} -q CFLAGS) %{rpmcflags} -fPIC"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
58
59 install src/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
60 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %service -q apache restart
67
68 %postun
69 if [ "$1" = "0" ]; then
70         %service -q apache restart
71 fi
72
73 %triggerpostun -- %{name} < 0.40-2.1
74 if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
75         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
76         sed -i -e '
77                 /^Include.*mod_%{mod_name}\.conf/d
78         ' /etc/apache/apache.conf
79 else
80         # they're still using old apache.conf
81         sed -i -e '
82                 s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
83         ' /etc/apache/apache.conf
84 fi
85 %service -q apache restart
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README ChangeLog LICENSE faq.html support CONTRIBUTORS TODO utils/*
90 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
91 %attr(755,root,root) %{_pkglibdir}/mod_mp3.so
This page took 0.090294 seconds and 3 git commands to generate.