]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/commitdiff
This commit was manufactured by cvs2git to create tag 'STABLE'. STABLE
authorcvs2git <feedback@pld-linux.org>
Sun, 30 Jun 2002 00:45:57 +0000 (00:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2001-10-24 14:04:22 UTC Sebastian Zagrodzki <sebek@zagrodzki.net> '2845686f535a76f9663ef4eafe687583  mod_auth_pgsql-0.9.10.tar.gz'
Cherrypick from master 2002-06-30 00:45:57 UTC kloczek <kloczek@pld-linux.org> '- release 4: mod_auth_pgsql added to Obsoletes.':
    apache1-mod_auth_pgsql.spec -> 1.14

apache1-mod_auth_pgsql.spec [new file with mode: 0644]

diff --git a/apache1-mod_auth_pgsql.spec b/apache1-mod_auth_pgsql.spec
new file mode 100644 (file)
index 0000000..9e686bd
--- /dev/null
@@ -0,0 +1,115 @@
+%define                mod_name        auth_pgsql
+%define        apxs            /usr/sbin/apxs
+Summary:       This is the PostgreSQL authentication module for Apache
+Summary(cs):   Základní autentizace pro WWW server Apache pomocí PostgreSQL
+Summary(da):   Autenticering for webtjeneren Apache fra en PostgreSQL-database
+Summary(de):   Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
+Summary(es):   Autenticación vía PostgreSQL para Apache
+Summary(fr):   Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
+Summary(it):   Autenticazione di base per il server web Apache mediante un database PostgreSQL
+Summary(ja):   PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
+Summary(no):   Autentisering for webtjeneren Apache fra en PostgreSQL-database
+Summary(pl):   Modu³ autentykacji PostgreSQL dla Apache
+Summary(pt_BR):        Autenticação via PostgreSQL para o Apache
+Summary(sv):   Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
+Name:          apache-mod_%{mod_name}
+Version:       0.9.12
+Release:       4
+License:       GPL
+Group:         Networking/Daemons
+Source0:       http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
+BuildRequires: postgresql-devel
+BuildRequires: %{apxs}
+BuildRequires: apache(EAPI)-devel
+Prereq:                %{_sbindir}/apxs
+Requires:      apache(EAPI)
+URL:           http://www.giuseppetanzilli.it/mod_auth_pgsql/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Obsoletes:     mod_auth_pgsql
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+
+%description
+This is an authentication module for Apache that allows you to
+authenticate HTTP clients using postgresql RDBMS.
+
+%description -l cs
+Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
+poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
+PostgreSQL.
+
+%description -l de
+Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
+Web- Server bediente Dokumente zu beschränken, indem es die Felder in
+einer Tabelle in einer PostgresQL-Datenbank prüft.
+
+%description -l es
+Mod_auth_pgsql puede usarse para limitar el acceso a documentos
+servidos desde un servidor web verificando datos en una base de datos
+PostgreSQL.
+
+%description -l fr
+mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
+servis par un serveur Web en vérifiant des champs dans une table d'une
+base de données PostgresQL.
+
+%description -l it
+Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
+serviti da un server Web controllando i campi di una tabella in un
+database PostgresQL.
+
+%description -l ja
+Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
+¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
+À©¸Â¤Ç¤­¤Þ¤¹¡£
+
+%description -l pl
+To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
+klientów HTTP z u¿yciem bazy danych postgresql.
+
+%description -l pt_BR
+Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
+PostgreSQL.
+
+%description -l sv
+Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
+servade av en webbserver genom att kontrollera data i en
+PostgreSQL-databas.
+
+%prep
+%setup -q -n "mod_%{mod_name}-%{version}"
+
+%build
+%{apxs} \
+       -I %{_includedir}/postgresql \
+       -l pq \
+       -c mod_%{mod_name}.c \
+       -o mod_%{mod_name}.so
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_pkglibdir}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%{_sbindir}/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       %{_sbindir}/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc *.html
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.080365 seconds and 4 git commands to generate.