]> git.pld-linux.org Git - packages/apache-mod_evasive.git/commitdiff
- init
authorshadzik <shadzik@pld-linux.org>
Wed, 13 May 2009 23:38:01 +0000 (23:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_evasive.conf -> 1.1
    apache-mod_evasive.spec -> 1.1
    apache-mod_evasive.spec~ -> 1.1

apache-mod_evasive.conf [new file with mode: 0644]
apache-mod_evasive.spec [new file with mode: 0644]
apache-mod_evasive.spec~ [new file with mode: 0644]

diff --git a/apache-mod_evasive.conf b/apache-mod_evasive.conf
new file mode 100644 (file)
index 0000000..cc18c25
--- /dev/null
@@ -0,0 +1,13 @@
+LoadModule      evasive20_module        modules/mod_evasive20.so
+
+<IfModule mod_evasive20.c>
+        DOSHashTableSize 3097
+        DOSPageCount 2
+        DOSSiteCount 50
+        DOSPageInterval 1
+        DOSSiteInterval 1
+        DOSBlockingPeriod 100
+        DOSLogDir       "/var/log/httpd/mod_evasive"
+        DOSEmailNotify  root@atwa.us
+</IfModule>
+
diff --git a/apache-mod_evasive.spec b/apache-mod_evasive.spec
new file mode 100644 (file)
index 0000000..8060e0e
--- /dev/null
@@ -0,0 +1,57 @@
+%define                mod_name        evasive
+%define        apxs            %{_sbindir}/apxs
+Summary:       Apache module: evasive
+Summary(pl.UTF-8):     Moduł Apache'a: evasive
+Name:          apache-mod_%{mod_name}
+Version:       1.10.1
+Release:       1
+License:       GPL
+Group:         Networking/Daemons/HTTP
+Source0:       http://www.zdziarski.com/projects/mod_evasive/mod_evasive_1.10.1.tar.gz
+# Source0-md5: 784fca4a124f25ccff5b48c7a69a65e5
+Source1:       %{name}.conf
+URL:           http://www.zdziarski.com/projects/mod_evasive/
+BuildRequires: %{apxs}
+BuildRequires: apache-devel >= 2.2
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache(modules-api) = %apache_modules_api
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
+
+%description
+mod_evasive is an evasive maneuvers module for Apache.
+
+%description -l pl.UTF-8
+
+%prep
+%setup -q -n mod_%{mod_name}
+
+%build
+%{apxs} -c mod_%{mod_name}20.c -o mod_%{mod_name}20.la -DMAILER='/usr/sbin/sendmail -t'
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
+
+install .libs/mod_%{mod_name}20.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%service -q httpd restart
+
+%postun
+if [ "$1" = "0" ]; then
+       %service -q httpd restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*
diff --git a/apache-mod_evasive.spec~ b/apache-mod_evasive.spec~
new file mode 100644 (file)
index 0000000..82b3e47
--- /dev/null
@@ -0,0 +1,65 @@
+# $Revision$, $Date$
+%define                mod_name        evasive
+%define        apxs            %{_sbindir}/apxs
+Summary:       Apache module: evasive
+Summary(pl.UTF-8):     Moduł Apache'a: evasive
+Name:          apache-mod_%{mod_name}
+Version:       1.10.1
+Release:       1
+License:       GPL
+Group:         Networking/Daemons/HTTP
+Source0:       http://www.zdziarski.com/projects/mod_evasive/mod_evasive_1.10.1.tar.gz
+# Source0-md5: 784fca4a124f25ccff5b48c7a69a65e5
+Source1:       %{name}.conf
+URL:           http://www.zdziarski.com/projects/mod_evasive/
+BuildRequires: %{apxs}
+BuildRequires: apache-devel >= 2.2
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache(modules-api) = %apache_modules_api
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
+
+%description
+mod_evasive is an evasive maneuvers module for Apache.
+
+%description -l pl.UTF-8
+
+%prep
+%setup -q -n mod_%{mod_name}
+
+%build
+%{apxs} -i -c mod_%{mod_name}20.c -o mod_%{mod_name}20.la -DMAILER='/usr/sbin/sendmail -t'
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
+
+install .libs/mod_%{mod_name}20.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%service -q httpd restart
+
+%postun
+if [ "$1" = "0" ]; then
+       %service -q httpd restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*
+
+%define date   %(echo `LC_ALL="C" date +"%a %b %d %Y"`)
+%changelog
+* %{date} PLD Team <feedback@pld-linux.org>
+All persons listed below can be reached at <cvs_login>@pld-linux.org
+
+$Log$
This page took 0.061319 seconds and 4 git commands to generate.