]> git.pld-linux.org Git - packages/apache-mod_epp.git/blob - apache-mod_epp.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/apache-mod_epp.git] / apache-mod_epp.spec
1 # TODO:
2 # - example/minimal configuration file
3 %define         mod_name        epp
4 %define         apxs            /usr/sbin/apxs
5 Summary:        An EPP (Extensible Provisioning Protocol) implementation for Apache2
6 Summary(pl.UTF-8):      Implementacja EPP (Extensible Provisioning Protocol) dla Apache2
7 Name:           apache-mod_%{mod_name}
8 Version:        1.10
9 Release:        0.2
10 License:        Apache
11 Group:          Networking/Daemons/HTTP
12 Source0:        http://downloads.sourceforge.net/aepps/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  1418187bf2b478ef2769271000f2b2c8
14 Source1:        http://downloads.sourceforge.net/aepps/epp-erd-20030122.tar.gz
15 # Source1-md5:  3d7720410e83fe6e90742119892011e2
16 URL:            http://aepps.sourceforge.net/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2.0.43
19 BuildRequires:  rpm-perlprov
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 Requires:       apache(modules-api) = %apache_modules_api
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
26
27 %description
28 This Apache 2.0 module implements the EPP over TCP protocol as defined
29 in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
30 of draft-ietf-provreg-epp-0(6|7).txt.
31
32 This is *not* a full implementation of EPP, this module just makes it
33 possible to write an EPP server as a set of CGI scripts.
34
35 %description -l pl.UTF-8
36 Ten moduł Apache 2.0 jest implementacją protokołu EPP po TCP zgodną z
37 dokumentem draft-ietf-provreg-epp-tcp-05.txt oraz częściami
38 dotyczącymi zarządzania sesją z draft-ietf-provreg-epp-0(6|7).txt.
39
40 *Nie* jest to pełna implementacja EPP, ten moduł jedynie umożliwia
41 pisanie serwera EPP jako zestawu skryptów CGI.
42
43 %prep
44 %setup -q -n mod_%{mod_name}-%{version} -a1
45
46 %build
47 %{apxs} -c mod_%{mod_name}.c
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
52
53 libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
54 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
55
56 install -p epptelnet.pl $RPM_BUILD_ROOT%{_bindir}
57 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
60         $RPM_BUILD_ROOT%{_sysconfdir}/68_mod_%{mod_name}.conf
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %service -q httpd restart
67
68 %postun
69 if [ "$1" = "0" ]; then
70         %service -q httpd restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README TODO epp-erd*
76 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
77 %attr(755,root,root) %{_pkglibdir}/*.so
78 %attr(755,root,root) %{_bindir}/*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.06274 seconds and 3 git commands to generate.