]> git.pld-linux.org Git - packages/apache-mod_dbi_pool.git/blob - apache-mod_dbi_pool.spec
- URL, descs, fixed -devel dep
[packages/apache-mod_dbi_pool.git] / apache-mod_dbi_pool.spec
1
2 %define         mod_name        dbi_pool
3 %define         apxs            /usr/sbin/apxs
4 Summary:        mod_dbi_pool - Pool Database connections between modules and requests
5 Summary(pl):    mod_dbi_pool - po³±czenia bazowanowe miêdzy modu³ami i ¿±daniami
6 Name:           apache-mod_%{mod_name}
7 Version:        0.4.0
8 Release:        1
9 License:        GPL
10 Group:          Networking/Daemons
11 Source0:        http://www.outoforder.cc/downloads/mod_dbi_pool/mod_%{mod_name}-%{version}.tar.bz2
12 # Source0-md5:  7fd42e90358b370eafdddf1f7252a65e
13 URL:            http://www.outoforder.cc/projects/apache/mod_dbi_pool/
14 BuildRequires:  %{apxs}
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  apache-devel
18 BuildRequires:  libdbi-devel
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 Requires(post,preun):   %{apxs}
22 Requires:       apache
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
26
27 %description
28 mod_dbi_pool provides database connection pooling services for other
29 Apache Modules. Using libdbi it allows other modules to have a dynamic
30 pool of database connections for many common SQL Servers, including
31 mSQL, MySQL, PostgreSQL, Oracle and SQLite.
32
33 %description -l pl
34 mod_dbi_pool dostarcza us³ugi utrzymywania puli po³±czeñ z baz± danych
35 dla innych modu³ów Apache'a. Poprzez u¿ycie libdbi umo¿liwia innym
36 modu³om posiadanie dynamicznej puli po³±czeñ z baz± danych dla wielu
37 popularnych serwerów SQL, w tym mSQL, MySQL, PostgreSQL, Oracle i
38 SQLite.
39
40 %package devel
41 Summary:        Header files for mod_dbi_pool API
42 Summary(pl):    Pliki nag³ówkowe dla API mod_dbi_pool
43 Group:          Development/Libraries
44 Requires:       apache-devel = %{version}-%{release}
45
46 %description devel
47 Header files for mod_dbi_pool API.
48
49 %description devel -l pl
50 Pliki nag³ówkowe dla API mod_dbi_pool.
51
52 %prep
53 %setup -q -n mod_%{mod_name}-%{version}
54
55 %build
56 %{__libtoolize}
57 %{__aclocal} -I m4
58 %{__autoconf}
59 %{__automake}
60 %configure \
61         --with-apxs=%{apxs}
62 %{__make}
63 %{__make} -C src make_so
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_includedir}/apache}
68
69 install src/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
70
71 install include/mod_dbi_pool.h $RPM_BUILD_ROOT%{_includedir}/apache
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
78 if [ -f /var/lock/subsys/httpd ]; then
79         /etc/rc.d/init.d/httpd restart 1>&2
80 fi
81
82 %preun
83 if [ "$1" = "0" ]; then
84         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
85         if [ -f /var/lock/subsys/httpd ]; then
86                 /etc/rc.d/init.d/httpd restart 1>&2
87         fi
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_pkglibdir}/*.so
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_includedir}/apache/*.h
This page took 0.039225 seconds and 4 git commands to generate.