]> git.pld-linux.org Git - packages/apache-mod_cfg_ldap.git/blob - apache-mod_cfg_ldap.spec
fb39649ea0dfc91da763c968b277c34fd2aadb1d
[packages/apache-mod_cfg_ldap.git] / apache-mod_cfg_ldap.spec
1 %define         mod_name        cfg_ldap
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to keep Apache VirtualHost configuration in an LDAP directory
4 Summary(pl):    Modu³ do przechowywania konfiguracji serwerów wirtualnych Apache'a w katalogu LDAP
5 Name:           apache-mod_%{mod_name}
6 Version:        1.2
7 Release:        3
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/modcfgldap/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  055924d6488608f684b22e7b04cea2ea
12 URL:            http://modcfgldap.sourceforge.net/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0
15 BuildRequires:  db-devel >= 4.2.52
16 BuildRequires:  openldap-devel >= 2.3.0
17 Requires:       apache(modules-api) = %apache_modules_api
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
22
23 %description
24 mod_cfg_ldap allows you to keep your virtual host configuration in a
25 LDAP directory and update it in nearly realtime.
26
27 %description -l pl
28 mod_cfg_ldap pozwala na przechowywanie konfiguracji hostów wirtualnych
29 w katalogu LDAP i uaktualnianie jej prawie w czasie rzeczywistym.
30
31 %prep
32 %setup -q -n mod_%{mod_name}-%{version}
33
34 %build
35 %{__make} all \
36         APXS=%{apxs}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
41
42 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
43 install cfg_ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/85_mod_cfg_ldap.conf
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 if [ -f /var/lock/subsys/httpd ]; then
50         /etc/rc.d/init.d/httpd restart 1>&2
51 fi
52
53 %postun
54 if [ "$1" = "0" ]; then
55         if [ -f /var/lock/subsys/httpd ]; then
56                 /etc/rc.d/init.d/httpd restart 1>&2
57         fi
58 fi
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS ChangeLog INSTALL README TODO *.schema
63 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
64 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.074644 seconds and 2 git commands to generate.