]> git.pld-linux.org Git - packages/apache-mod_auth_radius.git/blob - apache-mod_auth_radius.spec
- initial
[packages/apache-mod_auth_radius.git] / apache-mod_auth_radius.spec
1 %define         apxs            %{_sbindir}/apxs
2 Summary:        RADIUS authentication module for the Apache 2 webserver
3 Summary(pl.UTF-8):      Moduł uwierzytelniający RADIUS dla serwera WWW Apache 2
4 Name:           apache-mod_auth_radius
5 Version:        1.5.8
6 Release:        1
7 License:        Apache-like
8 Group:          Networking/Daemons/HTTP
9 Source0:        ftp://ftp.freeradius.org/pub/freeradius/mod_auth_radius-%{version}.tar
10 # Source0-md5:  87d8ef049736254cc09f8b34667f0e59
11 Patch0:         %{name}-apache.patch
12 Patch1:         %{name}-conf.patch
13 URL:            http://www.freeradius.org/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2.4
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires:       apache(modules-api) = %apache_modules_api
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
22
23 %description
24 This is the Apache RADIUS authentication module. It allows any Apache
25 web-server to become a RADIUS client for authentication and accounting
26 requests. You will, however, need to supply your own RADIUS server to
27 perform the actual authentication.
28
29 %description -l pl.UTF-8
30 Ten pakiet zawiera moduł uwierzytelniający RADIUS dla serwera WWW
31 Apache. Pozwala dowolnemu serwerowi Apache stać się klientem RADIUS na
32 potrzeby żądań uwierzytelniania i rozliczania. Aby wykonywać właściwe
33 uwierzytelnianie potrzebny jest własny serwer RADIUS.
34
35 %prep
36 %setup -q -n mod_auth_radius-%{version}
37 %patch0 -p1
38 %patch1 -p1
39
40 %build
41 %{apxs} -c -o mod_auth_radius.so mod_auth_radius-2.0.c
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
46
47 install -p .libs/mod_auth_radius.so $RPM_BUILD_ROOT%{_pkglibdir}
48 cp -p httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_auth_radius.conf
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %service -q httpd restart
55
56 %postun
57 if [ "$1" = "0" ]; then
58         %service -q httpd restart
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README htaccess index.html
64 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/90_mod_auth_radius.conf
65 %attr(755,root,root) %{_pkglibdir}/mod_auth_radius.so
This page took 0.112981 seconds and 3 git commands to generate.