]> git.pld-linux.org Git - packages/anaconda.git/commitdiff
- 11.4.1.27
authorPatryk Zawadzki <patrys@room-303.com>
Wed, 27 Aug 2008 00:06:09 +0000 (00:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- not tested at all (yet)

Changed files:
    anaconda-branding.patch -> 1.7
    anaconda-libdir.patch -> 1.7
    anaconda-pld-release.patch -> 1.6
    anaconda-timezone.patch -> 1.6
    anaconda.spec -> 1.84

anaconda-branding.patch
anaconda-libdir.patch
anaconda-pld-release.patch
anaconda-timezone.patch
anaconda.spec

index c07497bf75978e3df2ce894e128404bb361c2c71..5d9b7431e8cdbb49e53944e393ed35f7731cc3e4 100644 (file)
@@ -1,12 +1,13 @@
 --- anaconda-11.2.0.24.org/product.py  2006-05-08 22:22:44.000000000 +0200
 +++ anaconda-11.2.0.24/product.py      2007-02-20 19:14:33.134623000 +0100
-@@ -23,11 +23,11 @@
+@@ -29,11 +29,11 @@
+ else:
      path = None
-     
 -productStamp = ""
 -productName = "anaconda"
 -productVersion = "bluesky"
--productPath = "anaconda"
+-productPath = "Packages"
 +productStamp = "pld"
 +productName = "PLD Linux Distribution"
 +productVersion = "3.0 (Th)"
  
  if path is not None:
      f = open(path, "r")
---- anaconda-11.2.0.24.org/iutil.py    2007-01-15 20:42:54.000000000 +0100
-+++ anaconda-11.2.0.24/iutil.py        2007-02-20 19:14:46.322623000 +0100
-@@ -421,7 +421,7 @@
-     rhpl.arch.canonArch = myarch            
-         
-     f = open("%s/etc/rpm/platform" %(root,), 'w+')
--    f.write("%s-redhat-linux\n" %(myarch,))
-+    f.write("%s-pld-linux\n" %(myarch,))
-     f.close()
-     # FIXME: writing /etc/rpm/macros feels wrong somehow
index 5463a3df8e299ea840b5b899d0b08c5943b67a25..83a52c1eaf414b3ac35c8c41a8dc25654381b55e 100644 (file)
 diff -ur anaconda-11.2.0.24/anaconda anaconda-11.2.0.24/anaconda
 --- anaconda-11.2.0.24/anaconda        2007-02-01 23:55:38.000000000 +0100
 +++ anaconda-11.2.0.24/anaconda        2007-02-20 18:15:06.726623000 +0100
-@@ -147,17 +142,7 @@
-                          "/tmp/updates/%s/%s" %(pypkg, f))
-       # get the libdir.  *sigh*
--      if os.access("/usr/lib64/python%s/site-packages/%s" %(pyver, pypkg),
--                   os.X_OK):
--          libdir = "lib64"
--        elif os.access("/usr/lib/python%s/site-packages/%s" %(pyver, pypkg),
--                       os.X_OK):
--          libdir = "lib"
--      else:
--            # If the directory doesn't exist, there's nothing to link over.
--            # This happens if we forgot to include one of the above packages
--            # in the image, for instance.
--            continue
-+      libdir = sys.lib
-       if os.access("/tmp/updates/%s" %(pypkg,), os.X_OK):
-           for f in os.listdir("/usr/%s/python%s/site-packages/%s" %(libdir,
-@@ -303,15 +288,15 @@
-         sys.path.append('textw')
-         sys.path.append('iw')
-     else:
--        sys.path.append('/usr/lib/anaconda')
--        sys.path.append('/usr/lib/anaconda/textw')
--        sys.path.append('/usr/lib/anaconda/iw')
-+        sys.path.append('/usr/%s/anaconda' % sys.lib)
-+        sys.path.append('/usr/%s/anaconda/textw' % sys.lib)
-+        sys.path.append('/usr/%s/anaconda/iw' % sys.lib)
+@@ -358,19 +358,19 @@
+                 break
+         if haveUpdates:
+-            sys.path.insert(ndx+1, '/usr/lib/anaconda')
+-            sys.path.insert(ndx+2, '/usr/lib/anaconda/textw')
+-            sys.path.insert(ndx+3, '/usr/lib/anaconda/iw')
++            sys.path.insert(ndx+1, '/usr/%s/anaconda' % sys.lib)
++            sys.path.insert(ndx+2, '/usr/%s/anaconda/textw' % sys.lib)
++            sys.path.insert(ndx+3, '/usr/%s/anaconda/iw' % sys.lib)
+         else:
+-            sys.path.insert(0, '/usr/lib/anaconda')
+-            sys.path.insert(1, '/usr/lib/anaconda/textw')
+-            sys.path.insert(2, '/usr/lib/anaconda/iw')
++            sys.path.insert(0, '/usr/%s/anaconda' % sys.lib)
++            sys.path.insert(1, '/usr/%s/anaconda/textw' % sys.lib)
++            sys.path.insert(2, '/usr/%s/anaconda/iw' % sys.lib)
  
      if (os.path.exists('booty')):
          sys.path.append('booty')
@@ -53,10 +41,10 @@ diff -ur anaconda-11.2.0.24/anaconda anaconda-11.2.0.24/anaconda
  
      sys.path.append('/usr/share/system-config-date')
  
-@@ -390,7 +375,7 @@
+@@ -446,7 +446,7 @@
+     child = os.fork()
      if child == 0:
-         for p in ('/mnt/source/RHupdates/pyrc.py', \
-                 '/tmp/updates/pyrc.py', \
+         for p in ('/tmp/updates/pyrc.py', \
 -                '/usr/lib/anaconda-runtime/pyrc.py'):
 +                '/usr/%s/anaconda-runtime/pyrc.py' % sys.lib):
              if os.access(p, os.R_OK|os.X_OK):
@@ -179,9 +167,9 @@ diff -ur anaconda-11.2.0.24/language.py anaconda-11.2.0.24/language.py
              if os.access(path, os.R_OK):
                  f = open(path, 'r')
 @@ -72,7 +73,7 @@
+         
          # nick -> (name, short name, font, keyboard, timezone) mapping
-         search = ('lang-table', '/tmp/updates/lang-table',
-                   '/mnt/source/RHupdates/lang-table', '/etc/lang-table',
+         search = ('lang-table', '/tmp/updates/lang-table', '/etc/lang-table',
 -                  '/usr/lib/anaconda/lang-table')
 +                  '/usr/%s/anaconda/lang-table' % sys.lib)
          for path in search:
@@ -199,18 +187,3 @@ diff -ur anaconda-11.2.0.24/loader2/loader.c anaconda-11.2.0.24/loader2/loader.c
          setenv("LD_LIBRARY_PATH", LIBPATH, 1);
          setenv("LANG", "C", 1);
          
-diff -ur anaconda-11.2.0.24/scripts/pkgorder anaconda-11.2.0.24/scripts/pkgorder
---- anaconda-11.2.0.24/scripts/pkgorder        2007-01-30 23:26:15.000000000 +0100
-+++ anaconda-11.2.0.24/scripts/pkgorder        2007-02-20 18:17:08.462623000 +0100
-@@ -18,8 +18,8 @@
- import sys
- import yum
--sys.path.append("/usr/lib/anaconda")
--sys.path.append("/usr/lib/booty")
-+sys.path.append("/usr/%s/anaconda" % sys.lib)
-+sys.path.append("/usr/%s/booty" % sys.lib)
- import anaconda_log
- import logging
-
index fc810d29dfc0694b84266d231bf207a0f99fe699..9b6290676c9daa1013bdca50cb8059075495c594 100644 (file)
@@ -41,46 +41,6 @@ diff -ur anaconda-11.2.0.24.org/partedUtils.py anaconda-11.2.0.24/partedUtils.py
          return relstr
      return ""
  
-diff -ur anaconda-11.2.0.24.org/scripts/pkgorder anaconda-11.2.0.24/scripts/pkgorder
---- anaconda-11.2.0.24.org/scripts/pkgorder    2007-02-20 18:23:45.538623000 +0100
-+++ anaconda-11.2.0.24/scripts/pkgorder        2007-02-20 18:28:05.766623000 +0100
-@@ -107,10 +107,10 @@
- def createConfig(toppath):
-     yumconfstr = """
- [main]
--distroverpkg=redhat-release
-+distroverpkg=issue
- gpgcheck=0
- reposdir=/dev/null
--exclude=*debuginfo*
-+exclude=vserver-packages *debuginfo*
- [anaconda]
- name=Anaconda
-diff -ur anaconda-11.2.0.24.org/scripts/splittree.py anaconda-11.2.0.24/scripts/splittree.py
---- anaconda-11.2.0.24.org/scripts/splittree.py        2006-12-13 16:55:23.000000000 +0100
-+++ anaconda-11.2.0.24/scripts/splittree.py    2007-02-20 18:27:17.982623000 +0100
-@@ -99,7 +99,7 @@
-         self.src_list = []
-         self.shared_list = []
-         self.reverse_sort_srpms=None
--        self.common_files = ['beta_eula.txt', 'EULA', 'README', 'GPL', 'RPM-GPG-KEY', 'RPM-GPG-KEY-beta', 'RPM-GPG-KEY-fedora']
-+        self.common_files = ['beta_eula.txt', 'EULA', 'README', 'GPL', 'RPM-GPG-KEY', 'RPM-GPG-KEY-beta', 'RPM-GPG-KEY-PLD']
-         self.logfile = []
-diff -ur anaconda-11.2.0.24.org/scripts/yumcache anaconda-11.2.0.24/scripts/yumcache
---- anaconda-11.2.0.24.org/scripts/yumcache    2007-01-30 22:55:56.000000000 +0100
-+++ anaconda-11.2.0.24/scripts/yumcache        2007-02-20 18:24:43.130623000 +0100
-@@ -24,7 +24,7 @@
-         self.yumconfstr = """
- [main]
--distroverpkg=redhat-release
-+distroverpkg=issue
- cachedir=%s
- gpgcheck=0
 diff -ur anaconda-11.2.0.24.org/yuminstall.py anaconda-11.2.0.24/yuminstall.py
 --- anaconda-11.2.0.24.org/yuminstall.py       2007-02-13 14:56:08.000000000 +0100
 +++ anaconda-11.2.0.24/yuminstall.py   2007-02-20 18:26:50.814623000 +0100
index 7eea428d8eece2bc6cd652d20f51b8869eb49894..426ac449ba189a9be29f3b94aceac0fd21430ec5 100644 (file)
@@ -31,28 +31,24 @@ diff -ur anaconda-11.2.0.24.org/iw/timezone_gui.py anaconda-11.2.0.24/iw/timezon
 diff -ur anaconda-11.2.0.24.org/timezone.py anaconda-11.2.0.24/timezone.py
 --- anaconda-11.2.0.24.org/timezone.py 2007-01-17 23:49:50.000000000 +0100
 +++ anaconda-11.2.0.24/timezone.py     2007-02-20 19:07:07.498623000 +0100
-@@ -13,6 +13,7 @@
+@@ -19,6 +19,7 @@
  
  import shutil
  import iutil
 +import string
+ import os
  from flags import flags
  
- import logging
-@@ -44,12 +45,32 @@
+@@ -44,8 +45,29 @@
  
        f = open(instPath + "/etc/sysconfig/clock", "w")
  
 -      f.write('ZONE="%s"\n' % self.tz)
 +      f.write('# Should the hardware clock be kept in Coordinated Universal Time (instead of local time).\n')
-       f.write("UTC=%s\n" % bool(self.utc))
 +      f.write('# true means your machine uses epoch 1980 in its hardware clock\n')
-       f.write("ARC=%s\n" % bool(self.arc))
--
 +      f.write('# true means your machine uses epoch 1900 in its hardware clock\n')
 +      f.write("SRM=false\n")
        f.close()
 +      # FIXME: solution for timezones like EET
 +      (area, zone) = string.split(self.tz, "/")
 +
@@ -70,7 +66,8 @@ diff -ur anaconda-11.2.0.24.org/timezone.py anaconda-11.2.0.24/timezone.py
 +      f.write('# Name of the time zone for your system.\n')
 +      f.write('TIME_ZONE="%s"\n' % zone)
 +      f.write("\n");
-+
++      f.close()
      def getTimezoneInfo(self):
        return (self.tz, self.utc, self.arc)
+
index 8d160382648959237501ed2dbcedb01172ed8b91..5cdc8461b93decf81153b6a6bc1e4e60139effa9 100644 (file)
 Summary:       Graphical system installer
 Summary(pl.UTF-8):     Graficzny instalator systemu
 Name:          anaconda
-Version:       11.4.0.10
+Version:       11.4.1.27
 Release:       0.1
 License:       GPL
 Group:         Applications/System
 Source0:       %{name}-%{version}.tar.bz2
-# Source0-md5: 875574321cf9795f853db61fb05ed7ff
+# Source0-md5: 31614b29612f2a5c6ff87a1eb88224e3
 Source1:       %{name}-mk-images
 Source2:       %{name}-upd-instroot
 Source3:       %{name}-mk-images.i386
@@ -55,20 +55,21 @@ Source5:    %{name}-installclass-pld.py
 Source6:       %{name}-splash.png
 # Source6-md5: 6b38a868585adfd3a96a4ad16973c1f8
 Patch0:                %{name}-pld.patch
+Patch1:                %{name}-warnings.patch
 Patch2:                %{name}-vserver-proc.patch
-Patch3:                %{name}-pkgorder.patch
+#Patch3:               %{name}-pkgorder.patch
 Patch4:                %{name}-errorhandling.patch
 Patch5:                %{name}-libdir.patch
 Patch6:                %{name}-pld-release.patch
 Patch7:                %{name}-timezone.patch
-Patch8:                %{name}-kernel.patch
+#Patch8:               %{name}-kernel.patch
 Patch9:                %{name}-optflags.patch
 Patch10:       %{name}-network.patch
 Patch11:       %{name}-branding.patch
 Patch13:       %{name}-installclasses.patch
 Patch14:       %{name}-release_notes_viewer_gui.patch
 Patch15:       %{name}-hosttree.patch
-Patch16:       %{name}-popt.patch
+#Patch16:      %{name}-popt.patch
 URL:           http://fedoraproject.org/wiki/Anaconda
 BuildRequires: bzip2-devel
 BuildRequires: device-mapper-static >= 1.01.05
@@ -82,13 +83,14 @@ BuildRequires:      kudzu-devel >= 1.2.68
 BuildRequires: libdhcp-devel
 BuildRequires: libdhcp-static
 BuildRequires: libdhcp4client-devel
-BuildRequires: libdhcp6client-static
-BuildRequires: libnl-static
-BuildRequires: libselinux-static >= 1.6
-BuildRequires: libsepol-static
+BuildRequires: libdhcp6client-devel
+BuildRequires: libnl-devel
+BuildRequires: libselinux-devel >= 1.6
+BuildRequires: libsepol-devel
 BuildRequires: newt-static
 BuildRequires: popt-static
 BuildRequires: python-devel
+BuildRequires: python-kickstart >= 1.42
 BuildRequires: python-rhpl
 BuildRequires: python-rpm
 BuildRequires: rpm-pythonprov
@@ -113,7 +115,7 @@ Requires:   python-bdevid >= 6.0.24
 Requires:      python-booty >= 0.93
 Requires:      python-dbus
 Requires:      python-devel-tools
-Requires:      python-kickstart >= 1.23
+Requires:      python-kickstart >= 1.42
 Requires:      python-libuser
 Requires:      python-libxml2
 Requires:      python-parted >= 1.8.9
@@ -210,14 +212,15 @@ Kod źródłowy Anacondy do celów diagnostycznych.
 %setup -q
 # looks obsolete
 #%patch0 -p1
+%patch1 -p1
 #%patch2 -p1
-%patch3 -p1
+#%patch3 -p1
 # obsolete, all parts merged
 #%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
+#%patch8 -p1
 # fixme
 #%patch9 -p1
 # obsolete, already merged
@@ -229,7 +232,7 @@ Kod źródłowy Anacondy do celów diagnostycznych.
 #%patch14 -p1
 # does it make any harm?
 #%patch15 -p1
-%patch16 -p1
+#%patch16 -p1
 
 rm -f po/no.po
 mv -f po/{eu_ES,eu}.po
@@ -314,7 +317,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/showpart
 %dir %{_libdir}/anaconda
 %{_libdir}/anaconda/*.py[co]
-%exclude %{_libdir}/anaconda/xsetup.py[co]
 %dir %{_libdir}/anaconda/installclasses
 %{_libdir}/anaconda/installclasses/*.py[co]
 %{_libdir}/anaconda/installclasses/*.py
@@ -329,7 +331,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/mini-wm
 %attr(755,root,root) %{_libdir}/anaconda/xutils.so
 %{_desktopdir}/liveinst.desktop
-%{_libdir}/anaconda/xsetup.py[co]
 %dir %{_libdir}/anaconda/iw
 %{_libdir}/anaconda/iw/*.py[co]
 %{_datadir}/anaconda
@@ -348,19 +349,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/anaconda/*-stub
 %dir %{_libdir}/anaconda-runtime
 %dir %{_libdir}/anaconda-runtime/boot
-%attr(755,root,root) %{_libdir}/anaconda-runtime/boot/syslinux.cfg
 %{_libdir}/anaconda-runtime/boot/boot.msg
 %{_libdir}/anaconda-runtime/boot/general.msg
+%{_libdir}/anaconda-runtime/boot/grub.conf
 %{_libdir}/anaconda-runtime/boot/options.msg
 %{_libdir}/anaconda-runtime/boot/param.msg
 %{_libdir}/anaconda-runtime/boot/rescue.msg
+%{_libdir}/anaconda-runtime/boot/syslinux.cfg
 %attr(755,root,root) %{_libdir}/anaconda-runtime/buildinstall
-%attr(755,root,root) %{_libdir}/anaconda-runtime/filtermoddeps
-%attr(755,root,root) %{_libdir}/anaconda-runtime/fixmtime.py
+%attr(755,root,root) %{_libdir}/anaconda-runtime/buildinstall.functions
 %attr(755,root,root) %{_libdir}/anaconda-runtime/genmodinfo
 %attr(755,root,root) %{_libdir}/anaconda-runtime/getkeymaps
 %{_libdir}/anaconda-runtime/keymaps-override-*
-%attr(755,root,root) %{_libdir}/anaconda-runtime/libunicode-lite.so.1
 %dir %{_libdir}/anaconda-runtime/loader
 %attr(755,root,root) %{_libdir}/anaconda-runtime/loader/init
 %attr(755,root,root) %{_libdir}/anaconda-runtime/loader/loader
@@ -373,23 +373,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.alpha
 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.i386
 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.ia64
+%attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.efi
 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.ppc
 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.s390
 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.x86
-%attr(755,root,root) %{_libdir}/anaconda-runtime/mk-rescueimage.i386
-%attr(755,root,root) %{_libdir}/anaconda-runtime/mk-rescueimage.ia64
-%attr(755,root,root) %{_libdir}/anaconda-runtime/mk-rescueimage.ppc
-%attr(755,root,root) %{_libdir}/anaconda-runtime/mk-rescueimage.x86_64
-%attr(755,root,root) %{_libdir}/anaconda-runtime/moddeps
 %attr(755,root,root) %{_libdir}/anaconda-runtime/modlist
-%attr(755,root,root) %{_libdir}/anaconda-runtime/pkgorder
 %attr(755,root,root) %{_libdir}/anaconda-runtime/pyrc.py
 %attr(755,root,root) %{_libdir}/anaconda-runtime/readmap
 %attr(755,root,root) %{_libdir}/anaconda-runtime/scrubtree
 %{_libdir}/anaconda-runtime/screenfont-*.gz
-%attr(755,root,root) %{_libdir}/anaconda-runtime/splittree.py
-%attr(755,root,root) %{_libdir}/anaconda-runtime/trimmodalias
 %attr(755,root,root) %{_libdir}/anaconda-runtime/trimpciids
 %attr(755,root,root) %{_libdir}/anaconda-runtime/upd-instroot
 %attr(755,root,root) %{_libdir}/anaconda-runtime/upd-updates
-%attr(755,root,root) %{_libdir}/anaconda-runtime/yumcache
This page took 0.072344 seconds and 4 git commands to generate.