]> git.pld-linux.org Git - packages/alex.git/blob - alex.spec
- converted to UTF-8
[packages/alex.git] / alex.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # use foreign (non-rpm) ghc
4 #
5 Summary:        A lexical analyser generator for Haskell
6 Summary(pl.UTF-8):   Generator analizatorów składniowych dla Haskella
7 Name:           alex
8 Version:        2.0.1
9 Release:        3
10 License:        BSD-like w/o adv. clause
11 Group:          Development/Tools
12 Source0:        http://www.haskell.org/alex/dist/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  edb62560e29c8de23913c65c52adbf19
14 Patch0:         %{name}-DESTDIR.patch
15 URL:            http://www.haskell.org/alex/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  docbook-dtd31-sgml
19 BuildRequires:  docbook-style-dsssl
20 %{!?with_bootstrap:BuildRequires:       ghc >= 5.04}
21 BuildRequires:  gmp-devel
22 BuildRequires:  jadetex
23 BuildRequires:  openjade
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  tetex-dvips
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Alex is a tool for generating lexical analysers in Haskell, given a
30 description of the tokens to be recognised in the form of regular
31 expressions. It is similar to the tool lex or flex for C/C++.
32
33 %description -l pl.UTF-8
34 Alex to narzędzie do generowania analizatorów składniowych w Haskellu
35 na podstawie opisu tokenów do rozpoznawania w postaci wyrażeń
36 regularnych. Jest podobne do narzędzi lex lub flex dla C/C++.
37
38 %prep
39 %setup -q
40
41 sed -i -e 's/\(alpha\*\|powerpc\|powerpc64\)-unknown-linux\*)/\1-*-linux*)/' configure.ac
42
43 %build
44 %{__aclocal}
45 %{__autoconf}
46 cp -f /usr/share/automake/config.sub .
47 %configure
48 %{__make} depend
49 %{__make}
50 %{__make} html -C alex/doc
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
55
56 %{__make} install \
57         bindir=$RPM_BUILD_ROOT%{_bindir} \
58         libdir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
59
60 cp -a alex/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc alex/{ANNOUNCE,LICENSE,README} alex/doc/alex
68 %attr(755,root,root) %{_bindir}/*
69 %dir %{_libdir}/%{name}-%{version}
70 %{_libdir}/%{name}-%{version}/A*
71 %attr(755,root,root) %{_libdir}/%{name}-%{version}/alex.bin
72 %{_examplesdir}/%{name}-%{version}
This page took 0.07535 seconds and 3 git commands to generate.