]> git.pld-linux.org Git - packages/aegisub.git/commitdiff
- rel 20, add bost 1.81 patch from https://github.com/void-linux/void-packages/blob... auto/th/aegisub-3.2.2-20
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 22 Feb 2023 21:21:20 +0000 (22:21 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 22 Feb 2023 21:21:20 +0000 (22:21 +0100)
aegisub.spec
boost181.patch [new file with mode: 0644]

index 94510580a0fe1ee154a610b2dd085e6e1e8865a2..bae69c04cae5a29fd5f2193861cf8d60757cb45d 100644 (file)
@@ -14,13 +14,14 @@ Summary:    Subtitle editor
 Summary(pl.UTF-8):     Edytor napisów
 Name:          aegisub
 Version:       3.2.2
-Release:       19
+Release:       20
 License:       BSD
 Group:         X11/Applications
 #Source0:      http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
 Source0:       https://github.com/Aegisub/Aegisub/archive/%{snap}/%{name}-%{version}-%{snap}.tar.gz
 # Source0-md5: ecb9b5441ead4135c9b1baec0abdec49
 Patch0:                make-4.3.patch
+Patch1:                boost181.patch
 URL:           http://www.aegisub.org/
 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
 #BuildRequires:        OpenAL-devel >= 0.0.8
@@ -87,6 +88,7 @@ obsługa tych zaawansowanych funkcji.
 %prep
 %setup -q -n Aegisub-%{gitrev}
 %patch0 -p1
+%patch1 -p1
 
 cat <<'EOF' >build/git_version.h
 #define BUILD_GIT_VERSION_NUMBER 9010
diff --git a/boost181.patch b/boost181.patch
new file mode 100644 (file)
index 0000000..a62c965
--- /dev/null
@@ -0,0 +1,65 @@
+Index: Aegisub-3.3.2/src/command/video.cpp
+===================================================================
+--- Aegisub-3.3.2.orig/src/command/video.cpp
++++ Aegisub-3.3.2/src/command/video.cpp
+@@ -475,7 +475,7 @@ static void save_snapshot(agi::Context *
+               // If where ever that is isn't defined, we can't save there
+               if ((basepath == "\\") || (basepath == "/")) {
+                       // So save to the current user's home dir instead
+-                      basepath = wxGetHomeDir().c_str();
++                      basepath = static_cast<const char *>(wxGetHomeDir().c_str());
+               }
+       }
+       // Actual fixed (possibly relative) path, decode it
+Index: Aegisub-3.3.2/src/dialog_attachments.cpp
+===================================================================
+--- Aegisub-3.3.2.orig/src/dialog_attachments.cpp
++++ Aegisub-3.3.2/src/dialog_attachments.cpp
+@@ -161,7 +161,7 @@ void DialogAttachments::OnExtract(wxComm
+       // Multiple or single?
+       if (listView->GetNextSelected(i) != -1)
+-              path = wxDirSelector(_("Select the path to save the files to:"), to_wx(OPT_GET("Path/Fonts Collector Destination")->GetString())).c_str();
++              path = static_cast<const char*>(wxDirSelector(_("Select the path to save the files to:"), to_wx(OPT_GET("Path/Fonts Collector Destination")->GetString())).c_str());
+       else {
+               path = SaveFileSelector(
+                       _("Select the path to save the file to:"),
+Index: Aegisub-3.3.2/libaegisub/include/libaegisub/lua/utils.h
+===================================================================
+--- Aegisub-3.3.2.orig/libaegisub/include/libaegisub/lua/utils.h
++++ Aegisub-3.3.2/libaegisub/include/libaegisub/lua/utils.h
+@@ -27,6 +27,7 @@
+ #include <boost/exception/detail/attribute_noreturn.hpp>
+ #define BOOST_NORETURN BOOST_ATTRIBUTE_NORETURN
+ #endif
++#include <boost/flyweight.hpp>
+ namespace agi { namespace lua {
+ // Exception type for errors where the error details are on the lua stack
+@@ -91,6 +92,13 @@ void set_field(lua_State *L, const char
+       lua_setfield(L, -2, name);
+ }
++template<>
++inline void set_field(lua_State *L, const char *name,
++             boost::flyweights::flyweight<std::string> value) {
++      push_value(L, value.get());
++      lua_setfield(L, -2, name);
++}
++
+ template<int (*func)(lua_State *L)>
+ void set_field(lua_State *L, const char *name) {
+       push_value(L, exception_wrapper<func>);
+Index: Aegisub-3.3.2/src/auto4_lua.cpp
+===================================================================
+--- Aegisub-3.3.2.orig/src/auto4_lua.cpp
++++ Aegisub-3.3.2/src/auto4_lua.cpp
+@@ -119,7 +119,7 @@ namespace {
+       int get_translation(lua_State *L)
+       {
+               wxString str(check_wxstring(L, 1));
+-              push_value(L, _(str).utf8_str());
++              push_value(L, static_cast<const char *>(_(str).utf8_str()));
+               return 1;
+       }
This page took 0.08266 seconds and 4 git commands to generate.