]> git.pld-linux.org Git - packages/aegisub.git/blob - aegisub.spec
- release 10, rebuild against icu 64, boost 1.70
[packages/aegisub.git] / aegisub.spec
1 # TODO
2 # - unvendor vendor/luabins
3 # - unvendor vendor/luajit
4 # - unvendor vendor/universalchardet
5 # - our cxxflags
6
7 # Conditional build:
8 %bcond_without  ffms2   # build ffms2 A/V provider
9
10 Summary:        Subtitle editor
11 Summary(pl.UTF-8):      Edytor napisów
12 Name:           aegisub
13 Version:        3.2.2
14 Release:        10
15 License:        BSD
16 Group:          X11/Applications
17 Source0:        http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  d80e852c34811add358c06d77f5cd40d
19 Patch0:         pthread.patch
20 Patch1:         %{name}-icu.patch
21 Patch2:         %{name}-icu64.patch
22 Patch3:         %{name}-boost-1.70.patch
23 URL:            http://www.aegisub.net/
24 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
25 #BuildRequires: OpenAL-devel >= 0.0.8
26 BuildRequires:  OpenGL-devel
27 BuildRequires:  alsa-lib-devel
28 BuildRequires:  autoconf >= 2.57
29 BuildRequires:  automake
30 BuildRequires:  boost-devel >= 1.50.0
31 %{?with_ffms2:BuildRequires:    ffms2-devel >= 2.16}
32 BuildRequires:  fftw3-devel >= 3.3
33 BuildRequires:  fontconfig-devel >= 1:2.4
34 # pkgconfig(freetype2) >= 9.7.0
35 BuildRequires:  freetype-devel >= 1:2.1.9
36 BuildRequires:  gettext-tools
37 BuildRequires:  hunspell-devel >= 1.2.0
38 BuildRequires:  intltool
39 BuildRequires:  libass-devel >= 0.9.7
40 BuildRequires:  libicu-devel >= 4.8.1.1
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  lua51-devel
43 BuildRequires:  pkgconfig >= 1:0.20
44 BuildRequires:  portaudio-devel >= 19
45 BuildRequires:  pulseaudio-devel >= 0.5
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  wxGTK2-unicode-gl-devel >= 3.0.0
48 BuildRequires:  wxWidgets-devel >= 3.0.0
49 BuildRequires:  xz
50 BuildRequires:  zlib-devel
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  gtk-update-icon-cache
53 Requires:       ffms2 >= 2.16
54 Requires:       fftw3 >= 3.3
55 Requires:       fontconfig-libs >= 1:2.4
56 Requires:       freetype >= 1:2.1.9
57 Requires:       hunspell >= 1.2.0
58 Requires:       libass >= 0.9.7
59 Requires:       libicu >= 4.8.1.1
60 Requires:       pulseaudio-libs >= 0.5
61 # due to luajit usage
62 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
63 # missing atomic_ops
64 ExcludeArch:    i386 i486
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 Aegisub is an advanced subtitle editor for Windows, and UNIX-like
69 systems, such as Linux, Mac OS X and BSD. It is open source software
70 and free for any use.
71
72 Aegisub natively works with the Advanced SubStation Alpha format
73 (aptly abbreviated ASS) which allows for many advanced effects in the
74 subtitles, apart from just basic timed text. Aegisubs goal is to
75 support using these advanced functions with ease.
76
77 %description -l pl.UTF-8
78 Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
79 uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
80 otwartych źródłach, darmowy do dowolnego użytku.
81
82 Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
83 stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
84 napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
85 obsługa tych zaawansowanych funkcji.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 %patch3 -p1
93
94 %{__mv} vendor{,.keep}
95 mkdir vendor
96 %{__mv} vendor.keep/{luabins,luajit,universalchardet} vendor
97
98 %build
99 %configure \
100         --disable-update-checker \
101         %{__with_without ffms2} \
102         --without-oss \
103         --with-player-audio=PulseAudio \
104         --with-wx-config=wx-gtk2-unicode-config
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 ln -s %{name}-3.2 $RPM_BUILD_ROOT%{_bindir}/%{name}
114
115 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
116 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
117 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
118 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
119 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
120
121 %find_lang %{name}-32
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %update_desktop_database
128 %update_icon_cache hicolor
129
130 %postun
131 %update_desktop_database
132 %update_icon_cache hicolor
133
134 %files -f %{name}-32.lang
135 %defattr(644,root,root,755)
136 %doc LICENCE README.md
137 %attr(755,root,root) %{_bindir}/%{name}
138 %attr(755,root,root) %{_bindir}/%{name}-3.2
139 %{_datadir}/%{name}
140 %{_desktopdir}/%{name}.desktop
141 %{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.071362 seconds and 3 git commands to generate.