]> git.pld-linux.org Git - packages/accelio.git/blob - accelio.spec
c7e309791f0962b6abc96a7613c381946954001e
[packages/accelio.git] / accelio.spec
1 # TODO:
2 # - kernel modules (BR: OFED kernel headers)
3 #
4 # Conditional build:
5 %bcond_without  fio             # FIO module
6 %bcond_with     kernel          # kernel modules
7 %bcond_without  static_libs     # static libraries
8 #
9 Summary:        Open Source I/O, Message and RPC Acceleration library
10 Summary(pl.UTF-8):      Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
11 Name:           accelio
12 Version:        1.7
13 Release:        3
14 License:        BSD
15 Group:          Libraries
16 #Source0Download: https://github.com/accelio/accelio/releases
17 Source0:        https://github.com/accelio/accelio/archive/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  b363e15ea8f7dac2179a610c1393a624
19 Patch0:         %{name}-fio.patch
20 Patch1:         %{name}-sse.patch
21 URL:            http://www.accelio.org/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake >= 1:1.11
24 %{?with_fio:BuildRequires:      fio-devel >= 2.19}
25 BuildRequires:  libaio-devel
26 BuildRequires:  libevent-devel >= 2
27 BuildRequires:  libibverbs-devel
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  numactl-devel
30 BuildRequires:  sed >= 4.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Accelio provides an easy-to-use, reliable, scalable, and high
35 performance data/message delivery middleware that maximizes the
36 efficiency of modern CPU and NIC hardware and that reduces
37 time-to-market of new scale-out applications.
38
39 %description -l pl.UTF-8
40 Accelio dostarcza łatwą w użyciu, wiarygodną, skalowalną i szybką
41 warstwę pośrednią przekazującą dane i komunikaty, maksymalizującą
42 wydajność współczesnych CPU i NIC, zmniejszającą czas potrzebny
43 na wytworzenie nowych aplikacji.
44
45 %package devel
46 Summary:        Header files for Accelio libraries
47 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Accelio
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for Accelio libraries.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe bibliotek Accelio.
56
57 %package static
58 Summary:        Static Accelio libraries
59 Summary(pl.UTF-8):      Statyczne biblioteki Accelio
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static Accelio libraries.
65
66 %description static -l pl.UTF-8
67 Statyczne biblioteki Accelio.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 %{__sed} -i -e 's/-Werror //' configure.ac
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__automake}
81 for d in src/kernel/xio examples/kernel/hello_world examples/kernel/hello_world_mt tests/kernel/hello_test examples/raio/kernel/nbdx ; do
82 cd $d
83 %{__autoconf}
84 cd -
85 done
86 %configure \
87         %{?with_fio:FIO_ROOT=%{_includedir}/fio} \
88         --disable-silent-rules \
89         %{!?with_static_libs:--disable-static} \
90         %{?with_fio:--enable-fio-build} \
91         %{?with_kernel:--enable-kernel-module}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # fio module, .la is useless
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libraio_fio.la
102 # test program
103 %{__rm} $RPM_BUILD_ROOT%{_bindir}/event_loop_tests
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS COPYING ChangeLog NEWS README README.md
114 %attr(755,root,root) %{_bindir}/raio_client
115 %attr(755,root,root) %{_bindir}/raio_server
116 %attr(755,root,root) %{_bindir}/reg_basic_mt
117 %attr(755,root,root) %{_bindir}/xio_*
118 %attr(755,root,root) %{_bindir}/xioclntd
119 %attr(755,root,root) %{_bindir}/xiosrvd
120 %attr(755,root,root) %{_libdir}/libraio.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libraio.so.0
122 %if %{with fio}
123 %attr(755,root,root) %{_libdir}/libraio_fio.so
124 %endif
125 %attr(755,root,root) %{_libdir}/libxio.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libxio.so.0
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libraio.so
131 %attr(755,root,root) %{_libdir}/libxio.so
132 %{_libdir}/libraio.la
133 %{_libdir}/libxio.la
134 %{_includedir}/libraio.h
135 %{_includedir}/libxio.h
136 %{_includedir}/xio_base.h
137 %{_includedir}/xio_predefs.h
138 %{_includedir}/xio_user.h
139
140 %if %{with static_libs}
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libraio.a
144 %{_libdir}/libxio.a
145 %endif
This page took 0.058315 seconds and 2 git commands to generate.