]> git.pld-linux.org Git - packages/ZoneAdmin.git/blob - ZoneAdmin.spec
d24a80f35d6d53d9e2556e33ecd11ec74450ce2a
[packages/ZoneAdmin.git] / ZoneAdmin.spec
1 Summary:        A Web-based administration interface for powerDNS
2 Name:           ZoneAdmin
3 Version:        0.2
4 Release:        0.1
5 License:        GPL
6 Group:          Applications/WWW
7 Source0:        http://dl.sourceforge.net/zoneadmin/%{name}-%{version}-beta1.tar.gz
8 # Source0-md5:  a848e14d947d41734d8a23d72d0196da
9 URL:            http://open.megabit.net/index.php?section=pro_home&project=ZoneAdmin
10 BuildRequires:  rpmbuild(macros) >= 1.268
11 Requires:       Smarty >= 2.6.18-2
12 Requires:       webapps
13 Requires:       webserver(php)
14 %if %{with trigger}
15 Requires(triggerpostun):        sed >= 4.0
16 %endif
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _webapps        /etc/webapps
21 %define         _webapp         %{name}
22 %define         _sysconfdir     %{_webapps}/%{_webapp}
23 %define         _appdir         %{_datadir}/%{_webapp}
24
25 %description
26 ZoneAdmin is a Web interface for the powerDNS name server using the
27 MySQL backend. It allows you to manage existing zones and add, remove,
28 and alter new ones, supports on-the-fly input validation, and allows
29 comments per zone and per record. Furthermore, it keeps a detailed
30 history of changes and allows you to temporary enable or disable zones
31 without having to remove them completely. New zones can use templates
32 that contain predefined records. It is designed to be used with one of
33 Apache's authentication methods.
34
35 %prep
36 %setup -q -n %{name}-%{version}-beta1
37
38 cat > apache.conf <<'EOF'
39 Alias /%{name} %{_appdir}
40 <Directory %{_appdir}>
41         Allow from all
42 </Directory>
43 EOF
44
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
47
48 install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
49 install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
50 install *.php   $RPM_BUILD_ROOT%{_appdir}
51 cp -a {contrib,img,includes,lang,templates_c,tpl}       $RPM_BUILD_ROOT%{_appdir}
52 mv $RPM_BUILD_ROOT%{_appdir}/includes/config.php.dist $RPM_BUILD_ROOT%{_sysconfdir}/config.php
53 ln -s %{_sysconfdir}/config.php         $RPM_BUILD_ROOT%{_appdir}/includes/config.php
54
55 %triggerin -- apache1 < 1.3.37-3, apache1-base
56 %webapp_register apache %{_webapp}
57
58 %triggerun -- apache1 < 1.3.37-3, apache1-base
59 %webapp_unregister apache %{_webapp}
60
61 %triggerin -- apache < 2.2.0, apache-base
62 %webapp_register httpd %{_webapp}
63
64 %triggerun -- apache < 2.2.0, apache-base
65 %webapp_unregister httpd %{_webapp}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %dir %attr(750,root,http) %{_sysconfdir}
73 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
74 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
75 %attr(660,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
76 %{_appdir}/*.php
77 %dir %{_appdir}/contrib
78 %{_appdir}/contrib/*.php
79 %{_appdir}/contrib/*.sql
80 %dir %{_appdir}/img
81 %{_appdir}/img/*.gif
82 %{_appdir}/img/*.png
83 %dir %{_appdir}/includes
84 %{_appdir}/includes/*.php
85 %dir %{_appdir}/includes/smarty/libs/
86 %{_appdir}/includes/smarty/libs/*.php
87 %{_appdir}/includes/smarty/libs/*.tpl
88 %dir %{_appdir}/includes/smarty/libs/internals
89 %{_appdir}/includes/smarty/libs/internals/*.php
90 %dir %{_appdir}/includes/smarty/libs/plugins
91 %{_appdir}/includes/smarty/libs/plugins/*.php
92 %dir %{_appdir}/includes/smarty_plugins
93 %{_appdir}/includes/smarty_plugins/*.php
94 %dir %{_appdir}/lang
95 %{_appdir}/lang/*.conf
96 %dir %{_appdir}/templates_c
97 %dir %{_appdir}/tpl/Boxes
98 %{_appdir}/tpl/Boxes/*.css
99 %{_appdir}/tpl/Boxes/*.js
100 %{_appdir}/tpl/Boxes/*.tpl
101 %dir %{_appdir}/tpl/Boxes/img
102 %{_appdir}/tpl/Boxes/img/*.jpg
103 %{_appdir}/tpl/Boxes/img/*.gif
104 %dir %attr(770,root,http) %{_appdir}/templates_c
This page took 0.093868 seconds and 2 git commands to generate.