]> git.pld-linux.org Git - packages/TiMidity++.git/commitdiff
- added patch to alsaseq server interace that stops in loop polling(saves power/batte...
authorKrzysztof Krakowiak <evil@pld-linux.org>
Thu, 16 Dec 2010 12:38:24 +0000 (12:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    TiMidity++-stop_polling.patch -> 1.1
    TiMidity++.spec -> 1.90

TiMidity++-stop_polling.patch [new file with mode: 0644]
TiMidity++.spec

diff --git a/TiMidity++-stop_polling.patch b/TiMidity++-stop_polling.patch
new file mode 100644 (file)
index 0000000..35c2b66
--- /dev/null
@@ -0,0 +1,34 @@
+--- TiMidity++-2.13.2/interface/alsaseq_c.c.orig       2010-12-16 13:26:54.000000000 +0100
++++ TiMidity++-2.13.2/interface/alsaseq_c.c    2010-12-16 14:15:24.486618509 +0100
+@@ -505,6 +505,8 @@
+ static void doit(struct seq_context *ctxp)
+ {
++      fd_set rfds;
++      struct timeval timeout;
+       for (;;) {
+               while (snd_seq_event_input_pending(ctxp->handle, 1)) {
+                       if (do_sequencer(ctxp))
+@@ -532,15 +534,17 @@
+                       play_event(&ev);
+                       aq_fill_nonblocking();
+               }
+-              if (! ctxp->active || ! IS_STREAM_TRACE) {
+-                      fd_set rfds;
+-                      struct timeval timeout;
+-                      FD_ZERO(&rfds);
+-                      FD_SET(ctxp->fd, &rfds);
++              
++              FD_ZERO(&rfds);
++              FD_SET(ctxp->fd, &rfds);
++              if (ctxp->active) {
+                       timeout.tv_sec = 0;
+                       timeout.tv_usec = 10000; /* 10ms */
+                       if (select(ctxp->fd + 1, &rfds, NULL, NULL, &timeout) < 0)
+                               goto __done;
++              } else {
++                      if (select(ctxp->fd + 1, &rfds, NULL, NULL, NULL) < 0)
++                              goto __done;
+               }
+       }
index 3cce5898722a075a7cae1ae4530a8ad9e345f410..b0c9412efbbb8d3382d6fc5d0c400b3f3f82fef2 100644 (file)
@@ -15,7 +15,7 @@ Summary(ru.UTF-8):    Проигрыватель MIDI файлов и конвер
 Summary(uk.UTF-8):     Програвач MIDI-файлів та конвертор їх в WAV формат
 Name:          TiMidity++
 Version:       2.13.2
-Release:       5
+Release:       6
 License:       GPL
 Group:         Applications/Sound
 Source0:       http://dl.sourceforge.net/timidity/%{name}-%{version}.tar.bz2
@@ -32,6 +32,7 @@ Source6:      timidity.sysconfig
 Patch0:                %{name}-detach.patch
 Patch1:                %{name}-gcc4.patch
 Patch2:                %{name}-configure.patch
+Patch3:                %{name}-stop_polling.patch
 URL:           http://timidity.sourceforge.net/
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    arts-devel}
@@ -233,6 +234,7 @@ jako silnik syntezatora MIDI w architekturze ALSA.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
+%patch3 -p1
 
 for f in doc/ja_JP.eucJP/README*; do
        mv -f $f ${f}.ja
This page took 0.36197 seconds and 4 git commands to generate.