]> git.pld-linux.org Git - packages/SuperLU.git/commitdiff
- added missing patches (-Werror=format-security fix, shared library) auto/th/SuperLU-4.3-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 29 May 2015 17:37:25 +0000 (19:37 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 29 May 2015 17:37:25 +0000 (19:37 +0200)
SuperLU-format.patch [new file with mode: 0644]
SuperLU-shared.patch [new file with mode: 0644]
SuperLU.spec

diff --git a/SuperLU-format.patch b/SuperLU-format.patch
new file mode 100644 (file)
index 0000000..9bd353c
--- /dev/null
@@ -0,0 +1,11 @@
+--- SuperLU_4.3/SRC/util.c.orig        2011-10-27 21:49:47.000000000 +0200
++++ SuperLU_4.3/SRC/util.c     2015-05-22 23:11:04.981981786 +0200
+@@ -29,7 +29,7 @@
+ void superlu_abort_and_exit(char* msg)
+ {
+-    fprintf(stderr, msg);
++    fputs(msg, stderr);
+     exit (-1);
+ }
diff --git a/SuperLU-shared.patch b/SuperLU-shared.patch
new file mode 100644 (file)
index 0000000..f77d99e
--- /dev/null
@@ -0,0 +1,65 @@
+--- SuperLU_4.3/SRC/Makefile.orig      2011-10-27 21:49:47.000000000 +0200
++++ SuperLU_4.3/SRC/Makefile   2015-05-28 18:50:54.792861306 +0200
+@@ -111,7 +111,19 @@
+       ilu_zcolumn_dfs.o ilu_zpanel_dfs.o ilu_zcopy_to_ucol.o \
+       ilu_zpivotL.o zdiagonal.o
+-all:    single double complex complex16
++ALL_SRC = \
++      $(SLUSRC) $(SLASRC) $(SCLAUX) \
++      $(DLUSRC) $(DLASRC) $(DZLAUX) \
++      $(CLUSRC) $(CLASRC) \
++      $(ZLUSRC) $(ZLASRC) \
++      $(ALLAUX) $(LAAUX)
++
++ALL_LO = $(ALL_SRC:.o=.lo)
++
++all: $(SUPERLULIB)
++
++$(SUPERLULIB): $(ALL_LO)
++      libtool --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -o $(SUPERLULIB) $(ALL_LO) $(BLASLIB) -lm -rpath $(libdir)
+ single: $(SLUSRC) $(ALLAUX) $(LAAUX) $(SLASRC) $(SCLAUX)
+       $(ARCH) $(ARCHFLAGS) $(SUPERLULIB) \
+@@ -140,13 +152,22 @@
+ slamch.o: slamch.c ; $(CC) -c $(NOOPTS) $(CDEFS) $<
+ dlamch.o: dlamch.c ; $(CC) -c $(NOOPTS) $(CDEFS) $<
+ superlu_timer.o:  superlu_timer.c ; $(CC) -c $(NOOPTS) $<
++slamch.lo: slamch.c ; $(LIBTOOL) --mode=compile $(CC) -c $(NOOPTS) $(CDEFS) $<
++dlamch.lo: dlamch.c ; $(LIBTOOL) --mode=compile $(CC) -c $(NOOPTS) $(CDEFS) $<
++superlu_timer.lo:  superlu_timer.c ; $(LIBTOOL) --mode=compile $(CC) -c $(NOOPTS) $<
+ ##################################
+ .c.o:
+       $(CC) $(CFLAGS) $(CDEFS) $(BLASDEF) -c $< $(VERBOSE)
++%.lo: %.c
++      $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(CDEFS) $(BLASDEF) -c $< $(VERBOSE)
++
+ .f.o:
+       $(FORTRAN) $(FFLAGS) -c $<
++%.lo: %.f
++      $(LIBTOOL) --mode=compile $(FORTRAN) $(FFLAGS) -c $<
++
+ clean:        
+       rm -f *.o $(SUPERLULIB)
+--- SuperLU_4.3/make.inc.orig  2011-12-12 23:34:18.000000000 +0100
++++ SuperLU_4.3/make.inc       2015-05-28 18:50:53.759528016 +0200
+@@ -22,7 +22,7 @@
+ #  The name of the libraries to be created/linked to
+ #
+ SuperLUroot   = $(HOME)/Codes/SuperLU/SuperLU_4.3
+-SUPERLULIB    = $(SuperLUroot)/lib/libsuperlu_4.3.a
++SUPERLULIB    = $(SuperLUroot)/lib/libsuperlu.la
+ TMGLIB        = libtmglib.a
+ ## BLASLIB    = $(SuperLUroot)/lib/libblas.a
+@@ -44,6 +44,7 @@
+ ARCH         = ar
+ ARCHFLAGS    = cr
+ RANLIB       = ranlib
++LIBTOOL      = libtool
+ CC           = gcc
+ CFLAGS       = -DPRNTlevel=0 -O3
index e3fa2ef121d5f41ecb8902856d414199af57ccdf..02f4507a3a593301021b6e5bd31f1ec0d22626e2 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Subroutines to solve a sparse linear system A*X=B
 Summary(pl.UTF-8):     Procedury do rozwiązywania rzadkich układów równań liniowych A*X=B
 Name:          SuperLU
 Version:       4.3
-Release:       1
+Release:       2
 License:       BSD
 Group:         Libraries
 Source0:       http://crd-legacy.lbl.gov/~xiaoye/SuperLU/superlu_%{version}.tar.gz
This page took 0.137094 seconds and 4 git commands to generate.