]> git.pld-linux.org Git - packages/SDL_sound.git/commitdiff
- added physfs patch (adjust for physfs 3 API)
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 28 Dec 2020 18:30:23 +0000 (19:30 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 28 Dec 2020 18:30:23 +0000 (19:30 +0100)
SDL_sound-physfs.patch [new file with mode: 0644]
SDL_sound.spec

diff --git a/SDL_sound-physfs.patch b/SDL_sound-physfs.patch
new file mode 100644 (file)
index 0000000..d34f3d1
--- /dev/null
@@ -0,0 +1,38 @@
+--- SDL_sound-1.0.3/playsound/physfsrwops.h.orig       2008-04-17 19:56:21.000000000 +0200
++++ SDL_sound-1.0.3/playsound/physfsrwops.h    2020-12-28 19:11:16.822650378 +0100
+@@ -39,7 +39,7 @@
+  *  @return A valid SDL_RWops structure on success, NULL on error. Specifics
+  *           of the error can be gleaned from PHYSFS_getLastError().
+  */
+-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
++PHYSFS_DECL SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
+ /**
+  * Open a platform-independent filename for writing, and make it accessible
+@@ -51,7 +51,7 @@
+  *  @return A valid SDL_RWops structure on success, NULL on error. Specifics
+  *           of the error can be gleaned from PHYSFS_getLastError().
+  */
+-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
++PHYSFS_DECL SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
+ /**
+  * Open a platform-independent filename for appending, and make it accessible
+@@ -63,7 +63,7 @@
+  *  @return A valid SDL_RWops structure on success, NULL on error. Specifics
+  *           of the error can be gleaned from PHYSFS_getLastError().
+  */
+-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
++PHYSFS_DECL SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
+ /**
+  * Make a SDL_RWops from an existing PhysicsFS file handle. You should
+@@ -75,7 +75,7 @@
+  *  @return A valid SDL_RWops structure on success, NULL on error. Specifics
+  *           of the error can be gleaned from PHYSFS_getLastError().
+  */
+-__EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
++PHYSFS_DECL SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
+ #ifdef __cplusplus
+ }
index a341f28e54e3f3ac209c3d21a44e8b1bccaf41e8..611060f5110f55226129d62be23414396d85589b 100644 (file)
@@ -7,6 +7,7 @@ License:        LGPL v2.1+
 Group:         Libraries
 Source0:       http://www.icculus.org/SDL_sound/downloads/%{name}-%{version}.tar.gz
 # Source0-md5: aa09cd52df85d29bee87a664424c94b5
+Patch0:                %{name}-physfs.patch
 URL:           http://www.icculus.org/SDL_sound/
 BuildRequires: SDL-devel >= 1.2.6
 BuildRequires: autoconf
@@ -16,7 +17,7 @@ BuildRequires:        libmikmod-devel >= 3.1.5
 BuildRequires: libmodplug-devel
 BuildRequires: libvorbis-devel >= 1:1.0-6
 BuildRequires: libtool
-BuildRequires: physfs-devel >= 1.0.1
+BuildRequires: physfs-devel >= 3
 BuildRequires: smpeg-devel >= 0.4.4-12
 BuildRequires: speex-devel
 Requires:      SDL >= 1.2.6
@@ -81,8 +82,9 @@ Statyczne biblioteki SDL_sound.
 
 %prep
 %setup -q
+%patch0 -p1
 
-rm acinclude.m4
+%{__rm} acinclude.m4
 
 %build
 %{__libtoolize}
This page took 0.078319 seconds and 4 git commands to generate.