]> git.pld-linux.org Git - packages/RakNet.git/blob - RakNet.spec
- BR: gcc-c++ (those are c++ files, but they don't use libstdc++)
[packages/RakNet.git] / RakNet.spec
1 # NOTE
2 # - RakNet 3.x is available, but it is not under GPL License
3 # - fix linking
4 # - SONAME lost?
5 #
6 %define         ver     %(echo %{version} | tr . _)
7 Summary:        Networking engine for game programmers
8 Summary(pl.UTF-8):      Silnik sieciowy dla programistów gier
9 Name:           RakNet
10 Version:        2.0
11 Release:        0.1
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        http://www.sumwars.org/data/Raknet%{ver}.tar.gz
15 # Source0-md5   bfdc95cf31d1381fb97631a3f07bc6c8
16 Patch0:         %{name}-destdir.patch
17 Patch1:         %{name}-flags.patch
18 URL:            http://www.jenkinssoftware.com/
19 BuildRequires:  gcc-c++
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.553
22 BuildRequires:  sed >= 4.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 RakNet is open source, networking engine for game programmers.
27
28 %description -l pl.UTF-8
29 RakNet jest otwartym, sieciowym silnikiem dla programistów gier.
30
31 %package devel
32 Summary:        Header files for RakNet library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki RakNet
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for RakNet library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki RakNet.
42
43 %prep
44 %setup -q -n Raknet%{ver}
45 %undos Makefile Source/Makefile Source/RakVoice/Makefile
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 %{__make} -j1 \
51         CC="%{__cc}" \
52         CFLAGS="%{rpmcflags} -fPIC" \
53         LDFLAGS="%{rpmldflags}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %{__make} -j1 install \
58         LIBS_DIR="%{_libdir}" \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(755,root,root) %{_libdir}/libraknet.so.*.*.*
70 #%attr(755,root,root) %ghost %{_libdir}/libraknet.so.2
71 %attr(755,root,root) %{_libdir}/librakvoice.so.*.*.*
72 #%attr(755,root,root) %ghost %{_libdir}/librakvoice.so.2
73
74 %files devel
75 %defattr(644,root,root,755)
76 %{_includedir}/raknet
77 %{_libdir}/libraknet.so
78 %{_libdir}/librakvoice.so
79 %{_pkgconfigdir}/RakNet.pc
This page took 0.082837 seconds and 3 git commands to generate.