]> git.pld-linux.org Git - packages/LiVES.git/blob - LiVES.spec
- s/CHANGELOG/ChangeLog/
[packages/LiVES.git] / LiVES.spec
1
2 # TODO
3 # - some platform-independent left in %{_libdir}
4
5 %define         _sname          lives
6
7 Summary:        LiVES - the Linux Video Editing System
8 Summary(pl.UTF-8):      LiVES - Linuksowy System Edycji Video
9 Name:           LiVES
10 Version:        0.9.8.3
11 Release:        0.1
12 License:        GPL v2
13 Group:          X11/Applications/Multimedia
14 Source0:        http://www.xs4all.nl/%7Esalsaman/lives/current/%{name}-%{version}.tar.bz2
15 # Source0-md5:  16f280b01fc426981494e03d4671488a
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-FHS.patch
18 Patch1:         %{name}-automake.patch
19 URL:            http://www.xs4all.nl/~salsaman/lives/
20 BuildRequires:  SDL-devel
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  gettext-devel >= 0.14.1
24 BuildRequires:  gtk+2-devel >= 2.0.0
25 BuildRequires:  libtheora-devel
26 BuildRequires:  libtool
27 BuildRequires:  libvisual-devel
28 BuildRequires:  mjpegtools-devel
29 BuildRequires:  pkgconfig
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  xorg-util-imake
32 Requires:       %{name}-plugins = %{version}-%{release}
33 Requires:       ImageMagick >= 5
34 Requires:       ffmpeg
35 Requires:       mplayer >= 0.90rc1
36 Requires:       ogmtools
37 Requires:       perl-base
38 Requires:       python >= 1:2.3
39 Requires:       sox
40 Requires:       transcode
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # workaround for the next change
44 %define         _localedir      %{_usr}/share/locale
45 # platform-dependent plugins in %{_datadir}
46 %define         _datadir        %{_libdir}
47 %define         _themesdir      %{_datadir}/%{_sname}/themes
48 # shared objects without .so (e.g. SDL), which we don't want to provide
49 %define         _noautoprovfiles        ^%{_datadir}/%{_sname}/.*
50
51 %description
52 LiVES began as the Linux Video Editing System. Since it now runs on
53 more operating systems, LiVES is a Video Editing System. It is
54 designed to be simple to use, yet powerful. It is small in size, yet
55 it has many advanced features.
56
57 %description -l pl.UTF-8
58 LiVES zaczynał jako Linuksowy System Edycji Video. Obecnie można
59 również uruchomić go na większej liczbie systemów operacyjnych.
60 Zaprojektowany został tak, by być zarówno prostym w użyciu jak i mimo
61 niewielkiego rozmiaru posiadać zaawansowane funkcje.
62
63 %package plugins
64 Summary:        Plugins for LiVES
65 Summary(pl.UTF-8):      Wtyczki dla LiVES
66 Group:          X11/Applications/Multimedia
67 Requires:       %{name} = %{version}-%{release}
68
69 %description plugins
70 Plugins for LiVES.
71
72 %description plugins -l pl.UTF-8
73 Wtyczki (plugins) dla LiVES.
74
75 %package themes
76 Summary:        Themes for LiVES
77 Summary(pl.UTF-8):      Motywy dla LiVES
78 Group:          Themes/GTK+
79 Requires:       %{name} = %{version}-%{release}
80
81 %description themes
82 Themes for LiVES.
83
84 %description themes -l pl.UTF-8
85 Motywy dla LiVES.
86
87 %prep
88 %setup -qn %{_sname}-%{version}
89 %patch0 -p1
90 %patch1 -p1
91
92 # wrrr
93 sed -i -e 's,/share/,/%{_lib}/,' po/pxgettext po/make_rfx_builtin_list.pl
94
95 %build
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__automake}
99 # hack: DATADIRNAME defined too late in configure
100 %configure \
101         DATADIRNAME=share
102 %{__make} \
103         CFLAGS="%{rpmcflags} -fPIC"
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_desktopdir}
108 install -d $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
109 for i in lives-plugins/plugins/effects/RFXscripts/*.script ; do
110         ./build-lives-rfx-plugin $i $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
111 done
112
113 # hack: override localedir because of redefined datadir
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         localedir=%{_localedir}
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119 mv $RPM_BUILD_ROOT%{_docdir}/%{_sname}-%{version} \
120         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
121
122 mv -f $RPM_BUILD_ROOT%{_localedir}/{cz,cs}
123 mv -f $RPM_BUILD_ROOT%{_localedir}/nl{_NL,}
124
125 %find_lang %{_sname}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files -f %{_sname}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED NEWS RFX OMC
133 %attr(755,root,root) %{_bindir}/*
134 %dir %{_datadir}/%{_sname}
135 %{_datadir}/%{_sname}/icons
136 %{_datadir}/%{_sname}/default.keymap
137 %{_desktopdir}/%{name}.desktop
138 %dir %{_themesdir}
139 %{_themesdir}/default
140
141 %files themes
142 %defattr(644,root,root,755)
143 %{_themesdir}/camera
144 %{_themesdir}/cutting_room
145 %{_themesdir}/greenish
146 %{_themesdir}/pinks
147 %{_themesdir}/sunburst
148 %{_themesdir}/editor
149
150 %files plugins
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_datadir}/%{_sname}/plugins
This page took 0.137036 seconds and 4 git commands to generate.